XBMC Community Forum

Full Version: No more 'audio passthrough' options?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Using a nightly build to get xbmc to work on mavericks, I notice that when I go to system, ssystem, audio output I am no longer able to setup receiver options. I need this because mp3 audio from tvshows is not working and I remember having to change something there in previous versions.

How do I get these options back? Output is set to hdmi.
Make sure you have advanced or expert settings enabled. Using the confluence skin, go into settings. Toggle left and you can access the tiers from the side menu bar.
yep, just found that out. turns out the settings are like they should, but I seem to be unable to get audio from movies/shows that have mp3 audio. Others work fine. When I play these files from vlc, the audio is just fine. What am I missing here?
I haven't tried it on Mavericks, but I suspect passthrough may be broken via HDMI?

Try Analog as the output, default audio device. Disable all *** capable receiver options.
I managed to get audio from mp3 encoded files by setting speakers to 2.0 and disabling lpcm. Any idea if this affectsnmy movies? Will my dts/ac3 movies still output surround sound when using this?
It should still output the same....I think.

Have you messed with your Audio MIDI settings in OSX? Do you have it set to 2 channel or 8? You might try experimenting with those settings in conjunction with the ones in XBMC.
Definitely something still broken with HDMI passthrough. I played a video with Dolby Digital that worked fine. But when I switched to one with DTS, I couldn't get a signal. Optical cable works fine though.

I also noticed a problem with audio channel mapping on a DTS 5.1 soundtrack with passthrough HDMI output. I don't think the center channel was working at all. Once again, optical worked fine.

And I thought the build I was using fixed the channel mapping? I'll stick with optical for now.
(2013-10-30 18:15)lapino Wrote: [ -> ]Using a nightly build to get xbmc to work on mavericks, I notice that when I go to system, ssystem, audio output I am no longer able to setup receiver options. I need this because mp3 audio from tvshows is not working and I remember having to change something there in previous versions.

How do I get these options back? Output is set to hdmi.

If you try with one of the 12.3 test builds is this still the case? (see http://forum.xbmc.org/showthread.php?tid=176721 ) I'm trying to see if this is a Mavericks issue or a nightly build issue, but I personally don't have any audio receivers right now.
(2013-10-31 03:28)beemarp Wrote: [ -> ]Definitely something still broken with HDMI passthrough. I played a video with Dolby Digital that worked fine. But when I switched to one with DTS, I couldn't get a signal. Optical cable works fine though.

I also noticed a problem with audio channel mapping on a DTS 5.1 soundtrack with passthrough HDMI output. I don't think the center channel was working at all. Once again, optical worked fine.

And I thought the build I was using fixed the channel mapping? I'll stick with optical for now.

This is on Mavericks with the special build mentioned in your signature?
Quote:This is on Mavericks with the special build mentioned in your signature?

This is on Snow Leopard with that special build. I also had issues with Mountain Lion too with HDMI passthrough. I thought it may have just been the operating system, but unfortunately not.

My config is Mac Mini HDMI --> Yamaha Receiver (5.1 surround) --> Sony LCD

I'll try the latest nightly this evening and see if it's still causing problems.
Still not working with latest test build. Problems with HDMI passthrough only when adjust refresh to display is enabled.
1. channel mapping doesn't have anything to do when using passthrough. It only affects the usage of lpcm.
2. the problem with audio and refreshrate adaption is known and there is no fix in sight for this unfortunately.

what always should work is still - 2.0 channels in osx-audio-midi-setup, 2.0 speaker setup in xbmc, enable dts and ac3 capable receiver, disable lpcm...
Thanks Memphiz, I'll try the work-around. I thought I had tried this already, but maybe just partially there ;-)
Well...it's still not working. Stereo pcm feeds work ok, but not dts or ac3 tracks. Audio midi set to 2.0, xbmc set to hdmi 2.0
Doesn't make Sense if you use passthrough ... No clue debug log
Pages: 1 2 3
Reference URL's