XBMC Community Forum

Full Version: [AppleTV] Launcher 3.2 testing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
Hi,

as some of you might know, Apple released a 3.0 software update for the ATV, which renders Launcher (< 3.2) unusable.

We've been working with the guys from awkwardtv.org (special thanks to |bile|, the guy that does nitoTV) to get something running and currently it looks like we got it working.

As pretty much noone tested this, please use this only if you're comfortable with the commandline, ssh and such. If you're not on 3.0 yet, you might want to wait until this is working properly and a new patchstick was made.

Source / changelog available on Launcher's googlecode page

Here we go:
1) "patchstick" the 3.0 ATV
2) ssh into it and download Launcher-3.2.beta3-debug.run
3) install Launcher chmod +x Launcher.. ; ./Launcher-3.2...
4) install XBMC with Launcher or just re-symlink your old install (ln -s /Users/frontrow/Applications/XBMC.app /Applications/XBMC.app)
5) test Wink

If something is broken, crashes, etc. please post in this thread and pastebin CrashReporter.log (~/Library/Logs/CrashReporter/CrashReporter.log) and console.log (/Library/Logs/Console/501/console.log).

Once you've got Launcher running, you can add an additional update source that will have the current testing version with:
Code:
defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array-add http://dl.getdropbox.com/u/858897/XBMC/update_urls.plist

Thanks and happy testing! Wink

Changelog:
alpha1:
- atv 3.0 compatibility
beta1:
- cleanup in update controller
- added images in Settings and Downloads
beta2:
- fixed crash when iPhone Remote App was used
- added: pass (some) iPhone Remote App gestures to XBMC (needs new keymapping in XBMC)
beta3:
- fixed: crash on ATV 3.01
- changed: if ATV version is unknown, default to most recent (3.01 in this case)

Edit1: updated to beta2, added update_urls.plist, changelog
Edit2: updated to beta3
Just a quick confirmation that it works Smile

- ATV 3.0
- created patchstick with 2.4
- r24122, manual install(nightly doesnt have 24148 for OSX)
- USB support - manual install
- AFP support - manual install

Thanks!

Zeljko
It works on my ATV.

I followed these steps:

1) upgrade to 3.0
2) patchstick using 3.0 dmg
3) install launcher 3.2 as above
4) download XBMC through launcher
5) run XBMC
It works for me. Everything (as far as XBMC goes) is up and running smoothly.

MaestroDD - much kudos on the help with the Launcher file. Smile
Confirmed working after inadvertent 3.0 update (knew I shoudda paid more attention...).
For anybody reading this that's not comfortable with command lines, this is an easy process, it took all of 2 minutes to do.

You should just use your old patchstick on the ATV, if you haven't used one before search on this forum for instructions. My old one from ATV v2.1 worked fine.

You should learn how to operate the ssh client, "putty.exe" (get it from here: http://www.chiark.greenend.org.uk/~sgtat...nload.html) is a good choice for Windows machines.

Use putty to connect to your ATV (you can see the IP address in the ATV system menu).

When they say "download launcher", copy this full address from the webpage: http://dl.getdropbox.com/u/858897/XBMC/L...-debug.run

Then type (no quotes) "wget http://dl.getdropbox.com/u/858897/XBMC/L...-debug.run"
Then type "chmod +x Launcher-3.2.alpha1-debug.run"
Then type "./Launcher-3.2.alpha1-debug.run" and enter the appropriate password (like it says, usually "frontrow") and answer "y" when it asks to restart the finder.
If you go back to your ATV now, there's a "Launcher" option. Go there, download XBMC, and follow all the usual prompts.

Voici, now you have XBMC back, running on your ATV 3.0. Thanks so much to everybody here for the help, and to the guys at akwardtv.
Suhweeet guys! Thank you! Up and running w/3.0 and XBMC and Alaska. I like the icon arrangement above the Launcher menu too. Looks classy!

One thing I ran into was my old reliable patchstick (running w/atvusb-creator-1.0.b10) did not initially work. I have not used it awhile so all I did was remake it with atvusb-creator-1.0.b10 again and the latest DMG I could find (2Z694-5789-067.dmg) and it worked (old patchstick had an old boot.efi maybe?).

Thanks for the extra and speedy effort. You guys rawk!
@bmartani Just wanted to say a huge thanks for posting your tutorial for us folks who aren't great when it comes to command lines! Worked perfect for me and happily have XBMC back on my ATV menu screen. Thanks again!
bmartani Wrote:When they say "download launcher", copy this full address from the webpage: http://dl.getdropbox.com/u/858897/XBMC/L...-debug.run

Uh, I'm sorry, I don't understand this one... (Newbie alert!) Nod

I D/L this onto my Mac, it's a script. I typed the filename into the Terminal as is, and it just says "No such file or directory"; I've SSH'd into my ATV, but I did put the path of the Mac before the filename...

Can you be a bit more specific into what EXACTLY step by step needs to be done?

Thanks!!!
mltobing, Amet, infohound112, tuckbodi thanks for testing and reporting back!

bmartani, as already mentioned in my first post, the version is not ready for public use, and only people who are comfortable with the command line should install it. We developers would be thankful, if you respected this. Please feel free to post a howto once we think this version is ready, although I don't think it'll be needed.
MaestroDD Wrote:and only people who are comfortable with the command line should install it.

Sorry!

Well, I figured out I was just to skip that line, and continue with the rest, and it worked properly out of an ATV v2.3.1 and Mac OS X Snow Leopard using Terminal.

Thanks a bunch!
MaestroDD Wrote:mltobing, Amet, infohound112, tuckbodi thanks for testing and reporting back!

bmartani, as already mentioned in my first post, the version is not ready for public use, and only people who are comfortable with the command line should install it. We developers would be thankful, if you respected this. Please feel free to post a howto once we think this version is ready, although I don't think it'll be needed.

NP Smile

A bit off topic if you dont mind,

when there is no OSX build on "Nightly" the launcher still shows the version number but fails as there is nothing to download. Sure, I know I can do it manually but couldn't we always download the latest version from the same place?
I realize that would have to be coordinated effort with TheQuestor, but would it be worth the effort?

Thanks for the quick fix.
Zeljko
Amet Wrote:[...]

when there is no OSX build on "Nightly" the launcher still shows the version number but fails as there is nothing to download. Sure, I know I can do it manually but couldn't we always download the latest version from the same place?
I realize that would have to be coordinated effort with TheQuestor, but would it be worth the effort?

IIRC there were already efforts to do something like this.
Easiest would probably be to kindly ask TheQuestor (->new thread) to change the way he publishes builds and to generate a new Info.asp only if a build was successful.
The instructions seemed perfectly clear to me but as I see others are getting confused this noob will try to clarify for others what to do.

Step 1. If you have not let your Apple TV update to 3.0 and want to try it you need to turn the updates back on and let it update. If you did a factory restore you need to have it update to 3.0, or if you are already at 3.0 read on.

Step 2. After it has updated to 3.0 apply your patchstick as normal, this is done to get SSH capability back.

Step 3. Log into your Apple TV via SSH using a tool like putty.exe, download link is here:
http://www.chiark.greenend.org.uk/~sgtat...nload.html

Step 4. Then type (no quotes) "wget http://dl.getdropbox.com/u/858897/XBMC/L...-debug.run"

Step 5. Then type (no quotes)"chmod +x Launcher-3.2.alpha1-debug.run"

Step 6. Then type (no quotes)"./Launcher-3.2.alpha1-debug.run" and enter the appropriate password (like it says, usually "frontrow") and answer "y" when it asks to restart the finder.

Go back to your ATV now, there should be a "Launcher" option. Download XBMC and install as usual. At this time it does not fix Boxee.

However DO NOT update Launcher as it will install version 3.1 and you will lose the "Launcher" options...yeah I learned that the hard way! ;-)
Works perfectly fine on my newly update 3.0, symbolic link old xbmc setup great too!
Many thanks.
Dean
update to beta1

changed:
- cleanup in update controller
- added images in Settings and Downloads

As a major problem with ATV updates is always screen release (meaning Finder doesn't let XBMC/Boxee come to front), testing this aspect would be nice. Disconnect TV, reconnect, XBMC still running, screensaver, etc.

new Launcher-3.2.beta1-debug.run

For in-Launcher updates, just add an additional update source with:
Code:
defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array-add http://dl.getdropbox.com/u/858897/XBMC/update_urls.plist

Thanks again for testing!

cheers,
mdd
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
Reference URL's