XBMC Community Forum
XBMC, lights and Tellstick. [Windows] - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Announcements, Info, and General Discussion (/forumdisplay.php?fid=85)
+--- Forum: Kodi General Discussion (/forumdisplay.php?fid=6)
+--- Thread: XBMC, lights and Tellstick. [Windows] (/showthread.php?tid=106481)



XBMC, lights and Tellstick. [Windows] - fiLLLip - 2011-07-28 23:57

Developed some small piece of software that will pull the videoplayer state from XBMC then command the Tellstick to turn on/off or dim lights

http://code.google.com/p/xbmc-light-controller/

Please feel free to try out ;-) This is an early stage since I created it today, but feel free to try!

This is supposed to run on Windows with Tellstick plugged in.

Only tested on Windows 7 with Telldus software against XBMC Live on remote computer.


- fiLLLip - 2011-10-31 14:17

Have released version 1.0.0.7

Please comment if you find it useful :-)


- fiLLLip - 2011-12-01 15:59

Have release new version: 1.0.0.8

This release has "Minimize to tray" so it won't be in your way while running. :-)


- unknown_inc - 2012-01-09 02:29

This doesn't work with Eden Beta 1. I found this guide though, works like a charm!

http://www.satheesh.net/2012/01/09/xbmc-lights/

Nod


- fiLLLip - 2012-01-11 12:13

Hmm, that sounds weird. I will download a copy of Eden Beta and test myself and see if any protocols have changed or anything Nerd

I use this every day myself and it works with stable release Smile

EDIT: http://wiki.xbmc.org/index.php?title=Eden_API_Changes
The JSON API has changed with Eden, rendering current release useless at time beeing. Will look into an automatic version compare with correct JSON commands later.


RE: XBMC, lights and Tellstick. [Windows] - fiLLLip - 2012-05-03 14:08

Hi again, I have now updated the piece of software to support XBMC Eden.

http://code.google.com/p/xbmc-light-controller/

Thank you for using this.


RE: XBMC, lights and Tellstick. [Windows] - n0ir - 2012-07-22 21:22

I only get this error message when I try to install this:

"Unable to install or run the application. The application requires that assembly Microsoft.VisualBasic.PowerPacks.Vs Version 10.0.0.0 be installed in the Global Assembly Cache (GAC) first."

I assume there is something else I need to install?