XBMC Community Forum
XBMC + Sickbeard/Couchpotato communication - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: XBMC + Sickbeard/Couchpotato communication (/showthread.php?tid=108779)



XBMC + Sickbeard/Couchpotato communication - Misterbashi - 2011-08-27 18:24

I'm having some trouble getting sickbeard to update XBMC, I have Sabnzbd on port 8080, sickbeard on 8081 and XBMC on 8082.

but when trying to send the 'update XBMC' command from Sickbeard I get a message saying 'unable to contact xbmc host'

I have tried using localhost:8082 and 'my IP':8082 in the sickbeard config but no joy.

Am I missing something obvious?

this is the last thing I need to do!

any help much appreciated


- gabbott - 2011-08-27 18:45

When you say XBMC is on 8082, you are referring to your xbmc client configured to listen on 8082, correct?


- jhsrennie - 2011-08-28 09:51

Grab a copy of curl from http://curl.haxx.se/download.html. Open a command prompt and type (or copy and paste):

Code:
curl "http://localhost:8082/xbmcCmds/xbmcHttp?command=ExecBuiltIn&parameter=XBMC.UpdateLibrary(video)"

Press Enter and see wat happens. If you get:

Code:
<html>
<li>OK
</html>

This means the command is working. Remember it only works when XBMC is running, and you need to go into System settings, Network, Services and enable "Allow control of XBMC via HTTP". You also need to make sure the username and password are both blank unless you can provide the username and password in Sickbeard.

JR


- Misterbashi - 2011-08-29 03:51

Thanks for the reply, I'm going to try this when I get home.

The port defined in XBMC is 8082, in system settings. I cannot see anywhere else where you can change this?

I have the "Allow control via HHTP" and "Allow control via UpNP" Enabled, so I will let you know the outcome.

Again, thanks for the fast help!


- feerlessleadr - 2011-08-29 05:20

you could try a couple of things that fixed the problem for me.

First, make sure that your ports are correctly forwarded on your router.

If you have a web interface selected, try and accessing it from a seperate pc not running xbmc (your_ip:8082). if you can't access it, then your problem may be that your xbmc settings aren't allowing communication by SB or CP.


- Misterbashi - 2011-08-30 16:45

quite strange, i removed the password and username from xbmc, but not sickbeard and now notifications work!


RE: XBMC + Sickbeard/Couchpotato communication - darkfreak - 2012-04-12 12:37

I have the exact same problem.

I set my XBMC to listen on port 9090.
I set up a username and password on XBMC as well.

I configured Sickbeard to update my XBMC library.
The test works (Message: Test notice sent successfully to 192.168.1.3:9090)

But when the system has to update XBMC after a new episode has been added (or when I try to manually update) I get this error:
Unable to contact XBMC host 192.168.1.3:9090.



TL;DR:
XBMC is set up with username and password to listen on port 9090
Sickbeard is pointed at XBMC through port 9090
Connection test on Sickbeard works
Actual update gives connection error


RE: XBMC + Sickbeard/Couchpotato communication - zodduska - 2012-04-14 02:07

make sure you don't prefix your xbmc address with "http://" in SB


RE: XBMC + Sickbeard/Couchpotato communication - darkfreak - 2012-04-14 03:29

(2012-04-14 02:07)zodduska Wrote:  make sure you don't prefix your xbmc address with "http://" in SB
I didn't Sad


RE: XBMC + Sickbeard/Couchpotato communication - Danforth - 2012-04-16 06:32

Has anyone had any luck? I've run into the same problem, unfortunately.

Edit: CouchPotato works just fine. Something isn't working between Sick Beard and XBMC...


RE: XBMC + Sickbeard/Couchpotato communication - joecho5 - 2012-05-01 07:50

I get the cannot connect error message with a new show I just added but not with old shows that are already up to date.


RE: XBMC + Sickbeard/Couchpotato communication - rogbott - 2012-07-24 07:25

I too am getting this error now with new shows that I have added, but my old shows are updating fine...


RE: XBMC + Sickbeard/Couchpotato communication - NotGonnaTellYou - 2012-10-12 00:28

I'm getting this error as well. I'm able to control XBMC through a browser on a different computer, I'm able to test successfully, but whenever I try to update XBMC, it says it cannot contact xbmc host.