XBMC Community Forum
blu-ray in 1080p with dts-hd and truehd - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Feature Suggestions (/forumdisplay.php?fid=9)
+--- Thread: blu-ray in 1080p with dts-hd and truehd (/showthread.php?tid=109314)



- thenudo - 2012-01-20 18:51

piphead Wrote:Hi Bluray

I have followed your guide to the letter, but when i select to play the DTS HD MASTER soundtrack or TRUE HD the movies just plays in fast forward mode, if i select a normal soundtrack the movies plays fine. i have tried this on my HTPC which has a amd radeon 6450 installed. I have also tried this on a clean install of windows7 32bit and get exactly the same result. would appreciate if you could give me any solution to this.

Thanks

piphead, did you solve this by chance? I'm having the same problem on a system with:

Vista Ultimate 64
ATI HD5450
Onkyo HT-RC360

I tried bluray's suggestions to no avail. Any chance you worked it out?


Choppy sound over TDS-HD - ambar - 2012-01-22 22:43

Hi there,

After getting the XBMC to play HD sound, now I'm experiencing sound glitches during TDS-HD playback. I've checked the same movies with MPC and it works fine with it.
the XBMC configuration is according to the screen shots provided by Bluray.
Any idea how to smooth playback with XBMC's internal player?

10x


- bluray - 2012-01-22 22:52

ambar Wrote:Hi there,

After getting the XBMC to play HD sound, now I'm experiencing sound glitches during TDS-HD playback. I've checked the same movies with MPC and it works fine with it.
the XBMC configuration is according to the screen shots provided by Bluray.
Any idea how to smooth playback with XBMC's internal player?

10x
I'm suggesting to setup MPC-HC for XBMC external player to playback all the BD movies with DTS-HD audio. You can use this guide- Working External Player Solution.


- jetske - 2012-01-23 01:57

Hi Bluray,
Can you please help me, I have changed to eden 11.1 latest release as it does not have the problem I have had andnot been able to cure in Darma, that is random jumping forward or back a minute or so during movie playback. It is great now, however I miss DTS HD on my Bluray rips, I had your setup in Darma and it was fantastic, I tried using your setup in Eden and launching XBMC from your exe, it works fine, standard audio, however it dies not have HD Audio like my Darma did, when I go to audio settings the HD Audio is not listed in set up. Is there anyway of fixing this?
Thanks for help in advance.
Steve


- bluray - 2012-01-23 02:37

jetske Wrote:Hi Bluray,
Can you please help me, I have changed to eden 11.1 latest release as it does not have the problem I have had andnot been able to cure in Darma, that is random jumping forward or back a minute or so during movie playback. It is great now, however I miss DTS HD on my Bluray rips, I had your setup in Darma and it was fantastic, I tried using your setup in Eden and launching XBMC from your exe, it works fine, standard audio, however it dies not have HD Audio like my Darma did, when I go to audio settings the HD Audio is not listed in set up. Is there anyway of fixing this?
Thanks for help in advance.
Steve
You can delete XBMC folder in AppData\Roaming\XBMC\userdata, and then launch XBMC from XBMC_HD_AUDIO folder. You should have your HD audio options back!


- Mrbrooks - 2012-01-23 06:36

Thanks bluray, i see the hd audio options with your method, but now i have two issues:

1. My scanned movies wont appear, the do appear only as files.
2. Now i cant play bd folders, apparently ony iso is recognized...

If i go back to the original betta eden 11.2 with transparency skin i still have all my movies showing fan art and i can play iso or bd folders.

Is there any way to pass this info and settings to the other folder?

Thanks


- bluray - 2012-01-23 06:40

Mrbrooks Wrote:Thanks bluray, i see the hd audio options with your method, but now i have two issues:

1. My scanned movies wont appear, the do appear only as files.
2. Now i cant play bd folders, apparently ony iso is recognized...

If i go back to the original betta eden 11.2 with transparency skin i still have all my movies showing fan art and i can play iso or bd folders.

Is there any way to pass this info and settings to the other folder?

Thanks
Unfortunately, XBMC_HD_Audio cannot mix with other XBMC!


- Mrbrooks - 2012-01-23 07:13

Thank you bluyray, i just scanned my movies again and that fixed everything, plus now i have HD audio.

Regards


- jetske - 2012-01-23 07:54

bluray Wrote:You can delete XBMC folder in AppData\Roaming\XBMC\userdata, and then launch XBMC from XBMC_HD_AUDIO folder. You should have your HD audio options back!

Hi, Thanks for the reply, however I do not have a XBMC folder in userdata.
I have checked and checked again the only XBMC folder is in roaming, this contains amongst other things userdata, but no XBMC folder.
Thanks
I have launced XBMC from the HD audio "exe" sucessfully but no HD dts ETC.
Confused


- ambar - 2012-01-23 12:05

bluray Wrote:I'm suggesting to setup MPC-HC for XBMC external player to playback all the BD movies with DTS-HD audio. You can use this guide- Working External Player Solution.

Thanks Bluray,
Is it possible to create a rule that only MKV files with HD audio will be played by external player?
As i mentioned in previous posts i like very much the XBMC's internal player and would like to use the external player only for HD audio movies...
A rule that check also the name of the movie for ex, if there is a DTS-HD or TrueHD will open external player and all others will be played with internal player...

10x


- ambar - 2012-01-23 12:35

I found in Wiki that a rule by Audiocodec is available. does HD audio supported? what is the syntax to use?


- bluray - 2012-01-23 16:02

jetske Wrote:Hi, Thanks for the reply, however I do not have a XBMC folder in userdata. I have checked and checked again the only XBMC folder is in roaming, this contains amongst other things userdata, but no XBMC folder.
Thanks
I have launced XBMC from the HD audio "exe" sucessfully but no HD dts ETC.
Confused
Yes, you are correct that there isn't XBMC folder in userdata folder. I meant to say XBMC folder in this folder- "AppData\Roaming\". Here is what I think:

1. Somehow, the XBMC_HD_Audio and Beta 11.1 get mixed up
2. You might have to delete XBMC folder from AppData\Roaming\ folder
3. You can launch XBMC_HD_Audio to generate a new XBMC_HD_Audio userdata

You'll have your HD audio options back afterward!


- T800 - 2012-01-23 17:16

Hopefully soon some clever person will make us an updated version of beta 2 with the audioengine.


- bluray - 2012-01-23 18:53

T800 Wrote:Hopefully soon some clever person will make us an updated version of beta 2 with the audioengine.
Can't wait for that day, but it will not be Beta 2! Laugh


- jetske - 2012-01-24 02:03

bluray Wrote:Yes, you are correct that there isn't XBMC folder in userdata folder. I meant to say XBMC folder in this folder- "AppData\Roaming". Here is what I think:

1. Somehow, the XBMC_HD_Audio and Beta 11.1 get mixed up
2. You might have to delete XBMC folder from AppData\Roaming\ folder
3. You can launch XBMC_HD_Audio to generate a new XBMC_HD_Audio userdata

You'll have your HD audio options back afterward!


Thank You,
All sorted out now, exactly as you said.
Wow the sound difference is amazing with DTS HD, I dont understand why its not standard in XBMC?
Why is your set up not just in the basic download, it works so well.
Thanks Steve WinkNod