XBMC Community Forum
blu-ray in 1080p with dts-hd and truehd - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Feature Suggestions (/forumdisplay.php?fid=9)
+--- Thread: blu-ray in 1080p with dts-hd and truehd (/showthread.php?tid=109314)



- fyrfyter71 - 2011-09-10 20:31

ix400 Wrote:Unfortunately, on my system this setup is only good for TrueHD. This works.

But with DTS-HD tracks, my receiver switches permanently between DTS-Master and PCM every two seconds, with no sound.

Thats why I'm really looking forward to the Eden audio branch Windows binaries.

Chris

I have the same problem as ix400. I haven't tried TRUEHD, but dtshd gives me no sound. I have followed bluray's guides. I tried many times with the same result. It doesn't seem like it should be this hard. I'm sure that the developers will have all the kinks worked out soon. As a matter if fact, I don't think I've seen a recent build of the AE branch, as the one in blurays link is fro mid July.

By the way, I'm using a GT430


- ix400 - 2011-09-10 20:38

fyrfyter71 Wrote:I have the same problem as ix400. I haven't tried TRUEHD, but dtshd gives me no sound. I have followed bluray's guides. I tried many times with the same result. It doesn't seem like it should be this hard. I'm sure that the developers will have all the kinks worked out soon. As a matter if fact, I don't think I've seen a recent build of the AE branch, as the one in blurays link is fro mid July.

By the way, I'm using a GT430
.

I'm using an ATI 6970, Sandy Bridge 2600K, Asrock Z68.

So obviously no driver issue.

Chris


- bluray - 2011-09-10 20:49

fyrfyter71 Wrote:I have the same problem as ix400. I haven't tried TRUEHD, but dtshd gives me no sound. I have followed bluray's guides. I tried many times with the same result. It doesn't seem like it should be this hard. I'm sure that the developers will have all the kinks worked out soon. As a matter if fact, I don't think I've seen a recent build of the AE branch, as the one in blurays link is fro mid July.

By the way, I'm using a GT430
i have gt430 in my less than powerful asrock e350m1 htpc, and it bitstreaming flawless. let me ask you these:

1. have you install the latest nvidia driver- NVIDIA Driver Downloads
a. in control panel- select nvidia hdmi audio ouput
b. in control panel>nvidia hdmi- configure speaker to stereo
2. download the latest hd codecs from here- High Definition Audio Codecs
3. use photos below to setup audiot output in xbmc-
[Image: 317axya.jpg]
if you are still having trouble bitstreaming with xbmc, you can try 7mce version too. the guide for bitstreaming using 7mce might be easier than xbmc, and i have been using it for a long time. it works flawless!


- clubwerks - 2011-09-12 16:34

I can also confirm that Dobly TrueHD also works flawlessly. If only my music vids played at the correct speed. Not that I watch a ton of music videos, but my daughter likes to put them on and dance around the living room. Big Grin


- >>X<< - 2011-09-12 17:37

@bluray

Totally unrelated to this thread but why don't you just press "print screen" to take a screen shot


- bluray - 2011-09-12 18:21

&gt;&gt;X&lt;&lt; Wrote:@bluray

Totally unrelated to this thread but why don't you just press "print screen" to take a screen shot
i think that it is related. i preferred screen shot than print screen.


- >>X<< - 2011-09-12 18:30

Print Screen takes a screen shot when XBMC is running :confused2:


- bluray - 2011-09-12 18:32

&gt;&gt;X&lt;&lt; Wrote:Print Screen takes a screen shot when XBMC is running :confused2:
that is right, and screen photo can do the same thing.


- clubwerks - 2011-09-12 19:14

bluray Wrote:that is right, and screen photo can do the same thing.


Seriously, you're not trying to argue that taking a camera picture of the screen with the flash bouncing off the screen is as elegant solution as getting an XBMC screenshot are you? Presentation my friend. The same thing with having to download a word document from a file hosting service when you could have just grabbed the screen and linked it from photobucket.


- bluray - 2011-09-12 19:30

clubwerks Wrote:Seriously, you're not trying to argue that taking a camera picture of the screen with the flash bouncing off the screen is as elegant solution as getting an XBMC screenshot are you? Presentation my friend. The same thing with having to download a word document from a file hosting service when you could have just grabbed the screen and linked it from photobucket.
i'm not trying to argue anything. if you turn off the flash, you shouldn't have any flash. i just like to do it my way which is with picture and upload it to tinypic and paste it here. i can see it fine on my screen. sometime, i like to save it to word because it allow me to include multiple things in a single file. with tinypic, there is no account required. i don't like to deal with any hosting site that required account.

if you preferred photobucket way, you can do that and i have no beef with it!


- clubwerks - 2011-09-13 04:21

bluray Wrote:i'm not trying to argue anything. if you turn off the flash, you shouldn't have any flash. i just like to do it my way which is with picture and upload it to tinypic and paste it here. i can see it fine on my screen. sometime, i like to save it to word because it allow me to include multiple things in a single file. with tinypic, there is no account required. i don't like to deal with any hosting site that required account.

if you preferred photobucket way, you can do that and i have no beef with it!

I was talking about you turning off the flash. Big Grin I would just use the screenshot function built in to XBMC.


- Songoku - 2011-09-13 20:48

I got mine gt430 today

tested more than 30 dtshdma and truehd mkv. all worked perfectly

but unfortunately %10 of my normal DTS movies sound skips between dts and pcm Sad tried everything writes in this thread but no solution so far.

Hope next xbmc comes soon

by the way thank ery much bluray for all info you shared.


- clubwerks - 2011-09-13 23:28

Songoku Wrote:I got mine gt430 today

tested more than 30 dtshdma and truehd mkv. all worked perfectly

but unfortunately %10 of my normal DTS movies sound skips between dts and pcm Sad tried everything writes in this thread but no solution so far.

Hope next xbmc comes soon

by the way thank ery much bluray for all info you shared.


I found my first movie this morning that would not work. A DTS encoded mkv of The Hunt for Red October. Really bad stuttering and distortion.


- Schwiing - 2011-09-15 01:55

Thanks again Blu ray for your post + build. First time I've seen bitstreaming in XBMC work. However, whether it be an .iso or an .mkv, the video is perfect but the audio skips a bit. I'm curious as to why this happens. My HTPC streams media from my storage server, though it never has problems in other programs (VLC, MPC-HC, PDVD, etc), so I know it can't be that. Any suggestions?


- bluray - 2011-09-15 03:46

Schwiing Wrote:Thanks again Blu ray for your post + build. First time I've seen bitstreaming in XBMC work. However, whether it be an .iso or an .mkv, the video is perfect but the audio skips a bit. I'm curious as to why this happens. My HTPC streams media from my storage server, though it never has problems in other programs (VLC, MPC-HC, PDVD, etc), so I know it can't be that. Any suggestions?
i know that you said it playback fine with mpc-hc, pdvd, etc but have you update your graphic card with the latest driver? have you properly selected hdmi output and configured speaker output to stereo in control panel.

as most of us aware that xbmc is very difficult to make it playback fluently, and both audio and video settings have to be perfectly setup for it to playback fluently!