XBMC Community Forum
[RELEASE] Official XBMC boblight Addon - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Service Add-ons (/forumdisplay.php?fid=152)
+---- Thread: [RELEASE] Official XBMC boblight Addon (/showthread.php?tid=116331)



RE: [RELEASE] Official XBMC boblight Addon - ppic - 2012-05-15 12:26

i've found my mistake, i've got the wrong prefix in my config file !


RE: [RELEASE] Official XBMC boblight Addon - drose25 - 2012-05-20 16:00

Has anyone seen a hardware schematic utilizing the TI MSP-430 instead of an Arduino microcontroller? I've seen one in action, and found the code necessary to use it with a Boblight mod, but I can't seem to find the hardware schematic anywhere. Might be because the site is in German, but the video and source is here: http://www.jevermeister.de/2011/11/mein-rgb-led-ambilight-mit-dem-msp430-funktioniert-mit-boblight/


RE: [RELEASE] Official XBMC boblight Addon - MrHenky - 2012-05-22 15:13

(2012-05-14 01:58)ppic Wrote:  hi all,

i've just installed my adalight setup and run boblight, but i only achieve to make the first 25 led ribbon, the second doesn't do anything.

during initialize of the arduino, all ribbons bright, but with booblight, only first 25 leds, here is my conf file: http://pastebin.com/e5UgVqc5

i think the problem is there, but don't see it.

You need to change your prefix. Somewhere in this thread, there is an Arduino sketch for calculating the prefix. Look for that or just use this prefix:

channels 150
prefix 41 64 61 00 95 C0

That should work. If I'm wrong, feel free to correct me.

EDIT: Solution already known. My bad.


RE: [RELEASE] Official XBMC boblight Addon - gef974 - 2012-05-24 10:06

Hello all!
I have an arduino uno, and I'm a windows user. I tried to get it works but I can't... I put ledstream.pde, when I launch boblightd.exe from boblight-1.3-beta1 the leds become red green blue. With boblight-getpixel it works quite good, so I think my boblight.conf is ok. I want to use the boblight addon but I can't. It says it failed to connect to boblightd.. I tried with boblightd.exe only, with boblightd and boblight-getpixel and nothing.
So I tried boblightd_r416 as draven187 said but same thing, failed to connect. The addon download librairies, it's ok, it's activate but nothing to do, I can't get it works...
Somebody can help? Thanks
Ps: sorry for my bad english


RE: [RELEASE] Official XBMC boblight Addon - schumi2004 - 2012-05-24 10:11

Maybe this http://forum.xbmc.org/showthread.php?tid=116331&pid=1086741#pid1086741 or this http://forum.xbmc.org/showthread.php?tid=116331&pid=1089572#pid1089572 will help.

Something else, anyone knows how to calculate prefix for boblight.conf? 75 leds?


RE: [RELEASE] Official XBMC boblight Addon - illiac4 - 2012-05-27 07:25

Prefix for 75 LEDS: 41 64 61 00 4A 1F


RE: [RELEASE] Official XBMC boblight Addon - ramouch0 - 2012-05-31 10:43

Hi,
Thank you for this addon, it works great.

Is there anywhere I could find a description of each parameter that can be set in the addon ?
Some of them are not very explicit and the only document i could find is the old boblight articles that are not much explicit


RE: [RELEASE] Official XBMC boblight Addon - donabi - 2012-06-01 18:54

i'm running into errors after "make"
http://pastebin.com/1m3Jgpf0

any ideas?


RE: [RELEASE] Official XBMC boblight Addon - Memphiz - 2012-06-02 02:05

if you are on ubuntu i would say "apt-get install build-essentials" ... else you are just missing your complete build environment (the c++ compiler in that case).


RE: [RELEASE] Official XBMC boblight Addon - donabi - 2012-06-02 13:28

Smile
That's it. I'm using the LIVE-Install. The Package-Setting was set to "german" and didn't find build-essentials.
After setting it to "main server" and searching for build-essential (without the "s") it installed.

.


RE: [RELEASE] Official XBMC boblight Addon - Memphiz - 2012-06-03 23:02

Boblight addon should be working on iOS now with the current nightlys. (performance is ok when watching h.264 content - for SD software decoded content the boblight is a bit to much Smile ).


RE: [RELEASE] Official XBMC boblight Addon - ramouch0 - 2012-06-05 15:06

After digging the forum, I finally found the meaning of each parameters.
Maybe you should but this on the first post.
http://forum.xbmc.org/showthread.php?tid=116331&pid=1034591#pid1034591


RE: [RELEASE] Official XBMC boblight Addon - Memphiz - 2012-06-05 16:16

done


RE: [RELEASE] Official XBMC boblight Addon - cyberman - 2012-06-06 11:24

Hello,

thanks so much for this addon!!
boblight-X11 didn't work with my AMD GPU in fullscreen, so this was my last hope and it works!

I really hope someday there will be menu ambilight support
>1. Currently boblight is only driven when the videoplayer is running. We hope to be able to extend it to the menu and even music playback in the future- though this will need major changes in the XBMC core so it wouldn't be the near future Wink.

That would be so great! Smile


RE: [RELEASE] Official XBMC boblight Addon - Jevermeister - 2012-06-08 14:03

(2012-05-20 16:00)drose25 Wrote:  Has anyone seen a hardware schematic utilizing the TI MSP-430 instead of an Arduino microcontroller? I've seen one in action, and found the code necessary to use it with a Boblight mod, but I can't seem to find the hardware schematic anywhere. Might be because the site is in German, but the video and source is here: http://www.jevermeister.de/2011/11/mein-rgb-led-ambilight-mit-dem-msp430-funktioniert-mit-boblight/

Hi,

i've used a RGB amplifier from ebay ( search for RGB SMD 5050 LED Strips Light Signal Amplifier 12V on ebay.com ) which is connected to
pin 2.1(red), pin 2.5(blue), pin 1.6(green) and VCC of the launchpad (not sure if R G B is twisted), but you need a MSP430 G2553 and twisted RX/TX pins. i heard that newer launchpads already use the G2553 and don't need the RX/TX mod.

Regards