XBMC Community Forum
[RELEASE] Official XBMC boblight Addon - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Service Add-ons (/forumdisplay.php?fid=152)
+---- Thread: [RELEASE] Official XBMC boblight Addon (/showthread.php?tid=116331)



- bleze - 2011-12-20 21:18

If anyone is listening, Memphiz helped me getting running. So Crystalbuntu with combustd, boblightd from svn and the addon works great.
Thanks again to Memphiz!


- bobo1on1 - 2011-12-20 23:41

You're using the old boblightd, the addon is not compatible with that version.


- Memphiz - 2011-12-21 14:07

bobo1on1 Wrote:You're using the old boblightd, the addon is not compatible with that version.

yep ... that was the issue i've fixed on his side Wink. So for the not so good reading people. The addon is still not compatible to the old boblightd - and won't be ever Wink


- bleze - 2011-12-21 18:01

In my defense I had read that I needed a newer version and I had checked it out and built it. Problem was that it was still booting the old version which I thought had been overwritten but was in another folder. If a version number or something had been output to the console when starting the daemon or boblight-constant I would probably have noticed this Smile


- Memphiz - 2011-12-21 19:58

bleze Wrote:In my defense I had read that I needed a newer version and I had checked it out and built it. Problem was that it was still booting the old version which I thought had been overwritten but was in another folder. If a version number or something had been output to the console when starting the daemon or boblight-constant I would probably have noticed this Smile

my statement was not for you ... but for people which read the "i fixed it" in my statement and think some sort of "ohh cool ... addon works with old boblightd now" ... Wink


- Wikking - 2011-12-22 12:43

Memphiz Wrote:yep ... that was the issue i've fixed on his side Wink. So for the not so good reading people. The addon is still not compatible to the old boblightd - and won't be ever Wink

So did you got the AMBX device to respond using the SVN-version of boblight or did you just told him to use the old 1.3 version? If it was the SVN-version, how did you fix his problems?
Because some time ago I tried to get the AMBX working with the SVN-version of boblight but couldn't get it to connect properly.


- Memphiz - 2011-12-22 16:34

Bleze uses the svn version now. Maybe he could be so kind and post his config file to pastebin.com and add a link.

There where some things needed i don't remember anymore exactly. A special boblight.conf, a ruby script and combust something?


- Wikking - 2011-12-22 17:28

That would be much appreciated! And not only by me but also by other AMBX-users. The issue with ABMX and SVN-boblight pops up on basically every forum connected to XBMC. And is, to my knowledge, unresolved...well obviously not anymore ;-)


- ECEC - 2011-12-22 18:07

I apologize if this isn't the place to ask, but I bought an arduino and some lights a few months ago for the purpose of creating my own ambilight. Would this add-on be what I would use to drive the lights from XBMC, or would I need some other software?

I really need to sit down and put all the hardware together one day, but I'm rubbish at electronics in general and am way intimidated by connecting everything up. Sad


- bobo1on1 - 2011-12-22 18:55

You would use this addon, and boblight from http://code.google.com/p/boblight/


- ECEC - 2011-12-22 20:44

bobo1on1 Wrote:You would use this addon, and boblight from http://code.google.com/p/boblight/

Cool, thanks! Smile

Edit: er, there's probably not gonna be a Windows version anytime soon, right? I might have to eventually get around to installing a Ubuntu VM on my WHS box for this and SiriProxy.


- bobo1on1 - 2011-12-22 21:20

Yeah probably not, I don't have time to support windows anymore.
Compiling boblight on cygwin should work though.


- Eoghlear - 2011-12-23 00:57

So, this should practically work out of the box on linux? Including XBMClive?
One of the reasons i'm considering leaving OpenElec for.


- bobo1on1 - 2011-12-23 03:10

Ehm no, you still need to have libboblight on your system and a running boblightd somewhere.


- metheos - 2011-12-24 22:45

Thanks so much for the great work! This is exactly what I've been needing!