XBMC Community Forum
New Home for Ember Media Manager (Official Thread) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (/forumdisplay.php?fid=116)
+---- Forum: Ember Media Manager (/forumdisplay.php?fid=195)
+---- Thread: New Home for Ember Media Manager (Official Thread) (/showthread.php?tid=116941)



RE: New Home for Ember Media Manager (Official Thread) - pedram - 2012-05-12 22:59

Just came across this after hobbling along with the older buggy version for months. Thanks a lot for updating it.!


RE: New Home for Ember Media Manager (Official Thread) - deh2k7 - 2012-05-13 01:18

(2012-05-12 22:22)anahka2309 Wrote:  I'd like the <sorttitle> option in EMM somewhere. So if you open a set it puts the movies in the correct order in case the names don't do so alphabetically. It's annoying to have to go into a dozen sets of movies and edit the .nfo manually Smile

This is currently available in EMM today. I use it for all of my movies. The field is labeled "sort title", right below the "original title" field.


RE: New Home for Ember Media Manager (Official Thread) - deh2k7 - 2012-05-13 06:48

(2012-05-12 19:41)xbmcfire1 Wrote:  I just started using Ember MM and I have a question that I don't think anyone has asked.
My movies are all in separate folders, and I encounter a problem with ones that are split in to two CD's. The directory structure looks like this:

[D] My Movie Name
- [D] CD1
---[F] movie-cd1.avi (or a bunch of unextracted rar files of the CD1 avi)
- [D] CD2
---[F] movie-cd2.avi (or a bunch of unextracted rar files of the CD2 avi)

So, the obvious solution would be to move the .avi files up into the root directory, but I'd really rather not do that (too many movies). When Ember scans (recursively, otherwise it doesn't detect any movies at all that is using the above folder structure), then it picks up each sub-directory as a separate entry. That means I end up with a long list of: CD1, CD1, CD1, CD1, CD2, CD2, CD2, CD2. Yuk!

Is there a way to NOT scan recursively and still have it enter the movie info into the top directory? It shouldn't matter what's in the CD1, CD2 directories if all the .nfo data is added to the root movie directory, right? (as some movie folders do have a .nfo in its root but EMM not detecting).

Also - is EMM able to detect movies that are unpacked (still in multiple rars)? As Ive got a few movies in folders named correctly but not extracted (i.e Movie Title->CD1->rar files) and EMM wont detect it. (I dont want to extract as XBMC can play them fine).

Thanks

For multi-discs, here is what I do. I also have each movie in it's own separate directory. I do NOT have each disc in its own subdir under the movie. You only need nfo, fanart, etc. for Disc1 of multidiscs, as XBMC and Ember will recognize it as a multidisc movie and stack accordingly. Try this:

Using Lawrence of Arabia since it's two discs:

c:\MyMovieLibrary\Larewnce of Arabia\
-Lawrence of Arabia [Disc 1].avi
-Lawrence of Arabia [Disc 1].nfo
-Lawrence of Arabia [Disc 1].tbn
-Lawrence of Arabia [Disc 1]-fanart.jpg
-Lawrence of Arabia [Disc 2].avi

Can't help you with the rar's, sorry.


RE: New Home for Ember Media Manager (Official Thread) - xbmcfire1 - 2012-05-13 07:39

(2012-05-13 06:48)deh2k7 Wrote:  
(2012-05-12 19:41)xbmcfire1 Wrote:  I just started using Ember MM and I have a question that I don't think anyone has asked.
My movies are all in separate folders, and I encounter a problem with ones that are split in to two CD's. The directory structure looks like this:

[D] My Movie Name
- [D] CD1
---[F] movie-cd1.avi (or a bunch of unextracted rar files of the CD1 avi)
- [D] CD2
---[F] movie-cd2.avi (or a bunch of unextracted rar files of the CD2 avi)

So, the obvious solution would be to move the .avi files up into the root directory, but I'd really rather not do that (too many movies). When Ember scans (recursively, otherwise it doesn't detect any movies at all that is using the above folder structure), then it picks up each sub-directory as a separate entry. That means I end up with a long list of: CD1, CD1, CD1, CD1, CD2, CD2, CD2, CD2. Yuk!

Is there a way to NOT scan recursively and still have it enter the movie info into the top directory? It shouldn't matter what's in the CD1, CD2 directories if all the .nfo data is added to the root movie directory, right? (as some movie folders do have a .nfo in its root but EMM not detecting).

Also - is EMM able to detect movies that are unpacked (still in multiple rars)? As Ive got a few movies in folders named correctly but not extracted (i.e Movie Title->CD1->rar files) and EMM wont detect it. (I dont want to extract as XBMC can play them fine).

Thanks

For multi-discs, here is what I do. I also have each movie in it's own separate directory. I do NOT have each disc in its own subdir under the movie. You only need nfo, fanart, etc. for Disc1 of multidiscs, as XBMC and Ember will recognize it as a multidisc movie and stack accordingly. Try this:

Using Lawrence of Arabia since it's two discs:

c:\MyMovieLibrary\Larewnce of Arabia\
-Lawrence of Arabia [Disc 1].avi
-Lawrence of Arabia [Disc 1].nfo
-Lawrence of Arabia [Disc 1].tbn
-Lawrence of Arabia [Disc 1]-fanart.jpg
-Lawrence of Arabia [Disc 2].avi

Can't help you with the rar's, sorry.

Thanks for the reply. Ive got disc 1 and disc 2 avi files in their own folders (titled CD1, CD2) within the movie's folder. Ive looked at your suggestion and it works (moving the files out of the folder and into the movie root). The problem is that heaps of my movies are in this structure so it will take lots of manual effort to cut/paste into root directory. Its obviously a last resort option if no one can help.

Cheers again

Is there a way to force EMM to scrape images based on folder names or .nfo in the folder? My folder has movie and year correctly, and in the root also has an .nfo. But EMM wont pick it up. Instead it picks up CD1 and CD2 as movie titles- so it seems EMM needs a media file to associate with before it will scrape anything...


RE: New Home for Ember Media Manager (Official Thread) - TeKo - 2012-05-13 13:17

(2012-05-13 07:39)xbmcfire1 Wrote:  
(2012-05-13 06:48)deh2k7 Wrote:  
(2012-05-12 19:41)xbmcfire1 Wrote:  I just started using Ember MM and I have a question that I don't think anyone has asked.
My movies are all in separate folders, and I encounter a problem with ones that are split in to two CD's. The directory structure looks like this:

[D] My Movie Name
- [D] CD1
---[F] movie-cd1.avi (or a bunch of unextracted rar files of the CD1 avi)
- [D] CD2
---[F] movie-cd2.avi (or a bunch of unextracted rar files of the CD2 avi)

So, the obvious solution would be to move the .avi files up into the root directory, but I'd really rather not do that (too many movies). When Ember scans (recursively, otherwise it doesn't detect any movies at all that is using the above folder structure), then it picks up each sub-directory as a separate entry. That means I end up with a long list of: CD1, CD1, CD1, CD1, CD2, CD2, CD2, CD2. Yuk!

Is there a way to NOT scan recursively and still have it enter the movie info into the top directory? It shouldn't matter what's in the CD1, CD2 directories if all the .nfo data is added to the root movie directory, right? (as some movie folders do have a .nfo in its root but EMM not detecting).

Also - is EMM able to detect movies that are unpacked (still in multiple rars)? As Ive got a few movies in folders named correctly but not extracted (i.e Movie Title->CD1->rar files) and EMM wont detect it. (I dont want to extract as XBMC can play them fine).

Thanks

For multi-discs, here is what I do. I also have each movie in it's own separate directory. I do NOT have each disc in its own subdir under the movie. You only need nfo, fanart, etc. for Disc1 of multidiscs, as XBMC and Ember will recognize it as a multidisc movie and stack accordingly. Try this:

Using Lawrence of Arabia since it's two discs:

c:\MyMovieLibrary\Larewnce of Arabia\
-Lawrence of Arabia [Disc 1].avi
-Lawrence of Arabia [Disc 1].nfo
-Lawrence of Arabia [Disc 1].tbn
-Lawrence of Arabia [Disc 1]-fanart.jpg
-Lawrence of Arabia [Disc 2].avi

Can't help you with the rar's, sorry.

Thanks for the reply. Ive got disc 1 and disc 2 avi files in their own folders (titled CD1, CD2) within the movie's folder. Ive looked at your suggestion and it works (moving the files out of the folder and into the movie root). The problem is that heaps of my movies are in this structure so it will take lots of manual effort to cut/paste into root directory. Its obviously a last resort option if no one can help.

Cheers again

Is there a way to force EMM to scrape images based on folder names or .nfo in the folder? My folder has movie and year correctly, and in the root also has an .nfo. But EMM wont pick it up. Instead it picks up CD1 and CD2 as movie titles- so it seems EMM needs a media file to associate with before it will scrape anything...

Add the folder as source and check "Only Detect one Movie From Each Folder" and "User Folder Name for Initial Listing" should do what you want.


RE: New Home for Ember Media Manager (Official Thread) - xbmcfire1 - 2012-05-13 14:59

(2012-05-13 13:17)TeKo Wrote:  
(2012-05-12 19:41)xbmcfire1 Wrote:  I just started using Ember MM and I have a question that I don't think anyone has asked.
My movies are all in separate folders, and I encounter a problem with ones that are split in to two CD's. The directory structure looks like this:

[D] My Movie Name
- [D] CD1
---[F] movie-cd1.avi (or a bunch of unextracted rar files of the CD1 avi)
- [D] CD2
---[F] movie-cd2.avi (or a bunch of unextracted rar files of the CD2 avi)

So, the obvious solution would be to move the .avi files up into the root directory, but I'd really rather not do that (too many movies). When Ember scans (recursively, otherwise it doesn't detect any movies at all that is using the above folder structure), then it picks up each sub-directory as a separate entry. That means I end up with a long list of: CD1, CD1, CD1, CD1, CD2, CD2, CD2, CD2. Yuk!

Is there a way to NOT scan recursively and still have it enter the movie info into the top directory? It shouldn't matter what's in the CD1, CD2 directories if all the .nfo data is added to the root movie directory, right? (as some movie folders do have a .nfo in its root but EMM not detecting).

Also - is EMM able to detect movies that are unpacked (still in multiple rars)? As Ive got a few movies in folders named correctly but not extracted (i.e Movie Title->CD1->rar files) and EMM wont detect it. (I dont want to extract as XBMC can play them fine).

Thanks

Add the folder as source and check "Only Detect one Movie From Each Folder" and "User Folder Name for Initial Listing" should do what you want.

Sad Nope, had that setting originally and doesnt work either. (Only detect one movie, use folder names- both checked and scanned recursively checked). If I uncheck scan recursively, those movies with the CD1 CD2 folder structure dont even show up at all (where as now they do show up but as movies titled CD1, CD2).

Thanks


RE: New Home for Ember Media Manager (Official Thread) - schumi2004 - 2012-05-13 15:14

(2012-05-10 23:48)DanCooper Wrote:  
(2012-05-10 21:50)schumi2004 Wrote:  Not so long a go i asked what is wrong with Ember that it doesn't pick up genre's when scrapping movies. Download latest version (fix 6), cleaned up everything else but also in this version i'm still not getting genre's.

If someone can help me fix this i can use Ember to scrap my collection again but without Genre it's pretty useless for me.

Edit:
Another thing i almost forgot, every time i start Ember i'ts bringing up the setup window again, selecting language etc. Am i doing something wrong here?

I use the native scraper and genre works perfect for me.

Hmm, you have make a clean install or overwrite old files? You can overwrite onle the files from version 1.3.0.5 to Fix 6, not from 1.3.0.4 or older.
I was using Olympia 1.5 scrapper maybe that's the problem. What i love about Olympia is that i can select language in which plot etc should be fetched.

Second think is a clean install on a Windows 7 x64 system. Running it in admin mode doesn't change it.


RE: New Home for Ember Media Manager (Official Thread) - HiSoC8Y - 2012-05-13 17:01

got a question.

if i decide to install this version 3.0.5 all over again from scratch, but i want to save every single setting i have already applied to my current installation, how can i apply the same settings again on the new installation?

i mean, i need every single setting.


RE: New Home for Ember Media Manager (Official Thread) - HiSoC8Y - 2012-05-13 18:26

(2012-05-13 17:01)HiSoC8Y Wrote:  got a question.

if i decide to install this version 3.0.5 all over again from scratch, but i want to save every single setting i have already applied to my current installation, how can i apply the same settings again on the new installation?

i mean, i need every single setting.

Update: I tried this method, it didnt fix my sets issue.


RE: AW: New Home for Ember Media Manager (Official Thread) - DanCooper - 2012-05-15 13:32

(2012-05-12 19:52)HiSoC8Y Wrote:  Hi Dan

as requested, please find below.

XBMC standard:
Code:
<set>Godfather Collection</set>

YAMJ standard:
Code:
<sets>
    <set order="1">Test</set>
</sets>


What standard do you have currently in the NFO?
Which standard you want to use?

Do you use YAMJ or XBMC as a media player?


RE: New Home for Ember Media Manager (Official Thread) - morikaweb - 2012-05-15 14:50

I upgraded yesterday, but the first thing I noticed is that when I scrape movies the button to select all original fanart is missing. This used to put all the fanart as extra into the \extrathumbs folder. Now all I can get it to do is to put really really small thumbnails in the extra art folder, and to do that I must manually click on every single fanart, as there seems too be no way to automate it. Is there anyway to get back the old functionality? At this point I am seriosly regretting not backing up the old version, I would be willing to install an older version if It would give me back this funcanality.

Edit:

Another minor issue I find is before it would tell you the size of fanart on the main screen, now it just says Multiple and you must click on evry single one to find out how big they are, this is very annoying if you only want 1080 fanart. Is there any way to turn off this grouping?

Edit 2: Ok I figured out how to make the extra fanart origanal size. But I still cannot get it to automaticly download them like it used to.


RE: New Home for Ember Media Manager (Official Thread) - AgeOfPanic - 2012-05-15 23:06

I've added a feature request for the episodeguide tag on the github page for EMM with number 94. I hope somebody will pick up on this issue. Thank you for your help.


RE: New Home for Ember Media Manager (Official Thread) - hatbrox - 2012-05-15 23:35

Hi,

I recently changed my media server, I reinstalled everything on the box. I added my movie folders into EMM.
problem: Although EMM sees all the movies on the left pane, the right pane says: "No Information Available For This Movie"
When I look at my movies with windows explorer (each movie is in an individual folder) I can still see the fanart, poster, nfo files.
my sets are also gone.
Since I spent a enormous time to carefully select the genre, fanart and poster for each movie, I'd like EMM to recover that information.
Is it possible?
I tried to rescrap one movie, but EMM ignores the local files and generated new ones, overwriting my previous info.
I so scared to have lost it all! Can someone help?

I assume that my sets are gone for good.


RE: New Home for Ember Media Manager (Official Thread) - DanCooper - 2012-05-15 23:48

(2012-05-15 14:50)morikaweb Wrote:  I upgraded yesterday, but the first thing I noticed is that when I scrape movies the button to select all original fanart is missing. This used to put all the fanart as extra into the \extrathumbs folder. Now all I can get it to do is to put really really small thumbnails in the extra art folder, and to do that I must manually click on every single fanart, as there seems too be no way to automate it. Is there anyway to get back the old functionality? At this point I am seriosly regretting not backing up the old version, I would be willing to install an older version if It would give me back this funcanality.

Edit:

Another minor issue I find is before it would tell you the size of fanart on the main screen, now it just says Multiple and you must click on evry single one to find out how big they are, this is very annoying if you only want 1080 fanart. Is there any way to turn off this grouping?

Edit 2: Ok I figured out how to make the extra fanart origanal size. But I still cannot get it to automaticly download them like it used to.

1. The grouping can not be disabled
2. Grouped will be only pictures of TMDB
3. Minimum size of poster on TMDB are always 666px
4. Minimum size of fanarts on TMDB are always 1280px
5. the poster sizes on TMDB are: original >666x?px / medium = 500x?px / cover = 128x?px / small = 92x?px
6. the fanart sizes on TMDB are: original(large) >1280x?px / poster = 780x439px / medium(w1280) = 1280x720px / small(thumb) = 300x169px

The reason for this grouping is that only one image size will be downloaded for preview. It speeds up the manual scraping.

There are two settings for downloading Extrathumbs:
1. Size for automatic scraping
[Image: 18cje1.jpg]

2. Size for manual scraping
[Image: 2m4x4ef.jpg]

If it is set in both the same size all the fanarts on manual scraping are selected.

And FYI: If you use XBMC it does not matter how big are your poster or fanarts. XBMC trims the images to the perfect size for import into the database. It is only necessary to maintain a certain minimum size, so you can always select "Original". For the last extrathumbs even the smallest size (small / thumb), the images are in each skin I know not shown much larger than a postage stamp ;-)


Edit: The following sizes are the same in the two settings:

large = original
medium = w1280
small = thumb
(can not be set) = poster

(2012-05-15 23:35)hatbrox Wrote:  Hi,

I recently changed my media server, I reinstalled everything on the box. I added my movie folders into EMM.
problem: Although EMM sees all the movies on the left pane, the right pane says: "No Information Available For This Movie"
When I look at my movies with windows explorer (each movie is in an individual folder) I can still see the fanart, poster, nfo files.
my sets are also gone.
Since I spent a enormous time to carefully select the genre, fanart and poster for each movie, I'd like EMM to recover that information.
Is it possible?
I tried to rescrap one movie, but EMM ignores the local files and generated new ones, overwriting my previous info.
I so scared to have lost it all! Can someone help?

I assume that my sets are gone for good.

Please post screenshots of:
- example movie folder
- the settings "Movies -> Data & Sources"
- one ore more NFO's (on pastebin or similar)


RE: New Home for Ember Media Manager (Official Thread) - hatbrox - 2012-05-16 00:25

Hi,
thanks for looking into my problem.
Below are the screenshots:
[Image: mainscreen.png]

[Image: settings.png]

[Image: folder.png]

NFO:
http://pastebin.com/6knrDmDr