XBMC Community Forum
[RELEASE] Demand 5 (Video) Addon - UK Channel 5 on demand - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Demand 5 (Video) Addon - UK Channel 5 on demand (/showthread.php?tid=119551)

Pages: 1 2 3 4 5 6 7


- spoyser - 2012-01-16 10:17

castalla Wrote:Glad it worked out!

How about a live itv and/or channel 4 playerConfused!!!

How about the TV Catchup plugin, has over 40 live UK streams (and they all work, all the time!)

http://plugins.tvcatchup.com/~xbmc/


- castalla - 2012-01-16 11:04

... or not at all, all the time, if you use a vpn!!!


- nokmond - 2012-01-16 14:56

Thanks for the plugin - only issue is home & away doesn't work, just get a script error. The wife will be delighted if it can be fixed!!


- Jimmer - 2012-01-16 15:31

Hi I'm running the PVR-branch on Hardy on my ATV1. Using v1.0.1 for the plugin, I get one successful play of the first show I select. All subsequent attempts to play (either the same show or any other show) end up with a Script Failed! error.

Killing and relaunching XBMC allows me to successfully play another show just the once again, then Script Failed returns!

Reading the comments above, it looked like v1.0.0 had this issue and it was fixed for others after upgrading to v1.0.1.... or do others still get the issue with v1.0.1?

Pastebin of failed attempt:

http://pastebin.com/gwW1jcZV

Regards,


Jim


EDIT: Just to add that I've tried it on my other pre-eden pvr box (nvdia graphics, maverick base - updated to 3.0 Kernel) with exactly the result described above. Log shows same error, so haven't bothered to pastebin it.....


- spoyser - 2012-01-16 19:26

Jimmer Wrote:Hi I'm running the PVR-branch on Hardy on my ATV1. Using v1.0.1 for the plugin, I get one successful play of the first show I select. All subsequent attempts to play (either the same show or any other show) end up with a Script Failed! error.

Killing and relaunching XBMC allows me to successfully play another show just the once again, then Script Failed returns!

I'm now getting this behaviour with Eden-Beta and Dharma, looks like Channel 5 have got it in for this plugin!!

Edit
Actually looks like I jumped the gun, seems it is only with Eden-Beta. Dharma looks fine, just started to play at least 10 programmes successfully with Dharma.


- Jimmer - 2012-01-16 19:29

spoyser Wrote:I'm now getting this behaviour with Eden-Beta and Dharma, looks like Channel 5 have got it in for this plugin!!

Lol! Keep fighting the good fight...... if you want anybody to help with testing, let me know?

Jim


- Big Steve - 2012-01-17 03:00

Thanks for a great plugin. Getting the same error over here too, I can play a single show then get a script error. Shutdown xbmc and restart and I can watch another single show.


- zuccster - 2012-01-25 02:37

spoyser Wrote:Couldn't take my 6 year daughter nagging me anymore so I've fixed the missing programs issue.

If you replace the current ShowEpisodes function with the following 2 functions it should then work, it basically scrapes for all series and then uses the existing functionality to scrape for individual episodes.

Great work spoyser, that finds all 50+ episodes of City of Friends for me, as opposed to the original code's one episode.

@nibor - thanks for a great addon - is there any chance spoyser's changes can me merged into the next release, please?


- Mighty_Diamond - 2012-01-25 03:48

For some reason this has stopped working for me. Here is the paste: http://pastebin.com/RUXc07YD

Any ideasConfused I get paste the play/download menu then it hangs with 'loading', before script error.

Much appreciated.


- Death-Axe - 2012-01-25 19:49

This been fixed yet?


- spoyser - 2012-01-26 14:21

I can't speak for nibor but given that this plugin works perfectly in Dharma I would hazard a guess that it is more than likely a problem with Eden rather than the plugin itself (updated libraries?).

I have spent quite a while trying to fix it but without success but for any coders looking in it appears to be a problem with the encoding of the pyamf.remoting.Envelope

One thing I have noticed in Eden is that whilst the plugin is downloading an episode it also streams other episodes correctly (to allow this you need to comment out the final while loop in the download code), as soon as the download completes then it starts giving scripts errors.


- zuccster - 2012-01-27 03:54

OK, I think I've cracked the script error in Eden Beta 2

in .xbmc/addons/plugin.video.demand5/pyamf/xml.py around line 72

add a try / except block around the
Code:
t = _get_etree_type(etree)
call thus:

Code:
try:
            t = _get_etree_type(etree)
        except TypeError:
            continue


Modified copy here
Also, for convenience a default.py with spoyser's fixed episode parsing.


- spoyser - 2012-01-27 11:27

zuccster Wrote:OK, I think I've cracked the script error in Eden Beta 2

in .xbmc/addons/plugin.video.demand5/pyamf/xml.py around line 72

add a try / except block around the
Code:
t = _get_etree_type(etree)
call thus:

Code:
try:
            t = _get_etree_type(etree)
        except TypeError:
            continue


Modified copy here
Also, for convenience a default.py with spoyser's fixed episode parsing.

SmileSmile

Good one!!

Weird thing is I was just looking at that line, put a try/except in to see what was going on and lo and behold found that it then worked!

Not sure if it is a bug in the pyamf libraries themselves (surely they have been tested to death by now!) or the way they are being used by the plugin, or why it is only in Eden, but who cares it works. I can finally upgrade the living room XBMC to Eden (my 6 year old wouldn't let me until Milkshake worked!!)

SmileSmile


- Jimmer - 2012-01-27 12:32

zuccster Wrote:Modified copy here
Also, for convenience a default.py with spoyser's fixed episode parsing.

Dude, for a high gaf (like waf, but living in sin!) demand5 is essential. This is a solid fix and you have my thanks!

+thanks to Spoyser for the parsing fix, too.

Anyone let Nibor know about the fixes? Haven't seen any activity on his repo...

Jim


- zuccster - 2012-01-27 13:04

I've just PM'ed him.