XBMC Community Forum
[WINDOWS][PATCH]Bitstream output of HD audio formats - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Development (/forumdisplay.php?fid=93)
+--- Thread: [WINDOWS][PATCH]Bitstream output of HD audio formats (/showthread.php?tid=121877)



- DDDamian - 2012-03-09 02:41

spin-dizzy Wrote:I've searched around for the answer to this, but can't find anything pertinent. Is there a binary of the PVR branch with this patch anywhere, or do I have to learn Git and build it myself?Big Grin

I know Dado483 did some builds of the AE branch with PVR support, but I'm not aware of any with this patch. Fire up a git client and VS C++!


- bluray - 2012-03-09 03:41

voip-ninja Wrote:I work at a company that develops meeting room and conferencing software that blows Net Meeting out of the water,
I'm wondering what software is this. Can you PM me the link? Maybe, I can try it.....


- DDDamian - 2012-03-09 04:02

voip-ninja Wrote:I work at a company that develops meeting room and conferencing software that blows Net Meeting out of the water, so please feel free to try to continue educating me about the marvels of net meeting and how big companies are using it.

... now back to your regularly scheduled programming.

bluray Wrote:I'm wondering what software is this. Can you PM me the link? Maybe, I can try it.....

enough with the OT already


- fezster - 2012-03-09 12:23

fezster Wrote:Not sure if this is specific to this HD audio build, or a problem with Eden RC2 in general, but external subtitles no longer seem to work for me. I used to be able to download using the subtitles addon.

I can still download, and still enable, but no subtitles are displayed. Anyone else have this issue ?

Sorry, this had nothing to do with this build.

In case anyone makes the same mistake as me - I switched from smb to nfs, but made my nfs mounts readonly. There is an option in xbmc, which by default, downloads subtitles to your movie directory. Because the directory was not writable, the subtitles were not working.


- Dj Freddy D - 2012-03-09 19:59

bluray Wrote:Make sure you do these-

1. Make sure that you connect your system this way- HTPC-->AVR-->HDTV via two HDMI cables
2. Select AMD HDMI audio output in W7 control panel and XBMC as shown below

[Image: 28hzrmh.jpg]

[Image: w99vlg.jpg]

Per the quoted message above. I have the same settings above but my Onkyo TX-NR807 will not display that red "D" that says digital on it.

Is there any other settings that I need to be tweaking?

W7 (32bit), Radeon HD 5450, XBMC-RC2 HDAudio

And yes, Radeon Video Card drivers updated to the latest, Catalyst as well.


- bluray - 2012-03-09 20:15

Dj Freddy D Wrote:Per the quoted message above. I have the same settings above but my Onkyo TX-NR807 will not display that red "D" that says digital on it.

Is there any other settings that I need to be tweaking?

W7 (32bit), Radeon HD 5450, XBMC-RC2 HDAudio

And yes, Radeon Video Card drivers updated to the latest, Catalyst as well.
Did you see as shown below in Windows 7 Control Panel?

[Image: 28hzrmh.jpg]


- Dj Freddy D - 2012-03-09 20:54

Yes sir, exactly what you have up thereSmile


- DDDamian - 2012-03-09 21:16

Dj Freddy D Wrote:Yes sir, exactly what you have up thereSmile

Make sure you are using WASAPI exclusive. In the Avanced tab of the Windows dialog shown, select "Allow applications to take Exclusive control of this device" and "Give exclusive applications priority".

In the XBMC audio dialog make sure your audio output device is listed as "WASAPI: " + the driver name for your HDMI device.

If that fails post a link to a debug log here.


- Dj Freddy D - 2012-03-09 21:35

DDDamian thank you for your advice and support. I will try this tonight. The Allow Applications stuff you posted I have not done nor checked.

The WASAPI putput - Mine says WASAPI TX-NR807 (This is my receiver model)

If all else fails I wil post that debug log you are requesting.

Thank You Bluray and DDDamian


- bluray - 2012-03-09 21:39

Dj Freddy D Wrote:Yes sir, exactly what you have up thereSmile
If it looks the same as those two screen shots, it must be related to Onkyo settings then. Have you try to change sound mode on the remote?


- Dj Freddy D - 2012-03-09 21:41

Yes sir I have, to DTS, THX, Dolby D. PLX II however I still do not see that capital letter "D" in red.


- Dj Freddy D - 2012-03-09 21:47

Yes sir I have.

I toggled and changed them from THX S2, Dolby D, DTS and ect. but still cannot get that "D" to appear.


- DDDamian - 2012-03-09 21:51

Dj Freddy D Wrote:The WASAPI putput - Mine says WASAPI TX-NR807 (This is my receiver model)

Yeah, it should have the name of your GPU driver, nothing to do with the receiver name in that XBMC audo device box. Should say something like "WASAPI: AMD HDMI Output (AMD High Definition Audio Device)".


- bluray - 2012-03-09 21:52

Dj Freddy D Wrote:The WASAPI putput - Mine says WASAPI TX-NR807 (This is my receiver model)
That should be fine...because mine shown up as WASAPI:HT-RC270-3 (Nvidia HD), which is my Onkyo model and GPU model. It works fine with this option!


- Dj Freddy D - 2012-03-09 21:52

I will change that as soon as I get home! Update you guys after the changes are madeSmile