XBMC Community Forum
[WINDOWS][PATCH]Bitstream output of HD audio formats - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Development (/forumdisplay.php?fid=93)
+--- Thread: [WINDOWS][PATCH]Bitstream output of HD audio formats (/showthread.php?tid=121877)



RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - jack0w - 2012-03-25 15:21

Running the latest version (Eden+patch) installed and I've noticed that when playing either DD, DTS or DTS-HD files on the codec info screen the missed counter goes up rapidly - by around 10 per second. Is this expected behaviour or is this indicative of a problem?

**Just reverted to Final Eden and behaviour appears the same as in the patched version, so ignore the above. Looks to be unrelated to the patch itself.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - CpTHOOK - 2012-03-25 16:40

Dang....That was quick. Thank You! I will give it a try!


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - cyradix - 2012-03-25 18:41

(2012-03-25 15:21)jack0w Wrote:  Running the latest version (Eden+patch) installed and I've noticed that when playing either DD, DTS or DTS-HD files on the codec info screen the missed counter goes up rapidly - by around 10 per second. Is this expected behaviour or is this indicative of a problem?

**Just reverted to Final Eden and behaviour appears the same as in the patched version, so ignore the above. Looks to be unrelated to the patch itself.

Do you have sync playback to display enabled?
I have that "problem" for months now. If I enable the sync option the missed counter starts racing up (but playback seems fine).
This started months ago with the nightlies for me so way before any HD audio patch...


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - jack0w - 2012-03-25 18:52

Yes I do have sync playback to display enabled. Since my post I have tried a few more files and thus far I've not been able to spot any issues apart from that number rocketing up!

Thanks for confirming it isn't just me Smile


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - DanielaE - 2012-03-25 19:10

(2012-03-25 12:15)minimoe Wrote:  I' m having problems with this release and WMV files. XBMC can not lock the framerate.
With 30fps WMV files, the fps counter of the OSD fluctuates between 22 and 33 fps and with 25fps WMVs it's between 22 and 27fps. The drop:xx counter doesn't show any dropped frames but there are a lot of skips and jumps in the picture.
Does vanilla Eden exhibit the same behavior? Neither am I an expert in the video processing part of XBMC nor did I dare to touch it.
(2012-03-25 12:15)minimoe Wrote:  I also noticed that there is a advancedsettings.xml file in the "Program Files/xbmc/system/" folder. Is this necessary? I don't see it in a plain-vanilla Eden installation.
It's not necessary at all - I've thrown it in for a snappier UI experience. Delete it if you don't like it.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - yasan - 2012-03-25 19:20

(2012-03-25 14:35)patseguin Wrote:  Oh no, what's wrong with TrueHDConfused

sound comes stutterSad


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - DanielaE - 2012-03-25 19:22

(2012-03-25 13:59)Phantom_Zone Wrote:  Heres my Pastebin!
Which seems to be collected without debug logging enabled, thus missing the interesting info. At least I can't see an error initializing audio output.

May be the advancedsettings.xml that I've thrown in for convenience causes havoc on your setup. You may delete it.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - DanielaE - 2012-03-25 19:31

(2012-03-25 15:02)Darby Wrote:  At a bit of a loss here as to what to attempt next, my setup has been working fine for years configured like this (this is my first go with Eden in any version however, and I was not trying to get HD audio before either).
With a hardware setup like yours, jumping straight to a non-standard release with additional demands on the subtleties and intricaties of HDMI might be too big a step in the first place. Your hardware and the drivers involved here need to be solid enough to setup and maintain a HD-audio channel between XBMC and your attached AVRs. There are quite some tips in this forum in this regard.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - amdmannen - 2012-03-25 20:00

I donĀ“t have sync to display enabled.
Tested with true-hd, dts-ma and no problem at all.
Did a run with some dvd iso when my daughter sat in the sofa and no problem with that.

Thx again Smile


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - DDDamian - 2012-03-25 20:29

Hey Daniela - awesome you did the 11.0 build and added goodies Smile Haven't tried yet as I'm finally putting together a better server setup, but hope to soon. Only have one DTS-wav to test, most have been decoded to m/c PCM and flac'd for song seperation and metadata embedding, but can test with that and grab some more.

Glad you kept at it Wink


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - minimoe - 2012-03-25 20:48

(2012-03-25 19:10)DanielaE Wrote:  
(2012-03-25 12:15)minimoe Wrote:  I' m having problems with this release and WMV files. XBMC can not lock the framerate.
With 30fps WMV files, the fps counter of the OSD fluctuates between 22 and 33 fps and with 25fps WMVs it's between 22 and 27fps. The drop:xx counter doesn't show any dropped frames but there are a lot of skips and jumps in the picture.
Does vanilla Eden exhibit the same behavior? Neither am I an expert in the video processing part of XBMC nor did I dare to touch it.

No, it doesn't happen with Eden downloaded from the official site. I did some more tests and I tend to believe that the problem happens with 'non-standard' audio streams i.e. flac or WMA.
I tested a WMV with DTS sound and it run smoothly but another movie with flac sound had the same problems.

All the files I tested run smoothly with DDDamian's patched RC2


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - necrosis - 2012-03-25 20:59

Awesome Patch!! Anybody wants to setup a DL mirror? The Dropbox link isn't working anymore (too much traffic).

I really want to download and install this patch and get it all up and running asap Smile

Thanks in advance.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - DanielaE - 2012-03-25 21:06

(2012-03-25 20:48)minimoe Wrote:  No, it doesn't happen with Eden downloaded from the official site. I did some more tests and I tend to believe that the problem happens with 'non-standard' audio streams i.e. flac or WMA. I tested a WMV with DTS sound and it run smoothly but another movie with flac sound had the same problems.
Interesting! Do you happen to have a sample for me to bite and chew on?


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - necrosis - 2012-03-25 21:21

Error (509)
This account's public links are generating too much traffic and have been temporarily disabled!


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - patseguin - 2012-03-25 21:33

So is the HD Audio patch working just like it did with RC2? Wanna make sure before I bork anything. :-)