XBMC Community Forum
Beta 3 - Movie Sets - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: Beta 3 - Movie Sets (/showthread.php?tid=123522)

Pages: 1 2 3


Beta 3 - Movie Sets - UserInterface - 2012-02-21 07:58

I am still having trouble grouping movie sets.

I have enabled Settings > Libary > Group movies into sets and removed all my movies and rescraped them from TheMovieDB but not a single one gets grouped.

Can some help with what I am missing?


- rudawgr - 2012-02-21 08:30

im having the same problem can someone explain how to use and group movie set please...and also what skin work for it


- UserInterface - 2012-02-21 11:33

rudawgr Wrote:im having the same problem can someone explain how to use and group movie set please...and also what skin work for it

Interesting... I am using NEON skin if that makes a difference..


- jmarshall - 2012-02-21 22:10

My guess is you have local nfo files.


- UserInterface - 2012-02-22 01:16

jmarshall Wrote:My guess is you have local nfo files.

Good guess. I thought that xbmc would add to the nfo files..


- jmarshall - 2012-02-22 02:35

It does, but not if you have <set>, er, set.


- UserInterface - 2012-02-22 02:40

jmarshall Wrote:It does, but not if you have <set>, er, set.

Not sure what that is. My nfos are just your typical nfos if you know what I mean..


- Jaken - 2012-02-22 02:56

Take a look with notepad at one of those nfo files there you will see a <set></set> tag remove this. Or you could just delete all your nfo files.


- UserInterface - 2012-02-22 03:01

I opened up about 20 of them (most that are trilogys) and none have "set"

Wouldn't it make more sence to have movie sets stored in the database so that it does noot mess up the current nfos...


- Jaken - 2012-02-22 03:28

The nfos are there for backup in case your db is lost or corrupt and for speeding up a "rescrape".

I think whats happening is you have nfos with no set information which xbmc reads its info from and not updating the set field in the database since there is nothing in the nfos about the set.

If you however delete your nfo files, xbmc is forced too look at themoviedb and can from there require the set information. You also have to empty your xbmc library beforehand.


- UserInterface - 2012-02-22 03:34

OK that makes sence. Because I have nfos in the directory they are over riding the xbmc database.

i'll delete all the nfos (not sure what that will do to other programs though).


- gabbott - 2012-02-22 03:34

UserInterface Wrote:I opened up about 20 of them (most that are trilogys) and none have "set"

Wouldn't it make more sence to have movie sets stored in the database so that it does noot mess up the current nfos...

Think of nfo files as a way to override what a scraper is scraping. If the info is found within an nfo file, the scraper doesn't go out to the site to grab the info.


- UserInterface - 2012-02-22 03:57

I am rescraping all my movies back in now but noticed that some are not being done and some are.
e.g. all alian movies grouped, but bad boys are still seperate.

Checked themoviedb and bad boys does have information about a set.


- Jaken - 2012-02-22 04:02

Did you delete all your nfos? Bad Boys might still have them?


- UserInterface - 2012-02-22 04:04

Sorry should have said. Deleted all NFOs and double checked ones that are not working.

Only thing I noticed is that each movie is on a different drive..