XBMC Community Forum
Compilation Error of XBMC . - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Development (/forumdisplay.php?fid=93)
+--- Thread: Compilation Error of XBMC . (/showthread.php?tid=124940)



Compilation Error of XBMC . - vishwasonu - 2012-03-07 12:38

Hi ,

I am building poky working on bernard branch on Ubuntu 10.10 ,64 bit host for my fishriver machine.
I get the error in do_compile in xbmc-10.1 something like this :

***************************************
| /usr/lib/libz.so: could not read symbols: File in wrong format
| collect2: ld returned 1 exit status
| make[4]: *** [libid3tag.la] Error 1
| make[4]: Leaving directory `/home/poky_xbmc_01Dec2011/build/tmp/work/atom-poky-linux/xbmc-10.1-r0/xbmc-10.1/xbmc/lib/libid3tag/libid3tag'
| make[3]: *** [all-recursive] Error 1
| make[3]: Leaving directory `/home/poky_xbmc_01Dec2011/build/tmp/work/atom-poky-linux/xbmc-10.1-r0/xbmc-10.1/xbmc/lib/libid3tag/libid3tag'
| make[2]: *** [all] Error 2
| make[2]: Leaving directory `/home/poky_xbmc_01Dec2011/build/tmp/work/atom-poky-linux/xbmc-10.1-r0/xbmc-10.1/xbmc/lib/libid3tag/libid3tag'
| make[1]: *** [libid3tag/.libs/libid3tag.so] Error 2
| make[1]: Leaving directory `/home/poky_xbmc_01Dec2011/build/tmp/work/atom-poky-linux/xbmc-10.1-r0/xbmc-10.1/xbmc/lib/libid3tag'
| make: *** [libid3tag] Error 2
| FATAL: oe_runmake failed
| ERROR: Function 'do_compile' failed
**************************************
It seems , the build system try to use libraries from my host system. How this can happen and how it can be avoided? Please give some advice.

Thanks in advance,
Regards,
Sonu Vishwakarma