XBMC Community Forum
TVHeadend not letting me in - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: PVR Help and Support (/forumdisplay.php?fid=167)
+---- Forum: HTS Tvheadend (/forumdisplay.php?fid=168)
+---- Thread: TVHeadend not letting me in (/showthread.php?tid=125011)



TVHeadend not letting me in - gsi095 - 2012-03-08 07:05

hi,

I install XBMCbuntu, updated to the PVR build from packages.pulse-eight.net and went to configure TVHeadend and I get a log in screen.

I have tried xbmc/xbmc, the user login details, but keep getting "The server localhost:9981 requires a username & password. The server says: TVHeadend"

I did the reconfigure utility via terminal and changed the user and password but keep getting this same reply.

Am I doing something wrong??

Dave


- LastCoder - 2012-03-08 18:09

Sorry, have no idea .. try to ask in the tvheadend forum (https://www.lonelycoder.com/redmine/projects/tvheadend/boards)

Greetz

LastCoder


- j1nx - 2012-03-08 18:52

1st figure out under which user the tvheadend is running;
Quote:#ps ax | grep tvheadend
You will get out such as;
Quote:2140 ? Ssl 3:55 /usr/bin/tvheadend -f -u hts -g video
32238 pts/1 R+ 0:00 grep --color=auto tvheadend
There you will see, it runs as user "hts" (-u hts)

Go into the hts config folder for that user;
Quote:cd /home/hts/.hts/tvheadend/
Here are all setting stored. But also the config of the super user. You need to be root, so under ubuntu for instance;
Quote:sudo cat superuser
You will get an output like;
Quote:{
"username": "gsi095",
"password": "forgotthedamnthing"
}

Use those to get into the webadmin and do your things.


RE: TVHeadend not letting me in - opdenkamp - 2012-03-17 12:59

or just run:
sudo dpkg-reconfigure tvheadend

you'll be asked to enter a new password.


RE: TVHeadend not letting me in - babca - 2012-05-07 15:03

I had a similar issue, and found this:
Quote:create a file calles "1" with following content in the ~/.hts/tvheadend/accesscontrol/ directory
Code:
{
        "enabled": 1,
        "username": "*",
        "password": "*",
        "comment": "Default access entry",
        "prefix": "0.0.0.0/0",
        "streaming": 1,
        "dvr": 1,
        "webui": 1,
        "admin": 1,
        "id": "1"
}

source:
http://openelec.tv/forum/36-solved-bug-reports/3119-solved-bricked-tvheadend-manual-editing-users
http://www.lonelycoder.com/redmine/issues/166

For some reason the ~/.hts/tvheadend/accesscontrol/ directory had gone, so I had to create it again incl. the '1' file and it's OK now.


RE: TVHeadend not letting me in - nobleach - 2012-09-14 21:13

(2012-03-17 12:59)dushmaniac Wrote:  or just run:
sudo dpkg-reconfigure tvheadend

you'll be asked to enter a new password.

It doesn't matter how many times I try this, it doesn't let me in. I can see the username and password in the file, so I know I'm typing it correctly.

Does it not allow my to connect from a remote host? I can't connect from localhost, it doesn't have a web browser.


RE: TVHeadend not letting me in - Prof Yaffle - 2012-09-15 00:13

Have you played with the IP address config at all? Could it be that you're connecting from a PC that doesn't have admin rights because of its IP address?

I can't remember off the top of my head, but I wonder if tvheadend defaults to localhost unless you change it... so are you connecting from the machine hosting tvheadend, or a different one?

Have a look at ~/.hts/tvheadend/accesscontrol and see what's in there...


RE: TVHeadend not letting me in - nobleach - 2012-09-15 00:20

Yep, originally had it set to 0.0.0.0/0. I changed it to 192.168.1.0/24 just to see if it would change the outcome. I also SSHed in and used lynx to localhost:9981. It fails just the same.

Unless there's somewhere else to change it.


RE: TVHeadend not letting me in - thatsenough - 2012-09-16 12:41

Try start tvheadend with -C. This will create a user account with no username/password if no user exists already. Then you can get access and create a new user.

That did it for me.


RE: TVHeadend not letting me in - lachs - 2013-01-07 02:52

(2012-09-15 00:20)nobleach Wrote:  Yep, originally had it set to 0.0.0.0/0. I changed it to 192.168.1.0/24 just to see if it would change the outcome. I also SSHed in and used lynx to localhost:9981. It fails just the same.

Unless there's somewhere else to change it.

I had the same problem but when i ran:

cat /home/username/.hts/tvheadend/accesscontrol/1

it displayed:

root@LachsMC:/home/lachs/.hts/tvheadend/accesscontrol# cat 1
{
"enabled": 1,
"username": "xbmc",
"password": "xbmc",
"comment": "Default access entry",
"streaming": 1,
"dvr": 1,
"dvrallcfg": 1,
"webui": 1,
"admin": 1,
"id": "1"
}

showing me that despite setting up my own password with the initial tvheadend config it is using xbmc/xbmc as the user/pass still...
Hope this helps...


RE: TVHeadend not letting me in - shess757 - 2013-09-17 16:16

(2013-01-07 02:52)lachs Wrote:  
(2012-09-15 00:20)nobleach Wrote:  Yep, originally had it set to 0.0.0.0/0. I changed it to 192.168.1.0/24 just to see if it would change the outcome. I also SSHed in and used lynx to localhost:9981. It fails just the same.

Unless there's somewhere else to change it.

I had the same problem but when i ran:

cat /home/username/.hts/tvheadend/accesscontrol/1

it displayed:

root@LachsMC:/home/lachs/.hts/tvheadend/accesscontrol# cat 1
{
"enabled": 1,
"username": "xbmc",
"password": "xbmc",
"comment": "Default access entry",
"streaming": 1,
"dvr": 1,
"dvrallcfg": 1,
"webui": 1,
"admin": 1,
"id": "1"
}

showing me that despite setting up my own password with the initial tvheadend config it is using xbmc/xbmc as the user/pass still...
Hope this helps...

Had same problem tried xbmc/xbmc and it worked, just wanted to update this post.