XBMC Community Forum
[RELEASE] XBMC Subtitles - Addon Script - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Subtitle Add-ons (/forumdisplay.php?fid=143)
+---- Thread: [RELEASE] XBMC Subtitles - Addon Script (/showthread.php?tid=126495)



RE: [RELEASE] XBMC Subtitles - Addon Script - MatsF - 2012-04-02 08:55

Substitute masterprofile/addon_data doesn´t work for XBMC Subtitles

Maybe this is the right place for this post.
Hi,

The only discussion I have found about this is in this post . There it says that we can´t use substitute addon_data to have it centralized, at least not to an smb-share.
I want to have everything I can centralized and for that reason I have created all substitutions that I can for all my 5 instances of XBMC in my home. But when i am doing a substitute for masterprofile/addon_data I get the same problem as kri kri in the above post, the Subtitle download stops working. I have got the same error as kri kri but now I get some other errors, different in OSX and Win7(!)

This is what I do in advancedsettings.xml:

<substitute>
<from>special://masterprofile/addon_data/</from>
<to>smb://ComputerName/XBMC/userdata/addon_data</to>
</substitute>

I did almost the same in OSX and Win7:
I put debug on
closed and then opened XBMC
Started the same episode.
Tried to get a subtitle (automatic download of synced subtitle). In Win7 I also tried to manually download a synced subtitle from Bierdjope.

And then:
In both OSX and Win7 the settings.xml is read and written to the substituted directory.
In both OSX and Win7 the zip-file is saved locally and not in the substituted directory (why not?).
In Win7 it is trying to copy the srt-file from the local directory to the episode directory. It also seems to do different things depending on if it is using Opensubtitles (trying automatic download of synced subtitle) or Bierdjope (manual download). It also doesn't say any error that it is not working (although I have seen an error before, just like kri kri in the linked post above. But the copy doesn't work for some reason.
In OSX it is trying to open the just (locally) downloaded from the substituted directory(!) The same zip-file exist there so it gets that srt-file instead.

It looks odd, doesnt it?

Here are the logs (I hope I did this right):
Win7 Log
OSX Log


RE: [RELEASE] XBMC Subtitles - Addon Script - Thakoer - 2012-04-02 20:21

Today i want to see the movie the darkest hour. On the site of ondertiteling.com i can see the subtitle. But if i seatcht this on the xbmc no results. I have tried this manualy to.. No results.
The strange is that older movies like hangover 2 etc ik can find the subtitles, but I suspect that the new subtitels on 31 march 2011 not be can found. very strange...for de latest update was very good !

Any solutions. Thanks


RE: [RELEASE] XBMC Subtitles - Addon Script - jag00 - 2012-04-03 11:04

Podnapisi.net is not working in 3.0.0. (searches, but nothing found). Other services work fine.

If I revert to 2.5.16 Podnapisi works, without changing any settings or login information.

This is using XBMC 11.


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-03 11:07

(2012-04-03 11:04)jag00 Wrote:  Podnapisi.net is not working in 3.0.0. (searches, but nothing found). Other services work fine.

If I revert to 2.5.16 Podnapisi works, without changing any settings or login information.

This is using XBMC 11.

you have entered the login correctly? Debug Log please


RE: [RELEASE] XBMC Subtitles - Addon Script - ThumbGen - 2012-04-03 11:25

@amet: you wrote sooo many times "debug log" please ... :-) Why don't you put a BIG and VISIBLE link in your signature: "If you report a bug in the subtitles addon and you expect an answer please attach a DEBUG LOG to your report" :-) Amazing how much patience you have....


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-03 11:32

(2012-04-03 11:25)ThumbGen Wrote:  @amet: you wrote sooo many times "debug log" please ... :-) Why don't you put a BIG and VISIBLE link in your signature: "If you report a bug in the subtitles addon and you expect an answer please attach a DEBUG LOG to your report" :-) Amazing how much patience you have....

lol, yeah.. then I get told I am "angry" Smile

thing is I somehow expect the reasonable amount of common sense, if you are looking for help, you need to provide whats wrong... doesnt always work like that.

you are welcome to tell new users that we need the log when you see that its not there Smile


RE: [RELEASE] XBMC Subtitles - Addon Script - Thakoer - 2012-04-03 11:52

Hi amet,

Can you tell me what could by me the problem ?
Ha the debug log you need.


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-03 11:58

(2012-04-03 11:52)Thakoer Wrote:  Hi amet,

Can you tell me what could by me the problem ?
Ha the debug log you need.

Debug Log?


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-03 12:03

@ThumbGen

better? -> http://forum.xbmc.org/showthread.php?tid=126495&pid=1055030#pid1055030 Smile


RE: [RELEASE] XBMC Subtitles - Addon Script - gadus - 2012-04-03 15:07

Hi I got a problem resolving subtitles from a plugin created by anilkuj from xbmchub.com
The plugin is called "OneClickMovieZ" I installed It from his repo
Movies play fine from several host, but when I try to pull a (Dutch) sub from one off these subhosts, ondertitels.com, opensubtitles.org or podnapisi.net
Nothing happens !
Example movie "Snowtown":
When I try a manual search on XBMC Subtitles I see It Is trying to lookup "OneClickMovieZ Com-Snowtown CrEwSade ()"
Then I edit this to "Snowtown" or "Snowtown 2011" and I get 5 perfectly working subtitles to choose from

I contacted anilkuj and he looked Into the log an couldn't find anything
He suggested to have a look over here, maybe one off you guys have a suggestion ?

Iam on Windows 7, XBMC Eden 11.0, skin Transparency! 4.0.5, XBMC Subtitles 3.0.0, OnceClickMoviez 0.1.4

http://pastebin.com/jDr1PLSf


RE: [RELEASE] XBMC Subtitles - Addon Script - Thakoer - 2012-04-03 16:33

(2012-04-03 15:07)gadus Wrote:  Hi I got a problem resolving subtitles from a plugin created by anilkuj from xbmchub.com
The plugin is called "OneClickMovieZ" I installed It from his repo
Movies play fine from several host, but when I try to pull a (Dutch) sub from one off these subhosts, ondertitels.com, opensubtitles.org or podnapisi.net
Nothing happens !
Example movie "Snowtown":
When I try a manual search on XBMC Subtitles I see It Is trying to lookup "OneClickMovieZ Com-Snowtown CrEwSade ()"
Then I edit this to "Snowtown" or "Snowtown 2011" and I get 5 perfectly working subtitles to choose from

I contacted anilkuj and he looked Into the log an couldn't find anything
He suggested to have a look over here, maybe one off you guys have a suggestion ?

Iam on Windows 7, XBMC Eden 11.0, skin Transparency! 4.0.5, XBMC Subtitles 3.0.0, OnceClickMoviez 0.1.4

http://pastebin.com/jDr1PLSf


My problem is: old movie I get the subtitles with no problem.
but the new add subtitles like the darkest hour no results, tried manualy also no results. strange! (ondertitels.com, opensubtitles.org )
I use 1channel en icemovie but today I try OneClickMovie.


RE: [RELEASE] XBMC Subtitles - Addon Script - Thakoer - 2012-04-03 18:05

Today i want to see the movie the darkest hour. On the site of ondertiteling.com i can see the subtitle. But if i seatcht this on the xbmc no results. I have tried this manualy to.. No results.
The strange is that older movies like hangover 2 etc ik can find the subtitles, but I suspect that the new subtitels on 31 march 2011 not be can found. very strange...for de latest update was very good !

Any solutions. Thanks
I try now for the movie new year eve..als no results.

http://pastebin.com/HT6zJsG9


RE: [RELEASE] XBMC Subtitles - Addon Script - ThumbGen - 2012-04-03 20:42

(2012-04-03 12:03)amet Wrote:  @ThumbGen

better? -> http://forum.xbmc.org/showthread.php?tid=126495&pid=1055030#pid1055030 Smile

Great! Now let's see if it brings some (positive) results Smile


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-03 20:48

(2012-04-03 18:05)Thakoer Wrote:  Today i want to see the movie the darkest hour. On the site of ondertiteling.com i can see the subtitle. But if i seatcht this on the xbmc no results. I have tried this manualy to.. No results.
The strange is that older movies like hangover 2 etc ik can find the subtitles, but I suspect that the new subtitels on 31 march 2011 not be can found. very strange...for de latest update was very good !

Any solutions. Thanks
I try now for the movie new year eve..als no results.

http://pastebin.com/HT6zJsG9

^^^ not a Debug Log, read the link carefully


RE: [RELEASE] XBMC Subtitles - Addon Script - gadus - 2012-04-03 22:09

Quote:^^^ not a debug log, read the link carefully

Hope this Is what you are looking for ?
First auto search, no results, second time manually with perfect working subs
http://pastebin.com/EQE9TYBD