XBMC Community Forum
[solved] NFS - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: [solved] NFS (/showthread.php?tid=127191)



[solved] NFS - mauzzz - 2012-03-30 16:46

I have trouble setting up NFS on Eden.

Add videos -> browse -> nfs
nfs server is shown
shares are shown but can't browse or select them
-> ok

Select source in file view shows only a list of the nfs shares. Can't browse to subfolders. Where does Eden place the exported path? I can't find the files.

I have a working setup on the same box (Openelec Dharma) with NFS to my NAS. So i know the server is ok.


RE: NFS - mr.sparkle - 2012-03-30 16:57

Quote:Where does Eden place the exported path? I can't find the files.
Just browse to where you mounted the files like you would a local folder. Can you navigate and read/write to the folders from a terminal?


RE: NFS - Memphiz - 2012-03-30 16:59

you missed the wiki entry which says you have to activate the nfs server for allowing connections from privileged ports. Its just about adding the "insecure" flag into the exports line (speaking for a linux nfs server). Read the NFS Wiki entry i linked to in my signature and do the right thing for your nfs server.


RE: NFS - mauzzz - 2012-03-31 12:05

@Memphiz Thanks, I applied those changes months ago but they must have gone lost after a firmware update of my NAS. Blush Everything works great now.


RE: NFS - harkonian - 2012-04-17 03:20

I'd like to point out one missing step in the wiki for setting up NFS on a Synology server -- I'm sure this is painfully obvious to some (and I feel like an idiot for not seeing it sooner): when you ssh into the server **you are not in the root directory**, you are in the user subdir and need to cd .. to get to the root dir. I spent way too long chasing butterflies wondering how there wasn't an etc directory. Undecided


(2012-03-30 16:59)Memphiz Wrote:  you missed the wiki entry which says you have to activate the nfs server for allowing connections from privileged ports. Its just about adding the "insecure" flag into the exports line (speaking for a linux nfs server). Read the NFS Wiki entry i linked to in my signature and do the right thing for your nfs server.



RE: NFS - Memphiz - 2012-04-17 11:09

(2012-04-17 03:20)harkonian Wrote:  I'd like to point out one missing step in the wiki for setting up NFS on a Synology server -- I'm sure this is painfully obvious to some (and I feel like an idiot for not seeing it sooner): when you ssh into the server **you are not in the root directory**, you are in the user subdir and need to cd .. to get to the root dir. I spent way too long chasing butterflies wondering how there wasn't an etc directory. Undecided

The wiki allways refers to the absolute path (that is /etc/exports). It doesn't matter in which directory you are when using absolute pathes. I see nothing missing in the wiki.


RE: [solved] NFS - loeffel - 2012-04-17 11:40

When using USB drives on Synology NAS in combination with NFS shares the "insecure" option will changed back to "insecure_locks" on each NAS reboot. So XBMC is not able to access the NFS share any longer (tested on DS211j latest DSM 4.x).

To solve this I tried using the 3rd party application "autorun" to change the exports file when connecting the USB drive to the NAS. But autorun will be triggered by plugin the drive and not during a restart or similar.

The final solution was to change the exports file on NAS startup by adding a "sed" (sed -i 's/insecure_locks/insecure/g' /etc/exports) text change within the NFS startup script and using exportfs -ra afterwards.

I'm not sure if this has to be added to the wiki, but it could help someone who's running into the same issue.


[solved] NFS - Memphiz - 2012-04-17 23:13

everybody can alter the wiki - feel free to add it Smile


RE: NFS - bobdude - 2012-05-03 21:04

(2012-03-30 16:59)Memphiz Wrote:  you missed the wiki entry which says you have to activate the nfs server for allowing connections from privileged ports. Its just about adding the "insecure" flag into the exports line (speaking for a linux nfs server). Read the NFS Wiki entry i linked to in my signature and do the right thing for your nfs server.

Hi Memphiz,

I actually have the same problem.
This is my /etc/export on my synology DS212+
Code:
/volume1/Media  192.168.1.0/24(rw,async,insecure,no_root_squash)
/volume1/Thumbnails     192.168.1.0/24(rw,async,insecure,no_root_squash)
/volume2/Media2 192.168.1.0/24(rw,async,insecure,no_root_squash)

I can mount the nfs shares on os level, however, browsing nfs shares in XBMC will only show shares on localhost, not on the DS.
Any ideas?

Thanks,
Stefan


RE: [solved] NFS - Memphiz - 2012-05-03 22:55

what if you add the nfs url manually without using the nfs browser? nfs://ip/nameofexport/ ...


RE: [solved] NFS - bobdude - 2012-05-04 15:09

I reinstalled everything today, so I can browse NFS shares now.
adding them manually has always worked, to answer your question.

I have some really weird problems with my NAS, so I have to check into some things anyway.
so everything is fine for now here.
Thanks for replying.


RE: [solved] NFS - Kaba - 2013-04-02 19:47

(2012-04-17 11:40)loeffel Wrote:  When using USB drives on Synology NAS in combination with NFS shares the "insecure" option will changed back to "insecure_locks" on each NAS reboot. So XBMC is not able to access the NFS share any longer (tested on DS211j latest DSM 4.x).

To solve this I tried using the 3rd party application "autorun" to change the exports file when connecting the USB drive to the NAS. But autorun will be triggered by plugin the drive and not during a restart or similar.

The final solution was to change the exports file on NAS startup by adding a "sed" (sed -i 's/insecure_locks/insecure/g' /etc/exports) text change within the NFS startup script and using exportfs -ra afterwards.

I'm not sure if this has to be added to the wiki, but it could help someone who's running into the same issue.

Can somebody explain, with file and how exactly i must modify ?


RE: [solved] NFS - kyub - 2013-06-24 23:04

(2012-04-17 11:40)loeffel Wrote:  When using USB drives on Synology NAS in combination with NFS shares the "insecure" option will changed back to "insecure_locks" on each NAS reboot. So XBMC is not able to access the NFS share any longer (tested on DS211j latest DSM 4.x).

To solve this I tried using the 3rd party application "autorun" to change the exports file when connecting the USB drive to the NAS. But autorun will be triggered by plugin the drive and not during a restart or similar.

The final solution was to change the exports file on NAS startup by adding a "sed" (sed -i 's/insecure_locks/insecure/g' /etc/exports) text change within the NFS startup script and using exportfs -ra afterwards.

I'm not sure if this has to be added to the wiki, but it could help someone who's running into the same issue.

I've searched everywhere to try find out how to do this. Can you please provide the full steps to do so? Or anyone else, if they know how which file to edit and how via ssh. Smile