XBMC Community Forum
[Windows] MySQL library missing information - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: [Windows] MySQL library missing information (/showthread.php?tid=129848)



MySQL library missing information - JRP72 - 2012-04-24 20:57

Please forgive me if this problem is really basic.

I am trying to set up a central DB for multi room use of XBMC. I was running Darma (until yesterday) and before upgrading to Eden I exported my libraries (video and music). I installed Eden and everything was running smoothly. All the entries seemed to be there and the libraries were intact.

Trying to set up the multiroom ...
I followed the Wiki (http://wiki.xbmc.org/index.php?title=HOW-TO:Sync_multiple_libraries) and installed MySQL, set up XBMC (including the advancedsettings.xml file) however, here the the problem:

The TV room contains the information for the TV programs (list of all shows, a description and all the thumbs are there) however, none of the episodes show up. The list is blank. I can still access these using the "file" method.
The movies room contains only some of the movies (maybe 1/16 of the total list of movies)
The music room seems to be working fine, but this is working as a list of files and I can navigate my movies and TV shows.

I really do not know where to start. I downloaded HeidiSQL (another thread advised this to see if your DBs exist) and my databases seem to be there.

This is what is in the advancedsettings file:
<advancedsettings>
<videodatabase>
<type>mysql</type>
<host>192.168.1.105</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
</videodatabase>

<musicdatabase>
<type>mysql</type>
<host>192.168.1.105</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
</musicdatabase>
</advancedsettings>


Any suggestions on what could be wrong?

THanks
JP


RE: MySQL library missing information - JRP72 - 2012-04-24 23:52

I have narrowed down the problem a little bit more.

The libraries are fine until I put the advancedsettings file into my userdata folder (Users/.../AppData/Roaming/XBMC/userdata)

Once the file is there and I start XBMC the only movies that appear are the ones that contain AUDIO_TS and VIDEO_TS directories in the movie directory. All the movies that are AVI or other format do not appear anymore. The TV shows are all AVI or other, and hence do not appear either. Each movie is contained in its own directory (by name) and the TV shows by show name and season.

JP


RE: MySQL library missing information - JRP72 - 2012-04-25 02:12

I set my sources according to this thread :http://forum.xbmc.org/showthread.php?tid=126465&highlight=mysql+databas
and scanned everything again.

JP