XBMC Community Forum
Video decoding problems on Mavericks - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Mac OS X support (/forumdisplay.php?fid=56)
+---- Thread: Video decoding problems on Mavericks (/showthread.php?tid=177426)

Pages: 1 2


Video decoding problems on Mavericks - doug316 - 2013-11-07 04:07

Assuming the same issue as on this thread.

On my MacMini, using various Gotham builds. Everything has been fine up until Mavericks upgrade. No issues on MacBook.

Note overlays are fine.

[Image: xbmc-video-problem.png]

Anyone else seeing this? Any ideas for a fix?


RE: Video decoding problems on Mavericks - shotsboy123 - 2013-11-08 16:04

Got exactly the same problem, trying to get onto Navi-X and tried other software. The same interlacing problem occurs.. any fix found?


RE: Video decoding problems on Mavericks - marshalleq - 2013-11-12 09:35

I've got this same issue on Late 2012 Mac Mini. It only happens on some files (not very many actually but happens every time). Same files play on XBMC on Raspberry Pi Perfectly fine.

To get around it, switching the XBMC on Mac mini to software decoding works.

Unfortunately that makes XBMC crash more than it already does (on OSX Mavericks with XBMC13.0Alpha 9)


RE: Video decoding problems on Mavericks - marioslink1 - 2013-11-15 05:18

I've got this same issue.. any helpConfused


RE: Video decoding problems on Mavericks - Milupa - 2013-11-15 22:26

Same over here on a Mac Mini Late 2012.


RE: Video decoding problems on Mavericks - Gigantur - 2013-12-02 11:08

Just a hunch - this is the only explanation I can find for it coming good for me (as it did) - do a clean install (including deleting the userdata folder)


RE: Video decoding problems on Mavericks - Ned Scott - 2013-12-03 03:30

(2013-12-02 11:08)Gigantur Wrote:  Just a hunch - this is the only explanation I can find for it coming good for me (as it did) - do a clean install (including deleting the userdata folder)

If someone tries this, try saving a backup of the old userdata folder and then maybe we can find which setting (probably in guisettings.xml) is the cause for the issue.


RE: Video decoding problems on Mavericks - Memphiz - 2013-12-05 21:41

Its not guisettings related but some issue in the intel drivers in mavericks (this is an assumption).

Please try and report back:

http://mirrors.xbmc.org/test-builds/osx/i386/xbmc-20131205-c1018bb-fixripple2-i386.dmg


RE: Video decoding problems on Mavericks - Milupa - 2013-12-08 20:49

Sems to work fine after a quick test. Will report my experiences when i tried to play some files.

In the meantime thank you very much for your support!


RE: Video decoding problems on Mavericks - volcom45 - 2013-12-11 06:18

Works as it should after this test build! Huge props to you Memphiz!! So glad to have this behind me!


RE: Video decoding problems on Mavericks - lesarros - 2013-12-13 01:10

Works like a charm!
At 10.8.x and cause a lot of problems,most with audio for me,after some months go back to xbmc 11 (eden).
But now with 10.9 start xbmc 11 to have problems like 12.x etc
I nstalled yesrteday night the version of Memphiz recommended for 10.9 and has no problem.
Tested 1080p,720p,sd and audio with dts,,dd5.1,arc.2.0 & 5.1 and mp3.
No problems at all and with official skin of xbmc.
With other skins i had problems!


RE: Video decoding problems on Mavericks - Memphiz - 2013-12-13 12:29

This fix is commited to mainline and will be available in the next nightly build (at least if our server issues are sorted by then).


RE: Video decoding problems on Mavericks - Gigantur - 2013-12-14 01:05

Is there an x86-64 version of this test build ?

Happy to test if so - latest nightly still shows artifacts with the sample mkv from this post http://forum.xbmc.org/showthread.php?tid=175120


Video decoding problems on Mavericks - Memphiz - 2013-12-14 10:16

our servers are still influenced (read xbmc.org) leading that there are no nightly builds uploaded atm. Just be a bit mor patient while we are moving stuff to a new server - in a couple of days the nightlies should be up and running again and then there will be a 64bit version of this aswell.


RE: Video decoding problems on Mavericks - Gigantur - 2013-12-17 14:58

Got it. Artifacts are gone and all is good in the world again Smile