XBMC Community Forum
[Mac OS X] Audio sync off with refresh rate switching (nightly builds) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Mac OS X support (/forumdisplay.php?fid=56)
+---- Thread: [Mac OS X] Audio sync off with refresh rate switching (nightly builds) (/showthread.php?tid=186201)

Pages: 1 2 3 4 5


Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-02-14 00:22

Audio has to be delayed by around 100 ms to get it to sync with video. Sometimes seeking throws the sync completely off, by several seconds, but seeking again fixes it. I haven't been able to find any setting which would fix this expect disabling refresh rate switching completely.

I'm currently on the OSX audio engine test build but this same happened with regular nightly builds when i tested them few weeks ago.

Setup is HDMI to amp to TV. Everything set to 2ch and passthrough enabled.

http://pastebin.com/dRRDGifA


RE: Audio sync off with refresh rate switching (nightly builds) - Memphiz - 2014-02-24 14:07

Please try a current nightly build.


RE: Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-02-24 17:07

It was still there with yesterdays build. I'll try to come up with more detailed explanation when it happens. But it seems SmallStepBack or whatever the function name often throws the sync way off.


RE: Audio sync off with refresh rate switching (nightly builds) - davilla - 2014-02-25 05:46

100 ms is not 'way off'


RE: Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-02-25 08:21

Where did I say it is? But it is off enough to be able to see and hear it with your eyes and ears.

I said that skipping will cause the sync to go off by several seconds. It seems to be trying to catch up again and failing, it's easier to stop the video and start it again.


RE: Audio sync off with refresh rate switching (nightly builds) - idioteque - 2014-02-28 19:44

hi spacemonkey
did it get fixed?


RE: Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-02-28 19:49

It seems audio stays in sync if you don't seek or pause the video or do anything of that sort. So it's not off by 100ms anymore.

I'm having so many issues (this, loss of HDMI audio after suspend, video tearing or whatever the correct term is (although it's not as bad as it was in nightlies months ago) that i would be better off with my own thread Big Grin


RE: Audio sync off with refresh rate switching (nightly builds) - FlangeMonkey - 2014-03-02 02:52

I've also been experiencing audio sync issues, but at times, its much more than 100ms, it get to seconds on some media. Thinking about it, it was off when I was on 10.9 but I put this down to the Video Tearing issues. I downgraded to 10.6.8 as I couldn't find a solution. Over the last could of weeks, I've been thinking the audio was off slightly, but recently the seconds have forced me to revert to a windows box.

What OSX flavor are you on?

Do you find some media is worse than others?


RE: Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-03-02 10:35

I too downgraded to 10.6.8 because of the tearing in 10.9.x. Did that just yesterday so i don't have any experience yet if it helps with this.


RE: Audio sync off with refresh rate switching (nightly builds) - FlangeMonkey - 2014-03-02 11:58

For me DTS and DD have sync issues in 1080p. The 720p content I tested in DTS or DD seem bang on. Looking at older video's I've already watched, I get the same results so I think it's something on the new nightly's on osx.


RE: Audio sync off with refresh rate switching (nightly builds) - Memphiz - 2014-03-05 14:07

Please someone elaborate on that ticket:

http://trac.xbmc.org/ticket/14977


RE: Audio sync off with refresh rate switching (nightly builds) - idioteque - 2014-03-06 20:37

it also happens with Beta 1 Gotham. When Adjust TV refresh rate to source is turned off, the all is in sync. It appears that the wait period is not passed through to audio


RE: Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-03-06 22:34

I don't think that's the case, it did wait 5 seconds like i had set it.

Snow Leopard seems fine, no issues so far. Maybe some day i'll learn to stick with it instead of upgrading. Tongue


RE: Audio sync off with refresh rate switching (nightly builds) - Rassi - 2014-03-16 11:31

I'm having the same issue running XBMC 13 nightly (xbmc-20140306-1cba479-Gotham-i386.dmg) on Mac Mini 5,1 with OS X 10.7.5

(2014-03-05 14:07)Memphiz Wrote:  Please someone elaborate on that ticket:

http://trac.xbmc.org/ticket/14977
This ticket does not seem related, but I found http://trac.xbmc.org/ticket/14978 which looks more like it.

Here are logs:
Log with "Adjust refresh" turned on (sync issues)
Log with "Adjust refresh" turned off (no issues)

The logs show me:
  • start video
  • StepForward
  • SmallStepBack
  • SmallStepBack
  • rewind x2 a little

According to the bug, fritsch would like GetDelay logging, but I don't know how to get that. I've googled a little but didn't get wiser. So if that is necessary, please advise.


RE: Audio sync off with refresh rate switching (nightly builds) - SpaceMonkey - 2014-03-16 11:43

Sounds like a test build is needed where it logs something extra. I'd be happy to test it.