XBMC Community Forum
Bad video playback quality on Mac OS X - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Mac OS X support (/forumdisplay.php?fid=56)
+---- Thread: Bad video playback quality on Mac OS X (/showthread.php?tid=187138)

Pages: 1 2


Bad video playback quality on Mac OS X - Lemmy - 2014-02-21 17:34

Hi,

I'm running XBMC 12.3 on Mac OS 10.6.8 (yes i know, old, let's not go there, thanks).

I have a number of highres MKV files that "look like crap" (sorry, no other term comes to mind) when playing in XBMC, but they look crystal-clear if I play them with MPlayer Extended for Mac OS X.

Is there a way to improve XBMC in that area? Replace the codecs that come with it, or maybe even recompiling it with different options?

What kind of information would help someone here to help me fix this?

Cheers,
MH


RE: Bad video playback quality on Mac OS X - wgstarks - 2014-02-21 17:44

Screenshots would be very good. A debug log might provide some useful info as well as a Mediainfo report from one of the videos.

IMO 10.6.8 is probably the best OS to use with xbmc. I don't think that is the source of your problems.


RE: Bad video playback quality on Mac OS X - Lemmy - 2014-02-21 17:53

ok here are three screenshots.
The first one: a video playing fullscreen in MPlayer Extended
[Image: UGqulwQ.jpg]
The second: same video in XBMC
[Image: g4mF9MJ.png]
Third: same video in XBMC with the file info showing.
[Image: lSPJhtX.png]

Next will be debug logs, hang on for a bit.


RE: Bad video playback quality on Mac OS X - wgstarks - 2014-02-21 18:21

(2014-02-21 17:53)Lemmy Wrote:  ...how do i take a screenshot on Mac OS X with XBMC running a video?

I think screenshots are mapped to Cntl-s in xbmc and would be saved to whatever location you have set for them in your system settings. You could also switch xbmc to windowed mode and take the screenshot from Finder (command shift 3).

I use Snapz Pro X but this is not free. They do have a free trial though.


RE: Bad video playback quality on Mac OS X - Lemmy - 2014-02-21 18:28

debug log is here:
http://xbmclogs.com/show.php?id=135547


RE: Bad video playback quality on Mac OS X - jmarshall - 2014-02-22 03:34

Anime -> 10bit.

Try switching shader support (settings->video->player) till you get the appropriate image.


RE: Bad video playback quality on Mac OS X - Lemmy - 2014-02-22 09:40

won't that mess with the quality of other videos? Right now I have that on auto, I've already tried GLGS with no success.


RE: Bad video playback quality on Mac OS X - Lemmy - 2014-02-22 12:39

I can set the shaders to one out of "Auto", "Software", "Basic", and "Advanced (GLGS)". On Software I don't get any picture at all, and any of the rest gives me the bad image from the screenshots.
Worth a try tho. Any other things I could try?


RE: Bad video playback quality on Mac OS X - jayword - 2014-02-22 21:37

I would note that I do think there is a relatively widespread issue here. I see visual glitches similar to the screenshot from OP. I have several files that play perfectly in VLC 2.1 on Mavericks but have all kinds of video glitches in XBMC 12.3 as well as the 2/21/14 Gotham nightly. The files I'm dealing with are straight unmodified Blu-ray rips.

I have tried switching between Auto and Advanced shaders to no avail. Have not tried Software or Basic. Happy to post screenshots/logs as well as the OP, but will assume that OP's data is sufficient.


RE: Bad video playback quality on Mac OS X - jmarshall - 2014-02-22 23:23

I played 3 separate 10bit samples last night on current master. Regardless of what settings I configured (with the exception of Software which appears broken - will investigate) they played perfectly.

Thus, it's something to do either with versioning of the OS or a particular file or something else.

I'd suggest the first step is to get everyone testing the same file. i.e. provide a sample that CLEARLY shows the fault. If necessary, screenshot exactly what to look for.

Then several folk can test and we can start narrowing things down.


RE: Bad video playback quality on Mac OS X - Lemmy - 2014-02-23 11:28

I don't think it is something "to do with a particular file", since it pretty much hits half of what I have in my XBMC library right now... all animes, all .mkv, all h264 encoded as far as i can see. Will "take a survey" later (much later, 1wk business trip coming).


RE: Bad video playback quality on Mac OS X - jmarshall - 2014-02-24 06:17

What I mean is that you know what to look for in the particular file (whatever it may be). All I can do is download random 10bit files and hope I see something similar to what you describe.

Without testing the same sample, we're still in guessing mode and not in troubleshooting mode.


RE: Bad video playback quality on Mac OS X - davilla - 2014-02-24 06:42

do a ful -> widowed -> full cycle and report back. "\" will toggle it.


RE: Bad video playback quality on Mac OS X - jayword - 2014-02-24 08:36

At least in my case, full/windowed doesn't seem to change anything. Here's a screenshot of what I see:

[Image: YPfiS8H.png]

Many other Blu-rays have the same issue, some of them like Cleopatra are apparent for most of the movie. Others like this shot from GoT last only a second or so.

Here it is with the detail overlay:

[Image: vFB9vce.png]


RE: Bad video playback quality on Mac OS X - jmarshall - 2014-02-24 08:45

That's a different issue. The OPs problem is 10bit specific.