XBMC Community Forum
xTV (Apple TV take 1 replica/clone) skin is in the XBMC Skinning Project's SVN - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Skin Help and Support (/forumdisplay.php?fid=67)
+---- Forum: xTV SAF (/forumdisplay.php?fid=76)
+---- Thread: xTV (Apple TV take 1 replica/clone) skin is in the XBMC Skinning Project's SVN (/showthread.php?tid=24617)



- Jeroen - 2008-06-02 19:12

Allright, I added some basic fanart support. No dedicated fanart viewtype, but fanart appears in the already existing viewtypes like it does in PM3 for instance.

I added a button to enable or disable fanart. You can find it in the background section of the skin settings screen. I also added a button that can dim the fanart a bit if text becomes a bit hard to read, for instance if you have a lot of bright fanart images.

I also corrected a bug in this screen. The "visuals behind background" button actually enabled when disabling and vice versa.

There's 3 files to edit.

- First copy the code below and paste it into the file "includes.xml" in the PAL directory
http://pastebin.com/f1e0f8ceb

- Copy the code below and paste it into the file "custom59_BackgroundSettings.xml", also in the PAL directory
http://pastebin.com/f1549c85c

- And finally copy and paste the code below into the file "strings.xml" in the Language\English directory. This file is to make the text on the buttons localizable.
http://pastebin.com/f4fb4c85f

In all cases completely replace the old code.

Make a copy of the old files, just to be on the safe side (no this mod will not blow up your xbox Smile )


- Jeroen - 2008-06-02 19:16

Hold on, you need a button to get the fanart in the first place duh Rolleyes
Update later Big Grin


- Jeroen - 2008-06-02 19:23

So, in addition to the instructions in my previous post you will also need to edit the dialogvideoinfo.xml file. Use the code below
http://pastebin.com/f215cd494

This one has the trailer fix I posted earlier as well.


Mod I made - rtwight - 2008-06-02 20:52

I added the trailer button as well (but not the fan art).

I also added a line that displayed the filename of the selected file as well (used it so I could fix improperly scrapped files).

Here is my dialogvideoinfo.xml file. I did the trailers a little different than Jeroen, not sure which is the better way... I did notice that mine goes back to the movie list and not the movie info screen, maybe Jeroen goes back tothe info screen.

http://pastebin.com/m7b9f91bf

I had included this in another thread, but thought i would add it here as well Smile

Any feedback is appreciated as this is my first mod of a skin that I have done.


- RenZ0R - 2008-06-02 21:51

awesome work guys, the dim option dont seem to work, is there a userset value I can add somewere ?


- Jeroen - 2008-06-02 22:25

RenZ0R Wrote:awesome work guys, the dim option dont seem to work, is there a userset value I can add somewere ?

Strange, working correctly here. Maybe it just isn't noticable enough?

Try this. Look for this code in includes.xml:

Code:
<control type="image">
<description>Fanart background</description>
<posx>0</posx>
<posy>0</posy>
<width>720</width>
<height>576</height>
<info>FanArt.Image</info>
<visible>[Container.Content(seasons) | Container.Content(episodes)] + Skin.HasSetting(FanartEnable)</visible>
<animation effect="fade" start="100" end="80" time="0" condition="[Player.HasAudio | Player.HasVideo + !Skin.HasSetting(HomeViewToggle)]">Conditional</animation>
<animation effect="fade" start="100" end="70" time="0" condition="Skin.HasSetting(FanartDim)">Conditional</animation>
</control>

Try lowering the end value on the last line and see if that makes a difference. Don't understand why it wouldn't work but if it doesn't I'll have to look into it later.


- RenZ0R - 2008-06-03 04:04

cheers I reduced the setting down to 30, everythign's a lot more readable now


- RenZ0R - 2008-06-03 04:09

Ive just noticed, if you change the fanart thats automatic';y selected, it stops working


- Jeroen - 2008-06-03 14:22

RenZ0R Wrote:Ive just noticed, if you change the fanart thats automatic';y selected, it stops working

Could you elaborate? Does the dimming stop working or the fanart itself? Everything seems to work correctly here, but I have only tried it on my PC. I'll try it out on my xbox later (do you run it on the xbox or win/mac/linux?)


- kbrookes - 2008-06-04 15:30

Hi there, I usually only use xTV as my theme, but decided to play around with some others. After switching briefly to Aeon, I switched back to xTV, but suddenly all theme images were gone, plus the highlights for the menus stopped working.

Even after restarting the xbox, it's still showing just the text, but it's impossible to navigate as menu items don't show focus.

Please help!


- RenZ0R - 2008-06-04 16:36

Jeroen Wrote:Could you elaborate? Does the dimming stop working or the fanart itself? Everything seems to work correctly here, but I have only tried it on my PC. I'll try it out on my xbox later (do you run it on the xbox or win/mac/linux?)

Sure, running on xbox, latest T3CH version, fanart stops working for the selected series if you use the get fan art button


- xeonicxpression - 2008-06-04 16:44

When I grab the skin from the svn all I get is a back screen with text on it and cant see what is selected. I grabbed a copy from http://skin-downloads.googlecode.com/svn/trunk/xTV.rar and that one works fine. Are there any new features in the svn that aren't in that version? Anyone else having the same problem?

Note: not that it should matter, but I'm using it on xbmc-linux with the latest, as of last night around 10pm, build.


- Jeroen - 2008-06-04 17:11

RenZ0R Wrote:Sure, running on xbox, latest T3CH version, fanart stops working for the selected series if you use the get fan art button

I just tried to look into this on the xbox. However using the get fanart button just shows the busy animation and nothing ever happens. But I tested it with my own and other skins and it doesn't work in those either. It definitely worked flawlessly in my own skin so I'm thinking either fanart broke in the latest t3ch or thetvdb is having problems. The latter seems most likely as their site times out a lot for me at the moment.


- RenZ0R - 2008-06-04 17:50

xeonicxpression Wrote:When I grab the skin from the svn all I get is a back screen with text on it and cant see what is selected. I grabbed a copy from http://skin-downloads.googlecode.com/svn/trunk/xTV.rar and that one works fine. Are there any new features in the svn that aren't in that version? Anyone else having the same problem?

Note: not that it should matter, but I'm using it on xbmc-linux with the latest, as of last night around 10pm, build.

did you build the skin ?


- Jeroen - 2008-06-04 18:18

Nope, xTV was created by CHI3f (amongst others)