XBMC Community Forum
videos not playing...a final plea - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: videos not playing...a final plea (/showthread.php?tid=32182)

Pages: 1 2 3


videos not playing...a final plea - nmirza - 2008-03-25 16:23

I know i've discussed this before, and i hate to beat a dead horse but its driving me insane as to why its specifically not working for me. everything else is fine, library configured, etc. when i play the video, i just get a blank black screen with any and all videos i've tried. sound on some videos works fine (specifically divx), but most with ac3 or dd audio just have a loud hissing noise and no sound either in addition to no video. i've tried 1080p mkv content, 720p mkv, normal 700mb divx's, xvid, etc. none of them work.

the thing is that these work flawlessly using mplayer, i have ffmped, coreavc for mkv's, haali media splitter. im running these on bootcamped mini c2d 2.0, 950gma vid card with 1 meg ram. even though these files work fine outside xbmc, id expect if soemhow xbmc feels my comp is underpowered id get stuttering playback, not just a black screen. i just recently did a clean install of xp specifically to see if something i had previosuly installed was having an issue with xbmc but no luck. i currently have ffmpeg coreavc and haali installed. can anybody suggest anything? im using the latest t3ch build, and the latest xbmc for win. no outside the ordinary software otherwise as i only use this as an htpc.


- sjmiles - 2008-03-25 20:01

Hey nmirza,

I'm afraid I have no help for you, other than to say I have the exact same problem.

Basically the interface works beautifully, just blank videos.

I notice we both are using Bootcamp on a Mini, that may be a factor.

Have you tried earlier t3ch builds? I admit to n00bishness, so I haven't scoured the forum yet.

Anyway, you are not alone.


- bobrooney_78 - 2008-03-25 21:25

have you tried the latest Intel drivers? On ATI cards we have to use specific versions of drivers to get xbmc showing videos - because of opengl issues.


- agathorn - 2008-03-25 21:35

Pretty sure all T3CH builds are the DirectX skinning tool and not XBMC for Windows. Media playback is not supported nor even intended in the DirectX versions.

Use the actual XBMC for Windows SDL builds.

Now with that said, I could be tottaly wrong and there may be a T3CH build that is SDL in which case feel free ot ignore me Tongue


- sjmiles - 2008-03-25 22:00

Re: Builds, it seems there is a distinction between binary builds and the various support files.

My (limited) understanding is that to test the XBMC for Windows (SDL/OGL) we start with, e.g., a T3CH distribution and then add/replace key binaries.

I'm using the binaries in the XBMC_win32_rev12185 distro from sourceforge.

Please correct me if I've got it wonky, and/or give me a RTFM if I have failed in basic research.

bobrooney_78: you might be on to something. But Bootcamp has always supplied drivers, I've had a hard time identifying alternative drivers on this hardware.


- agathorn - 2008-03-25 22:07

sjmiles Wrote:Re: Builds, it seems there is a distinction between binary builds and the various support files.

My (limited) understanding is that to test the XBMC for Windows (SDL/OGL) we start with, e.g., a T3CH distribution and then add/replace key binaries.

Ahh I gotcha. My apologies then.


- bobrooney_78 - 2008-03-25 22:17

maybe it's worth a try?

http://www.123macmini.com/forums/viewtopic.php?t=15393


- sjmiles - 2008-03-25 22:28

@bobrooney_78:

Thanks for the info, it wasn't so hard after all to find an updated driver for the mini. Unfortunately, it didn't solve the problem.

Once again for the record, the basic interface is silky smooth and the sound is perfect.

I've been searching in vain for a few years for media software that would allow me to retire my XBOX. Nothing comes close to XBMC, so this is very tantalizing.


- nmirza - 2008-03-25 22:31

i do infact have the latest 945 gm video drivers but i admit i havent downloaded the chipset drivers...i thoguht video was all that was needed. this MAY solve the problem, im hoping it does.

as for the various builds here is how i am running xbmc. i downloaded the files as per the instructions on the forum to run xbmc on xp. i did a google search for t3ch xbmc and went to the first page which i sthe correct page i think then i downloaded the latest release of 9th march 08.

then i download the 12185 build for xp, replace xbmc.exe into the directory, replace the visuals folder as instructed, and there is an additional dll which i replaced aswell somewhere.

i am not aware if there are any other builds out there such as mentioend above opengl/direct x/windows sdl. im assuming windows sdl is the 12185 with the xbmc.exe file. i did hear some talk of directx and open gl version and how there were variosu builds but my queries went unanswered so im still confused about this although i did get the files based on instructions in the forum post.

sjmiles: yes, might just be a bootcamp thing althoguh i highly doubt it, unless theres some minor tweaks in the ahrdware that mkae it slightly non-standard and thus act wierd in our case. i love the xbmc os x and videos work fine and hope the xp xbmc works for me soon so i can use xp for this stuff, as i absolutely cannot use a music player other than winamp which is my biggest hinderance for using leopard.


- nmirza - 2008-03-25 22:32

just read your most recent post sjmiles...unfortuante that the chipset driver didn't solve the issue as that was pretty much my last hope to get this working.


- sjmiles - 2008-03-25 22:35

@nmirza: to be clear, I only updated the graphics driver itself (14.32.4), not any "chipset" driver per se.


- sjmiles - 2008-03-25 23:03

For completeness, here is my xbmc.log:

http://pastebin.com/d61fba3c7

I highlighted a line at the beginning of the information notices about OpenGL, in case that's an issue. It's also roughly where video playback begins.


- jaredharley - 2008-03-26 02:47

Maybe this is just a stupid question, but if you guys are using a bootcamp'ed Mac mini, why wouldn't you use the OSX version of XBMC...


- sjmiles - 2008-03-26 03:37

OSXBMC: Sure, am trying that out too.

Fwiw, I know I can use my MCE remote on Windows, that's a variable on OSX (the Apple remote is insufficiently buttoned).

Praise His Noodly Appendage.


- nmirza - 2008-03-26 17:43

jaredharley: xbmc on osx works flawlessly for me. BUT...i needs my winamp. if there was a winamp port for osx id totally switch, but since there isn't, and the alternatives dont even come close to it i can't. i've heard people sing praises about itunes, and im sure its great for them, i'm a pre-itunes guy, winamp all the way, flexibility with adding directories, vis, plugins, etc etc etc nothing compares to it.