XBMC Community Forum
XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu) (/showthread.php?tid=33327)



XBMC Autostart Script for Ubuntu Karmic - BurningSky - 2010-01-08 15:41

To start XBMC on Karmic automatically remove xbmc-live and execute this script:

Download:
http://www.mediafire.com/file/nmtnwmbmjti/setup_autostart_Karmic.sh

Code:
#!/bin/bash
## Created by BurningSky - 07.01.2010

echo 'description "Login XBMC"' >> /etc/init/xbmc.conf
echo 'author  "Miek Gieben <miek@miek.nl>"' >> /etc/init/xbmc.conf
echo >> /etc/init/xbmc.conf
echo 'start on (filesystem and started hal)' >> /etc/init/xbmc.conf
echo 'stop on runlevel [016]' >> /etc/init/xbmc.conf
echo >> /etc/init/xbmc.conf
echo 'task' >> /etc/init/xbmc.conf
echo 'console output' >> /etc/init/xbmc.conf
echo 'emits starting-x' >> /etc/init/xbmc.conf
echo >> /etc/init/xbmc.conf
echo 'script' >> /etc/init/xbmc.conf
echo 'su - xbmc -c startx' >> /etc/init/xbmc.conf
echo 'end script' >> /etc/init/xbmc.conf
echo 'case "`tty`" in' >> ~/.bash_profile
echo '/dev/tty1) clear && startx &>/dev/null;;' >> ~/.bash_profile
echo 'esac' >> ~/.bash_profile
echo 'exec xbmc --standalone' >> ~/.xsessionrc



- Daniel Malmgren - 2010-01-08 15:47

BurningSky Wrote:To start XBMC on Karmic automatically remove xbmc-live and execute this script:

How is that one better than Luigi's (the one included in xbmc-live package)?

/Daniel


- BurningSky - 2010-01-08 16:07

Daniel Malmgren Wrote:How is that one better than Luigi's (the one included in xbmc-live package)?

/Daniel
It is not better, it is different.
For people where xbmc-live don't work.


- outleradam - 2010-01-10 02:21

So how can we use billy?


- Robobandit - 2010-01-11 09:27

edit:

Please disregard this post.. I found my answer doing a quick search for "mouse".. I'll download and compile a newer version -

http://forum.xbmc.org/showthread.php?p=480377&highlight=mouse#post480377



I'm experiencing an odd UI issue on the newest ppa SVN (26540) of XBMC -

Here are my specs -

Zotac Ionitx A-U
2GB ram/512MB dedicated to the gpu
Nvidia 190.53 driver
XBMC 9.11 svn 26540
Ubuntu 9.11
Pioneer 1018AH-K receiver


The base UI elements are perfect.. I don't have the problem navigating the menus, but whenever there is a pop-up overlay like the context menu or the resume dialog, or the settings OSD during playback (not the drop down, it's fine.. but the audio and video settings dialogs during playback) the selection highlight doesn't line up with my mouse cursor, meaning I can't select certain items with the mouse. I can navigate them fine with the keyboard, so it isn't a huge deal.. but I wanted to see if anyone else had noticed a similar problem.

Anyone have any ideas as to where to look?

If it would help, I can post the contents of XBMC.log, but just wanted to ask here first.


- dandirk - 2010-01-13 22:39

Sorry for my ignorance...

If I installed the normal PPA... can I just add the SVN one and install?


- wattazoum - 2010-01-13 23:42

Yes you can.


- stefano85 - 2010-01-15 21:52

Robobandit Wrote:edit:

Please disregard this post.. I found my answer doing a quick search for "mouse".. I'll download and compile a newer version -

http://forum.xbmc.org/showthread.php?p=480377&highlight=mouse#post480377



I'm experiencing an odd UI issue on the newest ppa SVN (26540) of XBMC -

Here are my specs -

Zotac Ionitx A-U
2GB ram/512MB dedicated to the gpu
Nvidia 190.53 driver
XBMC 9.11 svn 26540
Ubuntu 9.11
Pioneer 1018AH-K receiver


The base UI elements are perfect.. I don't have the problem navigating the menus, but whenever there is a pop-up overlay like the context menu or the resume dialog, or the settings OSD during playback (not the drop down, it's fine.. but the audio and video settings dialogs during playback) the selection highlight doesn't line up with my mouse cursor, meaning I can't select certain items with the mouse. I can navigate them fine with the keyboard, so it isn't a huge deal.. but I wanted to see if anyone else had noticed a similar problem.

Anyone have any ideas as to where to look?

If it would help, I can post the contents of XBMC.log, but just wanted to ask here first.

same problem here with the mouse cursor on pop-up menus. it doesn't highlights the buttons, also if i move it around the screen. It works fine with wireless keyboard.

My specs are:
Asrock ION 330 Pro
2 GB RAM DDR
Ubuntu 9.10
Xmbc 9.11 svn 26540 (standalone version not LIVE)
Nvidia 190.53
Logitech MX 1100 (mouse wi-fi)
Logitech K340 (keyboard wi-fi)

thanks in advance for any help.


- BaerMan - 2010-01-16 13:50

Does anyone also have problems with quitting XBMC (SVN26540 from PPA)? On my HTPC XBMC always restarts, regardless what I select to quit. I'm calling XBMC as
Quote:/usr/bin/xbmc-standalone -q
which works fine for first start. But after quitting XBMC it immediately restarts and the screen is far too big for my TV.
I'm using an old TV, the screen is set to 720x576@51Hz. I adjusted the screen size to fit the TV but these settings seem to get ignored after XBMC newly starts. It then takes a long time until XBMC finishes the initial scraping and If in the meantime I try to quit again, it freezes, but I still can go to console and kill XBMC.


- user1234 - 2010-01-19 17:51

When will the next svn build be released as a ppa? The actual build 26540 has this nasty video issue (see: http://forum.xbmc.org/showthread.php?tid=66646) and I would really appreciate to update to a build > 27005.

Thanks in advance :-)


- wattazoum - 2010-01-19 18:04

It was released this morning.
See http://tinyurl.com/y8fs5mf .



- Superorb - 2010-01-19 18:33

So how exactly do we upgrade to newer versions of XBMC without reinstalling? I've run the "aptitude" script and it keeps saying that no new packages are available. I'd love to have movie trailers again since they don't work in the version I'm running (9.11 Live Stable).


- jbernardo - 2010-01-19 18:46

wattazoum Wrote:It was released this morning.
See http://tinyurl.com/y8fs5mf .

From what I can see there, packages were built for svn 26995, but the fixes for the vdpau problems are only in SVN > 27005. Any idea when these will be built?
Thanks!


- wattazoum - 2010-01-19 23:45

jbernardo Wrote:From what I can see there, packages were built for svn 26995, but the fixes for the vdpau problems are only in SVN > 27005. Any idea when these will be built?
Thanks!

I need to activate the daily builds again for that.

Superorb Wrote:So how exactly do we upgrade to newer versions of XBMC without reinstalling? I've run the "aptitude" script and it keeps saying that no new packages are available. I'd love to have movie trailers again since they don't work in the version I'm running (9.11 Live Stable).

You need to add the SVN repository in APT and do sudo apt-get update , then sudo apt-get dist-upgrade.


- Haohmaru - 2010-01-20 00:38

wattazoum Wrote:I need to activate the daily builds again for that.



You need to add the SVN repository in APT and do sudo apt-get update , then sudo apt-get dist-upgrade.

Thats what I get after those two commands:confused2:

xbmc@XBMCLive:~$ sudo apt-get update
Hit http://ppa.launchpad.net karmic Release.gpg
Ign http://ppa.launchpad.net karmic/main Translation-en_US
Hit http://www.lonelycoder.com hts Release.gpg
Ign http://www.lonelycoder.com hts/main Translation-en_US
Hit http://ppa.launchpad.net karmic Release
Hit http://www.lonelycoder.com hts Release
Hit http://ppa.launchpad.net karmic/main Packages
Ign http://www.lonelycoder.com hts/main Packages
Hit http://ppa.launchpad.net karmic/main Sources
Ign http://www.lonelycoder.com hts/main Packages
Hit http://www.lonelycoder.com hts/main Packages
Hit http://archive.ubuntu.com karmic Release.gpg
Ign http://archive.ubuntu.com karmic/main Translation-en_US
Ign http://archive.ubuntu.com karmic/restricted Translation-en_US
Ign http://archive.ubuntu.com karmic/universe Translation-en_US
Ign http://archive.ubuntu.com karmic/multiverse Translation-en_US
Hit http://archive.ubuntu.com karmic-security Release.gpg
Ign http://archive.ubuntu.com karmic-security/main Translation-en_US
Ign http://archive.ubuntu.com karmic-security/restricted Translation-en_US
Ign http://archive.ubuntu.com karmic-security/universe Translation-en_US
Ign http://archive.ubuntu.com karmic-security/multiverse Translation-en_US
Hit http://archive.ubuntu.com karmic Release
Hit http://archive.ubuntu.com karmic-security Release
Hit http://archive.ubuntu.com karmic/main Packages
Hit http://archive.ubuntu.com karmic/restricted Packages
Hit http://archive.ubuntu.com karmic/universe Packages
Hit http://archive.ubuntu.com karmic/multiverse Packages
Hit http://archive.ubuntu.com karmic-security/main Packages
Hit http://archive.ubuntu.com karmic-security/restricted Packages
Hit http://archive.ubuntu.com karmic-security/universe Packages
Hit http://archive.ubuntu.com karmic-security/multiverse Packages
Reading package lists... Done
xbmc@XBMCLive:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Its still the original live 9.11 build from dec 24
Can you give me some advice ?