XBMC Community Forum
XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu) (/showthread.php?tid=33327)



- analogue - 2011-11-19 19:32

Code:
sudo add-apt-repository ppa:pulse-eight/libcec



- Daniel Malmgren - 2011-11-19 20:10

analogue Wrote:
Code:
sudo add-apt-repository ppa:pulse-eight/libcec

Why is there no thanks button in this forum? Well anyway, thanks a lot!

New questions:
Why doesn't the oneiric repository contain any xbmc packages? I'm using the natty repository for now, is this the correct way to go?

When installing xbmc-live I now get this:
Code:
/var/lib/dpkg/info/xbmc-live.postinst: 208: cannot create /etc/lightdm/lightdm.conf: Directory nonexistent

Is lightdm a new dependency? Thought about installing it, but it seems to pull in heckloads of depdendencys...

/Daniel


- robo989 - 2011-11-20 10:01

How did you get that far, xbmc-live isn't even available in any repo, stable\unstable for me currently?


- Suven - 2011-11-26 13:56

Hi,

isn't it possible for XBMC-Live-Users to update to a nightly build? I added ppa:team-xbmc/unstable and the one for pulse-eight but still have failed build-dependencies with the package xbmc-live.

Or do I need to remove the stable pap?

EDIT:/ Okay, now it works.. But Im a little bit afraid because he asks to remove xbmc-data, xbmc-skin-confluence and xbmc-standalone.. Is that normal? That would mean that XBMC got 21MB smaller


- tortexal - 2011-11-28 06:21

tried to install from steps listed in http://wiki.xbmc.org/index.php?title=HOW-TO:Install_XBMC_for_Linux

but the team-xbmc repository seems to be missing critical packages

installed from source, instructions here http://wiki.xbmc.org/index.php?title=HOW-TO_compile_XBMC_for_Linux_from_source_code

works no problem.


- HellFire - 2011-12-05 05:59

Suven Wrote:Hi,

isn't it possible for XBMC-Live-Users to update to a nightly build? I added ppa:team-xbmc/unstable and the one for pulse-eight but still have failed build-dependencies with the package xbmc-live.

Or do I need to remove the stable pap?

EDIT:/ Okay, now it works.. But Im a little bit afraid because he asks to remove xbmc-data, xbmc-skin-confluence and xbmc-standalone.. Is that normal? That would mean that XBMC got 21MB smaller

That's fine. Those packages were merged into one.


- janumix - 2011-12-09 11:35

Suven Wrote:Hi,

isn't it possible for XBMC-Live-Users to update to a nightly build? I added ppa:team-xbmc/unstable and the one for pulse-eight but still have failed build-dependencies with the package xbmc-live.

Witch of these are up-to-date, right now ? In pulse-eight last version is 55 from 12 Nov.
In mainline were some updates after with moving weather to add-on.

@dushmaniac
would you be so kind to update PPA, please ?


- HellFire - 2011-12-09 13:52

Use my PPA. Mine is up-to-date and should update fine.

ppa:nathan-renniewaldock/xbmc-nightly
https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-nightly

I also have stable builds for Ubuntu 11.04, 11.10 and 12.04.
ppa:nathan-renniewaldock/xbmc-stable
https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-stable


- janumix - 2011-12-09 16:45

thanks


- janumix - 2011-12-10 22:29

HellFire Wrote:Use my PPA. Mine is up-to-date and should update fine.

ppa:nathan-renniewaldock/xbmc-nightly
https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-nightly

I also have stable builds for Ubuntu 11.04, 11.10 and 12.04.
ppa:nathan-renniewaldock/xbmc-stable
https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-stable

BTW they are not PVR-friendly Smile


- HellFire - 2011-12-11 13:22

Didn't notice you were after the PVR builds. The Pulse-Eight repo should work.


- janumix - 2011-12-11 15:31

Yes, I haven't mentioned... I've just jumped here from pvr development sub forum... Smile
But pulse eight is unfortunately out date a month.


- Henkske - 2011-12-18 23:14

HellFire Wrote:Use my PPA. Mine is up-to-date and should update fine.

ppa:nathan-renniewaldock/xbmc-nightly
https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-nightly

I also have stable builds for Ubuntu 11.04, 11.10 and 12.04.
ppa:nathan-renniewaldock/xbmc-stable
https://launchpad.net/~nathan-renniewaldock/+archive/xbmc-stable


Hey HellFire, thank you for your PPA.

I have a question regarding installing xbmc on ubuntu server 11.10.
I have a new install with ONLY NVIDIA drivers installed. Which packages should i install for xbmc ?
Is it:

sudo apt-get install xbmc xinit x11-xserver-utils xbmc-live -y ?

Thank you for your answer.


- BurningSky - 2011-12-18 23:37

That's what I install:
Code:
apt-get install xbmc-live xinit x11-xserver-utils linux-sound-base alsa-base alsa-utils upower udisks libvdpau1 python-software-properties pkg-config



- Bram77 - 2011-12-18 23:40

pulse is missing and some more I think (if using ubuntu minimal as a base; not sure for server)