XBMC Community Forum
XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) (/showthread.php?tid=45525)



- motd2k - 2009-03-03 00:41

liquidolze Wrote:Hello,

I got a problem playing mkv and other movie-files.
They play for a few seconds and then XBMC crashes. Any ideas?

Please forgive me my bad english(I'm from Germany)

Best regars

Oliver

You'll need to post logfiles, please read this... http://forum.xbmc.org/showthread.php?tid=34655


- liquidolze - 2009-03-03 01:02

Sorry motd2k,

AMD X2 6000+ 2 GB RAM
XBMC pre-9.04 SVN 18184M
Kernel 2.6.28-7
Debian Lenny
NVidia 8400GS with Driver 180.35

No Log because I told you wrong. Not XBMC crashes only the movie stops playing.

System Info says there are 107 KB free memory of total 900 ??

Oliver


- motd2k - 2009-03-03 01:23

The logfile will still exist... if you launched as i said (on page 1) it will be in the XBMC folder... if not, it will be in /var/tmp


- liquidolze - 2009-03-03 01:45

Sorry,

yes I'm a NERD, Log was there!

But itś too long, how can I post it to you?


- harryzimm - 2009-03-03 01:54

Use http://pastebin.com/ and post the link here

cheers.


- liquidolze - 2009-03-03 02:00

@ harryzimm -- Thanks a lot!

http://pastebin.com/m65b8ae0e


- motd2k - 2009-03-03 02:17

Are you playing this file over the network? Most likely SMB - try copying it locally.


- liquidolze - 2009-03-03 02:19

No, it's on sda1 (mounted in /mnt/sda1)


- liquidolze - 2009-03-03 02:25

I think my mkv-file is corrupted Iĺl try another one if I get one.


- BLKMGK - 2009-03-03 06:38

This thread still applies http://forum.xbmc.org/showthread.php?tid=34655 for folks who run into bugs...

Edit: To add to this a command Al posted for when XBMC simply freezes -> killall -SEGV xbmc.bin which will generate a core dump file Smile


- bjck - 2009-03-03 22:32

BLKMGK Wrote:This thread still applies http://forum.xbmc.org/showthread.php?tid=34655 for folks who run into bugs...

Thx, makes my life more easy. And now I really had to follow the rules :X First post, but reading for a while now.

I updated to the SVN 18227 on i686, intrepid on an Asus P5N7A-VM. Now I can stop a movie (or killa-sample) and it's fine. But when the movie/file/sample ends it crashes back to the terminal.

http://pastebin.ubuntu.com/125987/

Music seems fine, but also an XvID doesn't work. Only here it crashes strait away into the terminal without one frame displayed.

http://pastebin.ubuntu.com/125989/

No need to say the work is done here is really great. Had great fun with the build from last Saturday evening (AMS).


crashes when browsing video files - pilluli - 2009-03-03 23:23

Hi,

Many thanks for your hard work motd2k. Just wanted to report that I'm getting repeated crashes when browsing files. I think it is related to thumbnail generation/creation as later I'm seeing thumbs as messed green lines. This is the debug log:

http://pastebin.com/ff3b807b

and the gdb backtrace:

http://pastebin.com/f444aa4e

This is with vdpau branch r18222 and nvidia driver 180.35. Regards,


- asandir - 2009-03-04 00:34

How is everyone else's experience with seeking in 720p and 1080p files?

720 works if I don't seek too many jumps too closely together, but 1080 often crashes - or sometimes I get the sound running but the video is frozen. I'm wondering how much it's limited by cpu and network.

I'll have to get a log to upload tonight.


- philter - 2009-03-04 01:31

Dual core 2.5ghz and 8200 IGP here and I have no issues with seeking (local files)...running smooth. I haven't tried to seek too much when playing networked files, I don't intend to as I have all torrent/usenet programs running behind the scenes on my xbmc computer.


- davilla - 2009-03-04 01:59

Remember that everyone is not using the same svn version so individual results will differ depending on which Linux OS, nvidia version and xbmc svn version. It would be helpful to others if everyone posted their VERSIONS when making posts about working/non-working setups.