XBMC Community Forum
XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) (/showthread.php?tid=45525)



- nunu - 2009-03-20 23:43

Hello,
i have reinstall ubuntu 8.10 32bits. and following instruction of page 1.
I have not change default settings of XBMC.
I have a 9500GT 512MB & AMD64 3200+ - 180.35. With killa sample file CPU grow up to 100% . With 18487 i reach 40% and it's very smooth.

I made the test with my main computer (Q6600 + 8800GTS512 + 180.35 + 8.10 32 Bits), and i have the same think. Killa sample made only one core to 15%, and with recent version (i have tested several), each core reach 60-70%.

if i recompile the revision 18487 that works fine.

I will provide traces concerning an issue while playing the mummy3 bluray : it seems there is a leak of memory (i saw in ressource system the memory usage that grow up to the max to the memory - ie >3Go). I have to kill the task

regards
nunu


- xnappo - 2009-03-20 23:53

nunu Wrote:I made the test with my main computer (Q6600 + 8800GTS512 + 180.35 + 8.10 32 Bits), and i have the same think. Killa sample made only one core to 15%, and with recent version (i have tested several), each core reach 60-70%.

You need 185.13 for more recent versions.

xnappo


- cros13 - 2009-03-21 00:16

Would it be possible for a list to be maintained on the first post detailing the last safe svn revision for each driver version?

I've just gone through hell with the nvidia driver so I'm staying on 180.37 for the foreseeable future.


- tslayer - 2009-03-21 00:34

I don't think it is a good idea to maintain such a list. If you ever have issues, we will ask that you update to the latest SVN to see if the issue has already been fixed. And that means you will need to use the recommended driver versions.


- motd2k - 2009-03-21 09:05

You can check the SVN commit notes for the branch, they will tell you when I required a change in version.


- nunu - 2009-03-21 10:03

I have update my linux driver (185.13) and have still the problem.
(Ubuntu 8.10 32 - 185.13 - Q6600 - 880GTS512 )

Here the log : http://pastebin.com/m5c650001

I have followed page 1 instruction.
The video for test is the killa sample.

It seems better that my previous tests. In the log i have :

08:56:58 T:2896939920 M: 40218624 ERROR: ffmpeg: [h264_vdpau] number of reference frames exceeds max (probably corrupt input), discarding one

DEBUG: CDVDPlayerAudio:: Discontinuty - was:257815,825000, should be:288000,000000, error:30184,175000
ERROR: GetDelay - snd_pcm_delay, alsa error: -5 - Erreur d'entrée/sort


- sensei73 - 2009-03-21 11:03

maybe it's because you have a 8800 GTS with VP1

VDPAU supported cards are VP2 and VP3


- nunu - 2009-03-21 11:57

it works with 18487, so it's more a SW problem/settings than HW.
It's a GTS512 (G92).

I have the same troubles with my 9500GT on an other computer.

but i any cases the MUMMY3 bluray can't be played


- beefke - 2009-03-21 13:06

I don't know if it has been posted before, but this is an important note in the driver README:

G98, MCP77, MCP78, MCP79, MCP7A:

VDP_DECODER_PROFILE_H264_MAIN, VDP_DECODER_PROFILE_H264_HIGH:

Unsupported widths: 49, 54, 59, 64, 113, 118, 123 macroblocks (784, 864, 944, 1024, 1808, 1888 pixels).

Seems to be an hardware error (also pop ups in dxva). Something to keep in mind when certain h264 files don't play well.


- Haggy - 2009-03-21 13:16

Oh - that's interesting. So it's not a driver issue but the hardware is borked?


- beefke - 2009-03-21 13:23

That's true. The G98 and all the IGP's have this issue. In windows there is some fallback to software, in linux not (yet). See also:

http://www.nvnews.net/vbulletin/showpost.php?p=1963112&postcount=1012


- Haggy - 2009-03-21 13:40

So one might think that it was a designed flaw rather than a design flaw Smile


180.41? - cyba - 2009-03-21 13:59

xnappo Wrote:You need 185.13 for more recent versions.

xnappo

I was looking through svn logs, but didn't find any mention about this being a required version?

Also, the 180.41 driver is the latest nvidia release, does it mean that it should be used, or is the 185 branch the one that will be required from now on?


- Haggy - 2009-03-21 14:14

Sure it was in the log:
http://trac.xbmc.org/changeset/18605

and yes: you need 185.13 because of that change i think - but motd2k is more into the drivers features. also, 180.41 is another stable release, while 185.13 is called beta from nvidia itself.


- BLKMGK - 2009-03-21 15:23

180.29 is their latest listed "official" release on their drivers page right now. <shrug> Will move to newest though!