XBMC Community Forum
XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) (/showthread.php?tid=45525)



- Rand Al Thor - 2009-02-17 22:30

I am actually running gentoo. I have 180.29 installed and I can see /usr/include/vdpau/ it has both vdpau.h and vdpau_x11.h in it. Any other thoughts?

The only dev packages I can see for Nvidia are the cuda sdk, cuda toolkit, and the cg toolkit. Perhaps one of these is the equivalent to jaunty's dev package?


- motd2k - 2009-02-17 22:37

Sorry i misread, the GL headers could be the problem /usr/include/GL/gl.h and glx.h


- motd2k - 2009-02-17 22:38

alanwww1, what GPU do you have? VC-1 isnt supported on all hardware, i'll add a check and fallback at some point.


- alanwww1 - 2009-02-17 22:56

motd2k Wrote:alanwww1, what GPU do you have? VC-1 isnt supported on all hardware, i'll add a check and fallback at some point.

I have Nvidia 9400 Integrated motherboard. From the logs it shows it can, but i am not sure:

Code:
name          level macbs width height
------------------------------------
MPEG1             0  8192  2048  2048
MPEG2_SIMPLE      3  8192  2048  2048
MPEG2_MAIN        3  8192  2048  2048
H264_MAIN        41  8190  2032  2048
H264_HIGH        41  8190  2032  2048
VC1_SIMPLE        1  8190  2048  2048
VC1_MAIN          2  8190  2048  2048
VC1_ADVANCED      4  8190  2048  2048



- Katagia - 2009-02-17 23:03

My cpu load is at 20% each (2CPUs) with 1800MHz.
How can I check vdpau is used?


- rodalpho - 2009-02-17 23:13

As far as I know, you can't, short of checking the logs or noticing lower than normal CPU usage. That's a great enhancement request; I would love for the info popup to show something like "VDPAU: On".


- motd2k - 2009-02-18 00:19

I like that idea... commited to SVN revision 17790.


- Rand Al Thor - 2009-02-18 00:54

motd2k Wrote:Sorry i misread, the GL headers could be the problem /usr/include/GL/gl.h and glx.h

At the risk of sounding ignorant. Does that mean the issue is on my end? Both files are present in that location.


- motd2k - 2009-02-18 01:03

i'm afraid so, your compiler cant find headers (which exist!) try the following perhaps:

PHP Code:
cd ~/xbmc-vdpau/XBMC  (or whatever)
make distclean
rm configure
autoconf
./configure
make 



512 MB framebuffer, now 1080p is OK too - j0bro - 2009-02-18 01:12

Did a bios upgrade (to 0504) as I saw mine was already old (0407) so all fresh now. Set the framebuffer size to 512 MB and even compiled r17789. By changing to 512 MB, now 1080p playback is performing great as well. CPU usage is at 3-5% still, framerate at a rock solid 23.98 fps, no matter what bitrate!

This means the CPU power is way overkill but the cooling is dead silent now, which is a Very Good Thing™ Laugh


- Rand Al Thor - 2009-02-18 01:22

motd2k Wrote:i'm afraid so, your compiler cant find headers (which exist!) try the following perhaps:

PHP Code:
cd ~/xbmc-vdpau/XBMC  (or whatever)
make distclean
rm configure
autoconf
./configure
make 

Still no dice. Thanks for the help though. I will look into this and see if I can't sort it out myself. Cheers.


- dafart - 2009-02-18 01:46

Concerning the compile error i reported earlier today (http://www.xbmc.org/forum/showpost.php?p=284868&postcount=42). reason for this error is not having the nvidia xorg development and vdpau developmet files Frown

Currently compiling without any hickups.. Sorry for the confusion and maybe this info is usefull for people running into the same trouble

Cheers..


- BLKMGK - 2009-02-18 05:28

rodalpho Wrote:Actually, no. Those instructions are wildly inadequate. Steps are:

1) deactivate ubuntu's version of the proprietary nvidia 170.x drivers under system|administration|hardware drivers
2) sudo nvidia-uninstall (This step can possibly be skipped; I needed it as I skipped step 1 my first try. Step1 is definitely mandatory.)
3) from a shell prompt (ssh into your box or go to a VT from the console via ctrl-alt-F2), run
sudo /etc/init.d/gdm stop
to kill X
4) from that same shell prompt,
sudo sh nvidiawhatever.run
to install the new drivers
5) sudo shutdown -r now
to reboot

(feel free to put this in the wiki, if you want)

Smooth as glass using your instructions Rodalpho - thank you! I would have been happy to try Jaunty .deb files etc. too except that there was no explanation as to how to do so. I tried to find the repo address for Jaunty and add it but no luck at successfully installing them. I did see 180.11 in the repo but 180.29 is what I wanted - and now have! I have pulled down 17996 to my machine, am cleaning things up, and will see if I cannot get it to compile with the VDPAU stuff onboard. My thanks for the assist on driver install and the hard work that's gone into making this acceleration possible on XBMC!!

Edit: Compiled and running but dropping massive frames on Killa' Sad For some reason it doesn't seem to have picked up VDAPU capabilities, I do not see it listed as a render option. Does a command switch need to be given or will it pick it up by virtue of the headers being available? Main branch now yes?


- theuni - 2009-02-18 06:49

BLKMGK Wrote:Main branch now yes?

No. xbmc-vdpau branch.

TheUni


- BLKMGK - 2009-02-18 06:58

Ah okay thank you, I have been following the TRAC and it looked as if these changes had been merged into main already - doh!