XBMC Community Forum
XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: XBMC for Linux VDPAU - NVIDIA GPU video decoding support (now in the mainline SVN) (/showthread.php?tid=45525)



- motd2k - 2009-06-13 15:04

Its just an underpowered card. You could try overclocking the GPU core and your system RAM, helped for me but well... standard disclaimer applies!


- Haggy - 2009-06-13 21:07

motd2k Wrote:standard disclaimer applies!
Watch your temps if you try this. the 8200/8300 are hot as hell even at stock speed. I attached a better heatsink and pushed it to 550 gpu and 1600 shaders which helps - as you said - "a bit"


- gnif - 2009-06-15 08:57

Haggy Wrote:Ok, i looked a bit deeper into the settings. It seems like using the "(Fullscreen)" resolution, i get exactly half the fps that is shown, so it's 25fps for the 50Hz mode. Using f.e. the "1920x1080@50Hz" resolution however i get 50fps w/o a problem. Same for "1920x1080@24Hz" and so on... those resolutions are available since i modelined them into my xorg.conf. Nevertheless i cannot remember getting even 25fps in fullscreen mode with the older drivers. Why it's exactly half the refresh rate i don't know...same for my "1920x1080@60Hz" modeline, which renders at 30fps. Playing a movie switches to the desired refresh rate and stays stable for most of the files, though for some 1080p movies it can't keep up the framerate sometimes.

Try to build with this patch, it should fix the issue your having

http://trac.xbmc.org/ticket/6761


- Bahndit - 2009-06-15 11:44

gnif Wrote:Try to build with this patch, it should fix the issue your having

http://trac.xbmc.org/ticket/6761

gnif,
One word, Awesome! This made a huge difference for me on my Zotac IONITX board. I have never seen the BluRay MKV's I made of "The Dark Knight" and "Cars" play so smoothly using VDPAU. I tip my hat to you my good sir Wink and as always I bow in gratitude to mot2dk for the marvelous VDPAU integration and the rest of the XBMC devs for their amazing work. Man, XBMC is the bomb-beezy! Big Grin

-bahndit


- Haggy - 2009-06-15 14:46

gnif Wrote:Try to build with this patch, it should fix the issue your having

http://trac.xbmc.org/ticket/6761

Well... the GUI chopiness is indeed gone. I now have my resolution set to 1920x1080 (fullscreen), and i am starting xbmc with -fs --standalone. However overall playback performance did not improve. I suppose this patch addressed only the GUI. Casino Royale is still stuttering during the intro and at some busy scenes. I blame my crappy 8200/8300 for that though.


- ERamseth - 2009-06-15 16:49

Haggy Wrote:Well... the GUI chopiness is indeed gone. I now have my resolution set to 1920x1080 (fullscreen), and i am starting xbmc with -fs --standalone. However overall playback performance did not improve. I suppose this patch addressed only the GUI. Casino Royale is still stuttering during the intro and at some busy scenes. I blame my crappy 8200/8300 for that though.

Do you have an Athlon 64 x2?

If so: change your cpu governor to performance, rather than ondemand, and it will fix jitters.

Reasoning: seems to be that the speed of the memory controller is tied to the cpu clock speed. VDPAU doesn't tax the CPU much and so the CPU speed is scaled down to 1.00 GHZ (at least for me) most of the time. The memory controller is similarly scaled down. Clocking it at performance (aka full speed) will let the memory controller run at full speed.

Disclaimer: your computer will run hotter with fans louder.

If anyone knows a way (bios or OS) to set the memory controller speed to full speed, regardless of cpu speed, please let me/everyone know!


- pat1975 - 2009-06-15 21:53

@ERamseth: Set it to 1.8GHz. That will run your memory-controller at full speed, but not your CPU.

In Ubuntu, you can do that in /etc/init.d/cpufreqtools

Set the min_freq to 1800000

Patrick


- ERamseth - 2009-06-16 00:30

pat1975 Wrote:@ERamseth: Set it to 1.8GHz. That will run your memory-controller at full speed, but not your CPU.

In Ubuntu, you can do that in /etc/init.d/cpufreqtools

Set the min_freq to 1800000

Patrick

I was experimenting this this all day and was coming back here to report this exact finding haha.

EDIT: if that file doesn't exist (not sure it does by default) then install sysfsutils and add this line to the end of /etc/sysfs.conf

Code:
devices/system/cpu/cpu0/cpufreq/scaling_min_freq = 1800000



Zotac ION plays using VDPAU without stuttering - plue - 2009-06-16 12:10

plue Wrote:I also have stuttering when playing with VDPAU in my Zotac ION.

Haggy Wrote:You have to force VDPAU in settings. it will gracefully drop back to GLSL if it's not supported. Auto does not enable VDPAU even if available. Also make sure you have 512MB assigned to the IGP and you are running dualchannel.

I have resolved the stuttering when playing with VDPAU thanks to the dualchannel. :cool2:

In order to play without stuttering, I put two identical DDR2-800 memories.
I also set 512MB for the GPU in the BIOS.
I use the NVIDIA driver 185.18.14.


- pat1975 - 2009-06-16 14:36

ERamseth Wrote:EDIT: if that file doesn't exist (not sure it does by default) then install sysfsutils and add this line to the end of /etc/sysfs.conf

Code:
devices/system/cpu/cpu0/cpufreq/scaling_min_freq = 1800000

/etc/init.d/cpufrequtils is there, if you install package cpufrequtils with apt-get.


- ERamseth - 2009-06-16 16:29

pat1975 Wrote:/etc/init.d/cpufrequtils is there, if you install package cpufrequtils with apt-get.

Indeed it is.

I guess this could potentially become a cpufrequtils vs. powernowd thread but let's not get off topic. The workaround seems sufficient on my end.


- pat1975 - 2009-06-16 17:09

You're right. Fact is, set minimum speed to 1800 (or not 1000) and you will be happy :-)


- alanwww1 - 2009-06-16 20:01

I just saw this board, which supports DDR2-1066 memory.

http://www.gigabyte.com.tw/Products/Motherboard/Products_Overview.aspx?ProductID=3089

In dual channel mode i think it could beat any integrated solution today in memory bandwidth side.

I don't know an Intel 9300-9400 solution only up to ddr2-800

What do you think ?

How about the issue with 8200 integrated graphics with fullscreen ? Is it solved yet ?

I found a test tool which tests VDPAU decoding speed for various resolutions and formats:

http://www.nvnews.net/vbulletin/showthread.php?t=133465

Download, than:

Code:
tar -pxvf qvdpautest-0.3.tar.gz
sudo apt-get install qt4-dev-tools
cd qvdpautest-0.3/
qmake-qt4
make
./qvdaputest
Alternatively you can run it wit
./qvdpautest 1>results
to get the results in a file.

Can anyone make a test with a DDR2-1066 memory equipped 8200 integrated board ?
We can compare the results with the 9300-9400 integrated ddr2-800 solutions.


- motd2k - 2009-06-16 23:28

oh gawd, that tool is going to inspire alsorts of penis envy on what has been, up until now, a nice friendly field where the 8200's play together quite nicely with the 260's...


- alanwww1 - 2009-06-16 23:50

motd2k Wrote:oh gawd, that tool is going to inspire alsorts of penis envy on what has been, up until now, a nice friendly field where the 8200's play together quite nicely with the 260's...

I think the results are very good for the integrated solutions (at least the 9300 and 9400) They score more than most of the dedicated cards (even higher end cards)

So it might be a surprise who has the bigger .... Big Grin