XBMC Community Forum
Post Bugs here - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Skin Help and Support (/forumdisplay.php?fid=67)
+---- Forum: Skin Archive (/forumdisplay.php?fid=179)
+----- Forum: Serenity (/forumdisplay.php?fid=104)
+----- Thread: Post Bugs here (/showthread.php?tid=48837)

Pages: 1 2 3 4 5


- deano72 - 2009-04-27 18:51

excellent mate, many thanks.
I don't like using the A word either lol....


- digitalhigh - 2009-04-27 19:00

deano72 Wrote:excellent mate, many thanks.
I don't like using the A word either lol....

Give it a second...I just squashed another bug I accidentally created whilst toying around. I also tweaked the posters in TV list mode, this seems to make scrolling there faster.

What happens if you map regular old left/right to the held-down buttons for your keymap? My biggest problem in figuring out where your problems occur is that I can't emulate what you have, and in scrolling for me (on dev PC, HTPC, and Xbox) everything is smooth as butter...


- deano72 - 2009-04-27 19:15

Yeah, scrolling on my mac is nice and fast as well...
at the moment, the keymap has BigStepBack for hold left and BigStepForward for hold right.
Are you asking for me to add just left and right to hold up and hold down?


- deano72 - 2009-04-27 19:17

ooh, one more thing, would i be changing this on global settings or myvideolibrary in keymap?


- digitalhigh - 2009-04-27 19:20

deano72 Wrote:Yeah, scrolling on my mac is nice and fast as well...
at the moment, the keymap has BigStepBack for hold left and BigStepForward for hold right.
Are you asking for me to add just left and right to hold up and hold down?

It should be the global setting you're changing...that would explain why holding doesn't do anything. The bigstepback and begstepforward commands are for playing a video.

Try changing to scrollup and scrolldown in global, if that doesn't work (although it should), then try changing them to regular left/right.


- deano72 - 2009-04-27 19:39

many thanks. I am changing the keymap in userdata to have ScrollUp and ScrollDown in Hold Left and Hold Right Respectively. If that does not work will try just putting left and right (not up and down for scolling up or down? I was thinking left and right were to give movie info [align=right] or left to go back to genre/title/etc at top toolbar])?


- digitalhigh - 2009-04-27 19:42

deano72 Wrote:many thanks. I am changing the keymap in userdata to have ScrollUp and ScrollDown in Hold Left and Hold Right Respectively. If that does not work will try just putting left and right (not up and down for scolling up or down? I was thinking left and right were to give movie info [align=right] or left to go back to genre/title/etc at top toolbar])?

I guess that kinda depends on your preference...in panel/poster/fanart views, left/right are scroll. In list view, up/down would scroll. I really think that the scroll commands will work...I didn't realize you were putting them in the video section instead of global...


- deano72 - 2009-04-27 20:03

No. Never put them in video section before. The bigstep commands were in my global.
I will try the scroll commands and let you know. Would replacing the bigstep commands then stop bigstep whilst watching a video?


- digitalhigh - 2009-04-27 20:45

deano72 Wrote:I will try the scroll commands and let you know. Would replacing the bigstep commands then stop bigstep whilst watching a video?

Yes. But you should be able to put them in videoosd and still have them work.


- deano72 - 2009-04-27 21:47

tried the scroll commands in holdleft and holdright. tried it out in poster view, still scrolls slowly left or right this time.
tried adding them to holdup and holddown and in list view, still scrolls slow.
Just wondering why in other skins i never had to change keymap, it scrolls by default quite fast....strange.........


- deano72 - 2009-04-27 21:53

Should I try and have my films have no fanart? See if that has any effect (don't really want to do it, but it looks like the loading of fanart is the problem in trying to show fanart on each move down the list when scrolling)?
Cheer,
dean


- digitalhigh - 2009-04-27 22:13

Try this.


- deano72 - 2009-04-27 22:14

Try the new release in sig?


- digitalhigh - 2009-04-27 22:15

No, the attachment that failed to attach the first time.


- deano72 - 2009-04-27 23:05

Added file to 720p settings in serenity. Restarted xbmc. It is marginally better still going down one film at a time slowly but tiniest bit faster. I am now going to try my source without fanart and see how that fares.