XBMC Community Forum
FTP Streaming question - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Mac OS X support (/forumdisplay.php?fid=56)
+---- Thread: FTP Streaming question (/showthread.php?tid=49784)



FTP Streaming question - shlomi.schwartz - 2009-04-27 13:35

Hi guys,

After I despaired from using smb protocol (Performance issues), I've installed an ftp server on my PC (filezilla).

Streaming performance is great, the only issue is that now (on files view) XBMC doesn't show the folder.jpg (located inside a movie folder) as a Thumb like it use to do with smb.

Is there a solution for this, other than using library mode?

Info:
AppleTV 2.3
XBMC Atlantis Beta 2
Vista 64bit enterprise (which caused the smb problems:nerdSmile

Thanks


- spiff - 2009-04-27 13:44

disabled in code on purpose as ftp is extremely ill suited for what you are shoehorning it into doing.


- shlomi.schwartz - 2009-04-27 13:59

I see ...
So what would be the best solution for this:

I stream SD content from my Vista machine (via SMB) it works well on OS reboot, but after a while it stutters (buffering).

If I restart my OS it works fine again. I tried the following:
  • Changing the cache on XBMC settings
  • Changing the vista policy to "LM and NTLM – use NTLMV2 session security if negotiated"
  • followed this article support http://support.microsoft.com/kb/933468

Non of the above solved the problem, Any advice? Big Grin


- davilla - 2009-04-27 21:24

shlomi.schwartz Wrote:I see ...
So what would be the best solution for this:

I stream SD content from my Vista machine (via SMB) it works well on OS reboot, but after a while it stutters (buffering).

If I restart my OS it works fine again. I tried the following:
  • Changing the cache on XBMC settings
  • Changing the vista policy to "LM and NTLM – use NTLMV2 session security if negotiated"
  • followed this article support http://support.microsoft.com/kb/933468

Non of the above solved the problem, Any advice? Big Grin

virus checking on the vista side slowing down streaming ?


- althekiller - 2009-04-27 22:29

Or the firewall.


- shlomi.schwartz - 2009-04-28 14:19

I'll scan for viruses (even though there is an AVG scheduled scan every day).
Not sure about the firewall (I only use the windows firewall), what should I check there?

Could this be because Vista is using SMB 2.0?
can I see any clue for my streaming problem in the XBMC log?

Thanks again for all your help! Wink


- shlomi.schwartz - 2009-04-28 14:20

Just a reminder:
If i reboot the system, all is back to normal


- garyi - 2009-04-28 14:45

Defo something to get to grips with on your vista machine. I use SMB for my droboshare, and its flawless with XBMC.


- shlomi.schwartz - 2009-04-28 17:18

Do you use it with Vista? Confused


- shlomi.schwartz - 2009-04-29 10:33

I guess FTP is the solution for now ... no thumbs for me Sad


- garyi - 2009-04-29 22:19

You need to sort your stuff out on vista. There is something on the machine you are streaming from causing the issue not XBMC. I tap my droboshare with SMB and its perfect.


- shlomi.schwartz - 2009-05-01 09:10

Another problem with FTP streaming, fast forward fails on speed higher than X4.
Can anyone help on the SMB - Vista issue ?