XBMC Community Forum
[Archive] Transparency! - v0.27 - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Skin Help and Support (/forumdisplay.php?fid=67)
+---- Forum: Transparency! (/forumdisplay.php?fid=115)
+---- Thread: [Archive] Transparency! - v0.27 (/showthread.php?tid=52125)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38


- m.savazzi - 2009-07-03 21:14

Justcop Wrote:Settings>Appearance>View Options>Disable source button in file list

easy ;-)

Dummmmmy me Smile

great!
now I'm 99% done...


- ronie - 2009-07-04 00:13

nicoli_k Wrote:Unfortunately, the imdb scraper for the xbox is messed up so the cast doesn't show

there was an issue with the imdb scraper, it was fixed yesterday.

nicoli_k Wrote:Edit: It seems that it's ok to scrobble and have LastFM play nice with the skin. You just can't have the root LastFM folder be in your sources. I went to make it a source, but went deeper into the root folder to my profile, lastfm://Your profile (nicoli__k), and made that a source and all is good with the world. I then added another source with the root of LastFm and the blackness came back. So root of Lastfm and Transparency! on xbox = black screen after exiting a song... I'm pretty sure at least.

Thanx for all your efforts and the hell you had to go through to get your video library back in place. I'm even feeling a bit guilty since this is obviously due to some stupid coding error i made in Transparency!......now if i could only put my finger on it.

I've been testing around with lastfm and shoutcast for a while now, and low and behold, i've managed to get a black screen two times on my linux pc!
so as for now, it's not an xbox only issue.

I have a strong feeling it has to do with my hack to show fanart in filemode for music.
Did it ever happen to you when you were using music in library mode ?

The more i think of it, the stronger the feeling i get that it's trying to download a fanart.jpg image from lastfm or something....

Anyway, my quest continues....


- nicoli_k - 2009-07-04 00:28

yeah, I saw that the scraper's been fixed, but it hasn't made it to the xbox yet. I'm not too worried about it. It'll get merged eventually. Luckily I backed up my old folder and was able to dump everything into the new Userdata.

ronie Wrote:Did it ever happen to you when you were using music in library mode ?

Yeah, I got the black screen using the Fanart mode inside of the Music section, but that's only when I have the source of "lastfm://" if I go inside and to my profile and make that the source, the problem doesn't occur. I have yet to get the dreaded black screen using any other folder.

I've taken off the root Lastfm source and the problem goes away. I can listen to my playlist, scrobble all day long, and not have to restart XBMC to have the menu show up as long as I've got my profile as source.


- Greg. - 2009-07-04 11:06

[quote=ronie]ok, i've spent a few hours troubleshooting this. these are my findings:
- i don't have problems with music on a linux share
- i have to same problem as you with music on a windows share
- the problem only occurs when using music in filemode
- if i switch to library mode all is fine for me
- it's related to Transparency! trying the find a fanart.jpg image, this is a workaround i use to make fanart in filemode possible. other skins don't have this feature, so don't trigger this error.

thanks for that Ronie, your quite right library mode has no issues providing a reboot is done after the first error in file mode, and I can live with that for now. Wish you well with transparency!, will be following it with interest and hope too contribute more later.


- m.savazzi - 2009-07-04 18:32

ronie Wrote:open MyVideo.xml and MyVideoNav.xml find the library button and add
<visible>Skin.HasSetting(librarybutton)</visible> like this:

Done and working.

On the Movies there is a strange effect as the other buttons does not shift up if the library one is not visible.
Is there anyway to make to position depending on the value of Library Button?

ronie Wrote:next edit the guisettings.xml file of your profile and add:
<setting type="bool" name="Transparency!.librarybutton">true</setting>

I've seen the page to change the skin settings is not generated automatically (hehehe) which one is the correct one to modify? (your suggestion) Smile


- ronie - 2009-07-04 23:14

Greg. Wrote:[quote=ronie]ok, i've spent a few hours troubleshooting this. these are my findings:
- i don't have problems with music on a linux share
- i have to same problem as you with music on a windows share
- the problem only occurs when using music in filemode
- if i switch to library mode all is fine for me
- it's related to Transparency! trying the find a fanart.jpg image, this is a workaround i use to make fanart in filemode possible. other skins don't have this feature, so don't trigger this error.

thanks for that Ronie, your quite right library mode has no issues providing a reboot is done after the first error in file mode, and I can live with that for now. Wish you well with transparency!, will be following it with interest and hope too contribute more later.

Cheers Greg. I'll probably add an option to disable fanart in filemode, this should get rid of the lock settings popup.


- ronie - 2009-07-04 23:22

mfsav2 Wrote:Done and working.

On the Movies there is a strange effect as the other buttons does not shift up if the library one is not visible.
Is there anyway to make to position depending on the value of Library Button?

add this to all buttons below the library button (except for the two fake buttons):
Code:
<animation effect="slide" start="0,0" end="0,-45" time="0" condition="!Skin.HasSetting(librarybutton)">conditional</animation>
also add it to the shadow-bottom2.png image

mfsav2 Wrote:I've seen the page to change the skin settings is not generated automatically (hehehe) which one is the correct one to modify? (your suggestion) Smile

if you want to option to be available under Skin Settings, modify custom_SkinSetting_1111.xml
put this somewhere between the other options:
Code:
<control type="radiobutton" id="999">
    <width>880</width>
    <height>35</height>
    <font>font12</font>
    <label>Show Library Button</label>
    <textcolor>grey2</textcolor>
    <focusedcolor>white</focusedcolor>
    <texturefocus border="7">list-focus.png</texturefocus>
    <texturenofocus>-</texturenofocus>
    <textureradiofocus>radiobutton-focus-2.png</textureradiofocus>
    <onclick>Skin.ToggleSetting(librarybutton)</onclick>
    <selected>Skin.HasSetting(librarybutton)</selected>
</control>



- ronie - 2009-07-04 23:32

Work in progress...

Currently trying out some of the requests that are still on my to-do list.
- fanart view for now playing (see below)
- get rid of the neon green color theme
- drop the square corners
- change the font

[Image: now-playing.jpg]

nothing's definite, so it's likely to change before release.
but you know, all input is appreciated.


- m.savazzi - 2009-07-05 00:35

ronie Wrote:add this to all buttons below the library button ...

PERFECT!!!!!! you are too kind!!!!!

Thanks a lot!!!!!


- m.savazzi - 2009-07-05 00:39

Question:
which is the meaning of the media flags?

in this example
[Image: screenshot003djw.th.jpg]

I have:
480 - is the size...
MPEG4 - what is this? the video is an AVI MP4 without audio
DVD Offline - correct from the name
DVD - why is repeated?

thanks


- m.savazzi - 2009-07-05 00:43

ronie Wrote:Work in progress...

Currently trying out some of the requests that are still on my to-do list.
- fanart view for now playing (see below)
- get rid of the neon green color theme
- drop the square corners
- change the font

[Image: now-playing.jpg]

nothing's definite, so it's likely to change before release.
but you know, all input is appreciated.

It's very nice... but how do you enable the fanart for music?


- m.savazzi - 2009-07-05 00:49

Question:
In music there is the Library button but is gray?

why is it there? I can have a music library? how?
[edit: found the scan items to library....]


- Justcop - 2009-07-05 01:00

If you want my honest opinion of the your screen shot, I think its pretty terrible. I'm looking for something very sleek, that font is almost gothic, how about something more modern?

And as for the blue, definatly a good choice but I think that shade is too dark and two plain, is that one of the 16 bit colours? eww


- ronie - 2009-07-05 01:08

mfsav2 Wrote:Question:
which is the meaning of the media flags?

I have:
480 - is the size...
MPEG4 - what is this? the video is an AVI MP4 without audio
DVD Offline - correct from the name
DVD - why is repeated?
thanks

MPEG4 is the video codec
DVD is the source (source can be DVD, HDDVD, Blu-Ray, HDTV, SDTV)


mfsav2 Wrote:It's very nice... but how do you enable the fanart for music?

this will only work if your music direcory structure is Music/Artist/Album with a fanart.jpg image in the artist folder.

so like this:
Music/Artist1/Album1/Songs
Music/Artist1/Album2/Songs
Music/Artist1/fanart.jpg


- m.savazzi - 2009-07-05 01:16

ronie Wrote:MPEG4 is the video codec
DVD is the source (source can be DVD, HDDVD, Blu-Ray, HDTV, SDTV)

I expcted offline DVD to be the source... why I have even DVD? is it normal or a mistake in the code I put Smile

[EDIT]: Found my mistake... correct line is:
<control type="image" id="5085">
<include>MovieMediaflagsVars</include>
<texture>flags/movies/source/dvd.png</texture>
<visible>substring(listitem.filename,sddvd) | substring(listitem.filename,.ifo) | substring(listitem.filename,.vob) | [[!substring(listitem.filename,hddvd) + !substring(listitem.filename,bluray) + !substring(listitem.filename,offdvd)] + [substring(listitem.filename,.iso) | substring(listitem.filename,.img) | substring(listitem.filename,.avi) | substring(listitem.filename,.mkv) | substring(listitem.filename,.mov) | substring(listitem.filename,.mpg) | substring(listitem.filename,.mpeg) | substring(listitem.filename,.ts) | substring(listitem.filename,.wmv)] + ![substring(listitem.studio,720) | substring(listitem.studio,1080) | substring(ListItem.VideoResolution,720) | substring(ListItem.VideoResolution,1080)]]</visible>
</control>

Otherwise offdvd is read as dvd


ronie Wrote:this will only work if your music direcory structure is Music/Artist/Album with a fanart.jpg image in the artist folder.

so like this:
Music/Artist1/Album1/Songs
Music/Artist1/Album2/Songs
Music/Artist1/fanart.jpg

Harg!
my music is a mess!

I will have to re sort all of it.

This means that you cannot have multiple fanart? or different fanart for the album?