XBMC Community Forum
Sick Beard - Automatic TV Show Episode download/sort/rename, nfo/tbn maker & TV Guide - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for XBMC (/forumdisplay.php?fid=116)
+--- Thread: Sick Beard - Automatic TV Show Episode download/sort/rename, nfo/tbn maker & TV Guide (/showthread.php?tid=63591)



- deltazulu - 2010-07-22 17:09

Getting 500 error trying to process Losing It With Jillian

Code:
500 Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
  File "/export/home/danny/.sickbeard/cherrypy/_cprequest.py", line 660, in respond
    response.body = self.handler()
  File "/export/home/danny/.sickbeard/cherrypy/lib/encoding.py", line 193, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "/export/home/danny/.sickbeard/cherrypy/_cpdispatch.py", line 25, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/export/home/danny/.sickbeard/sickbeard/webserve.py", line 908, in processEpisode
    result = processTV.processDir(dir, nzbName)
  File "/export/home/danny/.sickbeard/sickbeard/processTV.py", line 187, in processDir
    result = processFile(curFile, dirName, nzbName)
  File "/export/home/danny/.sickbeard/sickbeard/processTV.py", line 443, in processFile
    newFile = os.path.join(destDir, helpers.sanitizeFileName(rootEp.prettyName())+biggestFileExt)
  File "/export/home/danny/.sickbeard/sickbeard/tv.py", line 1591, in prettyName
    if "Talk Show" in self.show.genre and sickbeard.NAMING_DATES:
TypeError: argument of type 'NoneType' is not iterable

Powered by CherryPy 3.2.0rc1

Show is "Losing.It.with.Jillian.S01E08.Alvarez.Family.HDTV.XviD-FQM".
TVDB shows the title of this show as "Losing It with Jillian Michaels!".
Tried renaming folder to "Losing.It.with.Jillian.Michaels.S01E08.Alvarez.Family.HDTV.XviD-FQM" but still get error... I think the "!" in tvdb is causing the error. To avoid having to rename every show, can this be wildcarded or something in the sabToSickBeard.py? I know some exceptions had to be made for Hell's Kitchen since it has the apostrophe inthe name.


- Sinnocence - 2010-07-22 21:00

Any python savvy user here capable of writing a small script to just call the http://<server>:<port>/manageShows/manageSearches/forceBacklog URL?

I tried to knock one up but my first foray into Python proved less than successful. The wiki even has an example of loading a URL but it's not triggering the force (and I can't see anything obvious to suggest the script failed).

Any help would be much appreciated.

Thanks.


- mattressfish - 2010-07-22 21:19

just use wget. It's available for windows. Then you just need a batch file that says:

wget http://<server>:<port>/manageShows/manageSearches/forceBacklog


- Sinnocence - 2010-07-22 22:34

mattressfish Wrote:just use wget. It's available for windows. Then you just need a batch file that says:

wget http://<server>:<port>/manageShows/manageSearches/forceBacklog

XBMC wont directly call it though right? You'd need to get a script to allow you to run .bat files?


- kricker - 2010-07-22 22:40

Sinnocence Wrote:XBMC wont directly call it though right? You'd need to get a script to allow you to run .bat files?
You could. There are threads discussing how to run external apps from XBMC using launcher plugin or directly (I know as I started one of them). You could even make your own menu/submenu item to do it. A little forum searching ought to get you what you need.

An XBMC addon to manage SB would be superb though.


- branlr - 2010-07-23 02:05

All hail whoever is willing to make a sickbeard addon for xbmc!


- ECEC - 2010-07-23 17:31

Using 456 on Windows Home Server. Sickbeard is set to automatically start on login, but the last time it started up before the mapped drive to my tv shows was reconnected. This results in Sickbeard thinking the dir is missing for all shows, and is usually corrected by restarting Sickbeard once the drive is reconnected. On 456, it still doesn't see the directory.

What can I do?


- mattressfish - 2010-07-23 17:35

ECEC Wrote:Using 456 on Windows Home Server. Sickbeard is set to automatically start on login, but the last time it started up before the mapped drive to my tv shows was reconnected. This results in Sickbeard thinking the dir is missing for all shows, and is usually corrected by restarting Sickbeard once the drive is reconnected. On 456, it still doesn't see the directory.

What can I do?

If its the same thing as this post:

http://forum.xbmc.org/showpost.php?p=571698&postcount=1344

You might not like the answer.


- darkscout - 2010-07-23 22:10

More or less just 'confirmed' that the search isn't failing back to other providers.

For new stuff it doesn't seem to matter, but for the backlog search what provider is on top seems to make a huge difference.

Kicked off a backlog search. Waited until it finished an then cleared the history.
Drug the bottom NZB search provider from the bottom to the top. (I have all of them enabled).

Kicked off another search. Found a ton of new episodes.

------------

Quote:You might not like the answer.

Yeah. I had the same problem with this a while ago. The only way I can think of to take care of it for now is to launch sickbeard with a bat file that waits until the drives are mounted.


- midgetspy - 2010-07-23 22:48

darkscout: post a log of it not searching all providers.


Setup: help finding episodes - jtmarcot - 2010-07-24 05:12

I'm struggling a bit on my first sickbeard setup. I've tried many different configurations, but sickbeard is refusing to find episodes on BinReq. I'm trying to d/l the latest episode of JTMARCOT. Under "Manage Shows", I change the episode status to "Wanted", and I choose "Search".

The error I get is ...

"No downloads were found
Couldn't find a download for JTMARCOT S07E06 YADA YADA"

When I manually search the Bin-Req site, the episode comes up with no issue. I've also tried the same on a couple other shows with the same result.

I've got sabnzbd running without issue on windows 7. SickBeard is running as built from source (as of about 12 hours ago), and is running on the same machine.

Any insight would be greatly appreciated.


- steve1977 - 2010-07-24 07:46

Would love to see a QPKG file for Sickbeard to get it on my NAS without manual install. Anyone working on this? Thanks in advance!!!


- ECEC - 2010-07-24 15:09

mattressfish Wrote:If its the same thing as this post:

http://forum.xbmc.org/showpost.php?p=571698&postcount=1344

You might not like the answer.

Ouch, that sucks. Sickbeard is a lot less useful if I end up with a temp folder full of unsorted TV show directories. :/

@midgetspy: will the fix for this be able to restore the paths or should I just go ahead and kill the db and start over?

Edit: or better yet have you looked into supporting UNC paths? Then I could just use \\server\share and not have to worry about the mapped drives at all.


- flamez - 2010-07-24 15:57

Anyone else running into this from nzbmatrix? Error trying to load NZBMatrix RSS feed: syntax error: line 1, column 49

I just noticed it wasn't pulling any nzb's from there anymore. Looks like nzbmatrix may have changed something on there end?


- kricker - 2010-07-24 16:14

I'm seeing it as well. But nzbmztrix shows the rss is offline and the API is still having issues. So that is most likely the cause.