XBMC Community Forum
Notify - iPhone Notification App for XBMC (send push notifications to XBMC) - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for XBMC (/forumdisplay.php?fid=116)
+--- Thread: Notify - iPhone Notification App for XBMC (send push notifications to XBMC) (/showthread.php?tid=64545)



- johoja - 2011-11-07 18:04

mongo527 Wrote:I just updated to Growl 1.3 on OS X and i cant get any notifications to come through. It was working perfectly on 1.2.2. I updated to 1.3 to be able to reply back to SMS!

Please read the thread, 1.3 now supports GNTP so UDP should not be used when configuring NP.


- mongo527 - 2011-11-07 18:50

johoja Wrote:Please read the thread, 1.3 now supports GNTP so UDP should not be used when configuring NP.

Sorry, probably should have said I am not using UDP. The weird thing is, Growl sees NP. Under Applications it lists NP, but it seems Growl just doesn't show a notification.


- johoja - 2011-11-07 18:52

mongo527 Wrote:Sorry, probably should have said I am not using UDP. The weird thing is, Growl sees NP. Under Applications it lists NP, but it seems Growl just doesn't show a notification.

Strange, could you please send me screen shots of the settings in growl. I don't have a mac so don't have growl 1.3. But it should work, since it works on windows. Make sure your display settings are correct in Grow.


- mongo527 - 2011-11-08 06:17

johoja Wrote:Strange, could you please send me screen shots of the settings in growl. I don't have a mac so don't have growl 1.3. But it should work, since it works on windows. Make sure your display settings are correct in Grow.

I emailed you the screenshots... Thanks!


- johoja - 2011-11-08 18:06

Does anyone here use Growl 1.3 on a Mac and have Notify Pro working ?

I don't have a Mac so it's a little hard for me to figure what's not working.

If you do have it working would you please share your settings.


- dareal68 - 2011-11-10 15:22

I finally manage to have Notify Pro to work with Growl-for-linux (my noob mistake, wrong port number), I actually use version 0.6.1 (here is the git: https://github.com/mattn/growl-for-linux).

Here are my Notify Pro settings:

Title: [what you want]
IP Address: [your IP]:9887
Password: [what you want]
Call Notify: [ON or OFF]
SMS Notify: [ON or OFF]
Push Notify: [ON or OFF]
Mail Notify: [ON or OFF]
Use UDP: ON

Growl settings:

Screenshot

SMS, Call, Mail notifications work perfectly but Push, iMessage don't work.

Thanks for this great work.

PS: are you working on a 2.0 version of Notify Pro?


- panos - 2011-11-15 23:40

johoja Wrote:Does anyone here use Growl 1.3 on a Mac and have Notify Pro working ?

I don't have a Mac so it's a little hard for me to figure what's not working.

If you do have it working would you please share your settings.

I have the latest Growl app for snow leopard (1.2). My OS is the 10.6.8. I just purchased notify pro (1.78) a few hours ago but it doesn't work! I tried nearly everything but still nothing! I d appreciate your help! Thank you very much in advance!

Panos


- panos - 2011-11-16 00:12

Connected!! FANTASTIC APP!! Thank you very much!


- jaaahaaa - 2011-11-27 01:15

Tested the version you posted here... ios5, 3gs (week 35) and eden xbmc build. Got incoming call to work but nothing else.


- johoja - 2011-11-28 07:28

jaaahaaa Wrote:Tested the version you posted here... ios5, 3gs (week 35) and eden xbmc build. Got incoming call to work but nothing else.

Please provide a syslog, can't help without it.

Just so everyone is aware I'm looking into the Growl 1.3+ issues on OSX, not sure entirely what the problem is. I think it might be something on their side. Not sure.


- jaaahaaa - 2011-11-29 01:28

johoja Wrote:Please provide a syslog, can't help without it.

Just so everyone is aware I'm looking into the Growl 1.3+ issues on OSX, not sure entirely what the problem is. I think it might be something on their side. Not sure.

Suddendly worked for my sms as well Smile

How do I set up eg? The only thing I can find is a broken link to a video...


- jaaahaaa - 2011-11-29 18:18

Figured it out that it talks to the eg webbserver... time to play Big Grin

Got a lamp that will start blinking when the phone rings... ooh yeah


- johoja - 2011-11-29 23:23

jaaahaaa Wrote:Figured it out that it talks to the eg webbserver... time to play Big Grin

Got a lamp that will start blinking when the phone rings... ooh yeah

Yeah sorry, that video died a long time ago.

Also you need to have a file named 'empty' in your web directory for it to work properly.


- GregNYR89 - 2011-12-13 00:48

johoja Wrote:Please provide a syslog, can't help without it.

Just so everyone is aware I'm looking into the Growl 1.3+ issues on OSX, not sure entirely what the problem is. I think it might be something on their side. Not sure.


Hi Johaja,

I believe the problem with Growl 1.3 not showing the notifications has to do with the framework version that you use for Notify Pro.

I've had similar problems with other apps on my mac where notifications were either not working or were not displaying correctly from other programs such as Skype...

What I did was downloaded a program from Growl.info called "Growl Version Detective" and was able to upgrade all the app's that can use Growl with "Framework Version 0.7.6" (or other versions depending on what the app used) to "Framework Version 1.3".

Once all the app's were upgraded with the new growl framework, all the notifications were displaying on Growl 1.3+.

The new 1.3.1 SDK is available on their website.

Hope this helps somehow.

-Greg


- Rubeast - 2011-12-19 14:53

I have been using the iPhonedelivery tweak for some while now.
More info
That way I get a little checkmark when I successfully send a message.

But when I send a message using my browser and the DeskSMS site, iPhonedelivery does not work.
I'm positive that this used to work on my iPhone under iOS4.

iPhone 4 - iOS5.01 - DeskSMS 1.0.75 - iPhonedelivery 0.5.1-7