XBMC Community Forum
[Linux] HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Announcements, Info, and General Discussion (/forumdisplay.php?fid=85)
+--- Forum: Tips, tricks, and step by step guides (/forumdisplay.php?fid=110)
+--- Thread: [Linux] HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware (/showthread.php?tid=70068)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36


- bobo1on1 - 2010-07-06 19:41

I'd use a 50 hertz mode instead of 25.


- Goga777 - 2010-07-06 20:07

even for 50 field per seconds video or 25 frame per second you would like to use 50 Hertz ?
Do you propose to remove mode "1920x1080_25" at all ?


- bobo1on1 - 2010-07-06 20:10

50 hertz is fine for 25 fps and 50 fps video, but 25 hertz can only do 25 fps video.


- Goga777 - 2010-07-06 20:18

but I suspected that with

Code:
Modes       "1920x1080" "1920x1080_25" "1920x1080_24_0" "1920x1080_30" "1920x1080_60"

for 25 fps video xbmc will choice "1920x1080_25"
but for 50 fps video xbmc will choice "1920x1080" which mean "1920x1080_50p"


- bobo1on1 - 2010-07-06 20:20

No, if 50 hertz is available it will always choose that for 25 fps.


- Goga777 - 2010-07-06 20:29

thanks, I didn't aware about it.

But let's come back to "1920x1080_50p" mode for 25 fps video. How xbmc will increase the fps from 25 fps (or 50 field per second) to 50 fps ?


- davilla - 2010-07-06 20:53

Goga777 Wrote:thanks, I didn't aware about it.

But let's come back to "1920x1080_50p" mode for 25 fps video. How xbmc will increase the fps from 25 fps (or 50 field per second) to 50 fps ?

show the same frame twice Smile 50 / 25 = 2.0000...

also, stop thinking "fields per second" unless you are taking interlaced Smile


- Goga777 - 2010-07-06 21:03

And such idea also correct for interlaced video ?

as far as know for video with 50 field per second need very powerfull deinterlacer (hardware or software) to do such job (50 fields per second ----> 50 frame per second), right ?

what happened if vdpau graphic card doesn't have such performance or CPU is very slow ?


- bobo1on1 - 2010-07-06 22:47

Goga777 Wrote:what happened if vdpau graphic card doesn't have such performance or CPU is very slow ?
Then you're screwed.
But this only happens on really slow hardware.


Problems with a JVC DILA - wmilas - 2010-07-08 03:18

I have a JVC DILA I'm trying to get running with an ION chipset. I've having a bit of a problem. I have a whole slew of modes validate correctly:

Code:
(II) Jul 07 20:05:23 NVIDIA(0): --- Modes in ModePool for JVC ILAFPJ -- XT4 (DFP-1) ---
(II) Jul 07 20:05:23 NVIDIA(0): "nvidia-auto-select" : 1920 x 1080 @  60.1 Hz Interlace  (from: E
DID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080"          : 1920 x 1080 @  60.1 Hz Interlace  (from: E
DID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_60i"      : 1920 x 1080 @  60.1 Hz Interlace  (from: E
DID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_60"       : 1920 x 1080 @ 59.94/60 Hz (CEA-861B Format
16) (from: EDID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_50"       : 1920 x 1080 @  50.0 Hz  (from: EDID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_24"       : 1920 x 1080 @ 23.97/24 Hz (CEA-861B Format
32) (from: EDID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_60i_0"    : 1920 x 1080 @ 59.94/60 Hz (CEA-861B Format
5) (from: EDID)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_50i"      : 1920 x 1080 @ 50 Hz Interlace (CEA-861B Fo
rmat 20) (from: EDID)

But then when the it then adds the modes it doesnt add the the 60p or 24p modes:

Code:
(II) Jul 07 20:05:23 NVIDIA(0): Assigned Display Device: DFP-1
(II) Jul 07 20:05:23 NVIDIA(0): Validated modes:
(II) Jul 07 20:05:23 NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(II) Jul 07 20:05:23 NVIDIA(0):
(II) Jul 07 20:05:23 NVIDIA(0): Implicitly adding the following modes to X Screen 0 (these
(II) Jul 07 20:05:23 NVIDIA(0):     will be available via XRandR and XF86VidMode):
(II) Jul 07 20:05:23 NVIDIA(0):
(II) Jul 07 20:05:23 NVIDIA(0): "nvidia-auto-select" : 1920 x 1080 @  60.1 Hz Interlace
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_50"       : 1920 x 1080 @  50.0 Hz
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_60i_0"    : 1920 x 1080 @ 59.94/60 Hz (CEA-861B Format
5)
(II) Jul 07 20:05:23 NVIDIA(0): "1920x1080_50i"      : 1920 x 1080 @ 50 Hz Interlace (CEA-861B Fo
rmat 20)

I'm at a loss as to why its doing this. No errors or anything? Help Smile


- trolly - 2010-07-08 08:20

Hi,

I follow this guide with success, but i just miss something in part 4.

export DISPLAY=:0; nvidia-settings -a "SyncToVBlank=1" -a "AllowFlipping=1" -a "FSAAAppControlled=1" -a "OpenGLImageSettings=3" -a "LogAniso=0" -a "GPUScaling[DFP-1]=1,1"; nvidia-settings -r

On my config (9.10 x86, svn 31642, nvidia 256.35), when I launch the command manually (ssh) it work. But after a reboot, tv don't switch in the appropriate mode anymore.

So I try to put the line in :
/etc/profile
/etc/bash.rc
/home/user/bash.rc

but it doesn't work (when I access with ssh it launch the command and xbmc work fine).

Question is : Where can I put the command so it apply settings automatically at startup ?

Thank you.


Sorry, not my native languague.


- JumJum - 2010-07-08 17:24

trolly Wrote:Hi,

I follow this guide with success, but i just miss something in part 4.

export DISPLAY=:0; nvidia-settings -a "SyncToVBlank=1" -a "AllowFlipping=1" -a "FSAAAppControlled=1" -a "OpenGLImageSettings=3" -a "LogAniso=0" -a "GPUScaling[DFP-1]=1,1"; nvidia-settings -r

On my config (9.10 x86, svn 31642, nvidia 256.35), when I launch the command manually (ssh) it work. But after a reboot, tv don't switch in the appropriate mode anymore.

So I try to put the line in :
/etc/profile
/etc/bash.rc
/home/user/bash.rc

but it doesn't work (when I access with ssh it launch the command and xbmc work fine).

Question is : Where can I put the command so it apply settings automatically at startup ?

Thank you.


Sorry, not my native languague.

nvidia-settings requires a running Xorg to work. Try with "DISPLAY=:0; nvidia-settings -l" in ~/.xinitrc


- Goga777 - 2010-07-08 19:52

bobo1on1 Wrote:I'd use a 50 hertz mode instead of 25.

I removed 25 herz mode and now I have

Quote:Modes "1920x1080_50" "1920x1080_24_0" "1920x1080_30" "1920x1080_60"

but xbmc reported

19:12:43 T:3032754048 M:159531008 INFO: ID:0x128 Name:1920x1080 Refresh:25.000000 Width:1920 Height:1080


why ?

http://paste.ubuntu.com/460698/


- trolly - 2010-07-08 23:32

Quote:nvidia-settings requires a running Xorg to work. Try with "DISPLAY=:0; nvidia-settings -l" in ~/.xinitrc

Don't seems to work.
I create a ~/.xinitrc file with the line but xbmc don't start anymore.
So I try to put it in /etc/X11/xinit/xinitrc, /etc/X11/Xsession don't work either.

The only thing that work is to start a ssh session from another pc and launch
Quote:export DISPLAY=:0; nvidia-settings -a "SyncToVBlank=1" -a "AllowFlipping=1" -a "FSAAAppControlled=1" -a "OpenGLImageSettings=3" -a "LogAniso=0" -a "GPUScaling[DFP-0]=1,1"; nvidia-settings -r
.

Can't find the right place to add this.

But I have to find it cause the result is like the topic says, perfect.


- trolly - 2010-07-09 11:43

Don't know if it's clean, but it works.

1. Set $DISPLAY variable
export $DISPLAY=:0 in /etc/environnement

2. Create a file called 56nvidia-settings i, /etc/X11/Xsession.d/ which execute nvidia-settings -l

Quote:# loads nvidia-settings config
if [ -x /usr/bin/nvidia-settings ]; then
/usr/bin/nvidia-settings -l
fi