XBMC Community Forum
AudioEngine branch - DO NOT REQUEST BINARY BUILDS - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Development (/forumdisplay.php?fid=93)
+--- Thread: AudioEngine branch - DO NOT REQUEST BINARY BUILDS (/showthread.php?tid=78289)



- gnif - 2012-01-30 03:08

@Calvados - please do, just pastebin it, if too big for pastebin, please make a clean log and pastebin that Smile


- DDDamian - 2012-01-30 03:12

@calvados - I have a similar issue under Win7 where the driver reports supporting of 88.2khz, responding positive in the IsSupported method, and then fails to initialize the sink. Still trying to find a workaround here - only 88.2khz affected - gonna try 176.4khz as some SACD's are ripped to that.

At least in Win7 with ATI its a driver issue.


- Calvados - 2012-01-30 03:46

@DDDamian: not a driver issue for me. It used to work fine with AE (July code).
@gnif: will do in 3 hours - pastebin is a bit slow now, and I have to run.


- Gryph - 2012-01-30 04:30

I have tested multi-channel FLACs as well as some 88kHz ones last night, I have yet to run into anything that can't play in its correct format.

On a side note; away for work for a few days, but when I get back I'll start testing again.


- DDDamian - 2012-01-30 04:42

@gryph - that's excellent news. I just found a driver update for the ATI GPUs released as part of the Catalyst package last week 1/25/2012 IIRC.

Driver is AMD 7.12.0.7705 dated 12/6/2011 - I can confirm it's fixed the issues with 88.2 and 176.4khz files.


- Calvados - 2012-01-30 06:37

My log:

http://pastebin.com/AzBvjgcz

Going to try your latest commits though in the meantime.

Edit: Tried latest commits, same issue with my FLAC.


- Hack_kid - 2012-01-30 07:53

ok and what does the audiophile setting actually enable/disable/change?


- gnif - 2012-01-30 08:02

@Hack_kid - with this setting disabled when playing audio if there is already an existing stream running, the new stream if it doesn't match the audio format, will be re-sampled, downmixed and converted to match so that mixing may occur seamlessly (no audio breaks).

Turning this on makes AE prefer to switch to the new stream's audio format causing a break in output... if there are any other older streams running they will be converted to the format of the new stream.

It doesn't matter what this setting is at for bit-streaming though, it is always passed through.

@Calvados - Investigating, can you please also provide a sample of the file.


- Hack_kid - 2012-01-30 08:06

gnif so basically its for listening to music. like with it enabled and one track is mp3 2ch and then it switches to flac 5.1 there will be a drop in there while it changes formats (much like xbmc acted with the old audio platform) versus with it disabled i will get that nice suddle crossfade? i'll go with audiophile lol

correct me if i'm wrong


- gnif - 2012-01-30 08:19

@Hack_kid - You are correct there, unfortunately there is not much we can do to avoid this crowbarring of audio formats into each other if people want cross-fade. This setting used to be called perferSeemless, which I am inclined to rename it to, and default it to off.


- Calvados - 2012-01-30 08:37

@gnif:

http://rapidlibrary.com/files/testeflac8824-flac_ulffnq8ccvifon.html

Alternatively, google for testeflac8824.flac Smile.


- DDDamian - 2012-01-30 10:18

@hack_kid - think of it as party-mode vs quality mode. If you've got a playlist of mp3s I'd leave it off. If you've got a lot of HQ stuff turn in on. It's basically to avoid downmixing and stuff - like going from 2-channel to 5.1 channel and losing all that surround effect, or having 96khz sources mixed down to 44.1khz.

AE presents a lot of inherent sonic advantages beyond TrueHD and DTS-MA, such as dithering, 24bit output, low latency, WASAPI exclusive, etc. This basically keeps it audio-wise right up there with the best of the dedicated audio players. But definitely not for most, who want the seemless cross-fade at the expense of some downmixing/downsampling. Audiophile vs party player - all good Smile


- rodercot - 2012-01-30 13:15

gnif Wrote:@Calvados - I have tracked down the issue, it is because I was calculating the period timeout and size assuming it was analog output, not a bitstream format. I have committed some fixes that should make things run smooth again. There are hard coded values for normal bitstreaming, and higher bitrate values for HD streams.
I have also located and fixed the looping sync re-open issue


Gnif,

GT430, Lucid(myth)10.04.3, alsa 10.23

All good with Hd here after the commits above, did not watch a full movie so I cannot report on dropouts. Suspend/Resume WORKS - and all formats playback fine after resuming. I have not tested any music but mine are all 96/24 or higher. did not test any m-c flac files will do so tonight.

A Note - I have one movie in truehd ex (6.1) so a single surround rear (in flag) for the avr, when this file plays the cpu usage jumps to over 50% and stays around there, does not seem to cause an issue for me but thought I would let you know. All my normal 5.1 truehd files play with use at around 10-15% (this is combined or total use I am talking)

THANKS Gnif for all your hard work.

rgds,

Dave


- elite1967 - 2012-01-30 20:17

Hi,
just tested the latest version and I am having some troubles:
- playback is faster than normal (I would say 2x)
- CPU usage is 100%
- I get some notifications in the screen: the notifications have no text inside them and an exclamation mark icon. They appear also during playback (please see photos)

Here is my logfile:
http://pastebin.com/5MPVtiSP

Version of 25/1 was fine.
I am reverting to that version.

Here are the screenshots of the notifications:
[Image: screenshot005o.png]
[Image: screenshot000v.png]
[Image: screenshot006u.png]


- DDDamian - 2012-01-30 20:26

@elite1967 - I'm more working the windows side, but I looked at your log (as it's pretty early where gnif is and he codes all night Laugh) and it appears AE couldn't inititalize your hardware device:

Code:
INFO: CAESinkALSA::Initialize - Attempting to open device hdmi,AES0=0x06,AES1=0x82,AES2=0x00,AES3=0x0e698.
18:53:17 T:140518060201728   ERROR: CAESinkALSA::Initialize - snd_pcm_open_lconf(-2) - hdmi,AES0=0x06,AES1=0x82,AES2=0x00,AES3=0x0e699.
18:53:17 T:140518060201728   ERROR: CAESinkOSS::Initialize - Failed to get supported formats, assuming AFMT_S16_NE

Are your settings correct for your ALSA output device? That's about all I can suggest. If that doesn't help gnif will be able to guide you further.