XBMC Community Forum
[RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC (/showthread.php?tid=79487)



- HenrikDK - 2011-07-15 21:09

Seems sraue has replicated the problem on 64bit OpenELEC and it seems related to the gcc upgrade:

Quote:I have updated OpenELEC with gcc-4.6.1 recently and now we have this bug too (only with x64 builds). from the time it can be related to the upgrade with gcc-4.6.1 from 4.5.3. makes this sense?

http://trac.xbmc.org/ticket/11584


- sraue - 2011-07-15 21:45

HenrikDK Wrote:Seems sraue has replicated the problem on 64bit OpenELEC and it seems related to the gcc upgrade:

http://trac.xbmc.org/ticket/11584

can you confirm Arch is running (xbmc is compiled with) gcc-4.6.x?


- Angelscry - 2011-07-15 22:20

sraue Wrote:can you confirm Arch is running (xbmc is compiled with) gcc-4.6.x?
Yes. Actual version of gcc under Archlinux is 4.6.1 : http://www.archlinux.org/packages/core/x86_64/gcc/


Similar or same problem - gven - 2011-07-16 01:23

dave_e Wrote:No proxy, no firewall -- like I said, I can hit that URL via curl from the command line or from within firefox and it works just fine. But I've got two different machines running XBMC, and they both have this same problem. I read through this whole thread again and saw that at least one other person had this same issue, but I didn't see a solution. Anything you can think of that I could try to help troubleshoot the issue? Is this question better directed toward the core XBMC devs rather than you?

Thanks,
-Dave

YouTube plugin has stopped working for me as well. XBMC is not able to fetch the URL contents although that URL works from a browser. The error log looks like this

http://pastebin.com/VmZPUcPG


- HenrikDK - 2011-07-16 13:11

gven Wrote:YouTube plugin has stopped working for me as well. XBMC is not able to fetch the URL contents although that URL works from a browser. The error log looks like this

http://pastebin.com/VmZPUcPG

Hmm i noticed something odd about both you and Dave_e log, you bot seem to get special treatment from youtube.

Code:
http://[b]o-o.preferred.comcast-sjc1.[/b]v21.lscache3.c.youtube.com/videoplayback?sparams=id,expire,ip,ipbits,itag,ratebypass&fexp=909702&itag=37&ip=67.0.0.0&signature=5417607861DAEC80DE7D040FB5FFC68BA6325C8E.8E0FA663CB8B3FF2A9393C9F5​4F98C86CDFFFB3A&sver=3&ratebypass=yes&expire=1310792400&key=yt1&ipbits=8&id=5091c1091fcdf802 | Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

In that the urls are prepended with some additional routing information, dont know if its this that is causing problems, it could be that youtube has added extra checks on their end on these servers Confused

Anyway, if you could provide a http live headers log of a normal playback in firefox of the failing video then i could recheck if we're throwing away some important piece of information, but i doubt it since you said the url worked in the browser.

/HenrikDK


- TobiasTheCommie - 2011-07-16 21:10

speed32219 Wrote:Explore YouTube > YouTube Movies > Crime > Choke

This has now been solved.

By running the very latest rtmpdump (from git) and the latest youtube beta (from svn), the rtmpe videos now work again.

Not tested is 4oD.

NOTE: We do not suggest anyone upgrade to these unstable versions. This is simply a notice that progress is being made.

It will take some time for the patches to migrate down through distros(or to xbmc's internal build). So give it time.


- VanZan - 2011-07-17 16:15

I am running version 2.0.5 on my XBOX. Yes I know that is not supported but I am hoping you might still be able to help me quite easily. I installed it to watch 4oD yet I can't watch this content. Ordinary videos play fine and even short (around 5 minute) 4oD stuff plays. But when I select an episode of the InBetweeners for example it looks like it's playing, a box appears but then just vanishes, nothing happens and the watched tick shows. I am in Ireland but have "Great Britain" selected in the options. I don't believe 4oD is geo locked anyway.

Again I must admit I haven't a leg to stand on since I'm using it on an XBOX. I have posted over at XBMC4XBOX and await a reply. Thanks for the plugin and your hard work.


- HenrikDK - 2011-07-17 17:15

VanZan Wrote:I am running version 2.0.5 on my XBOX. Yes I know that is not supported but I am hoping you might still be able to help me quite easily. I installed it to watch 4oD yet I can't watch this content. Ordinary videos play fine and even short (around 5 minute) 4oD stuff plays. But when I select an episode of the InBetweeners for example it looks like it's playing, a box appears but then just vanishes, nothing happens and the watched tick shows. I am in Ireland but have "Great Britain" selected in the options. I don't believe 4oD is geo locked anyway.

Again I must admit I haven't a leg to stand on since I'm using it on an XBOX. I have posted over at XBMC4XBOX and await a reply. Thanks for the plugin and your hard work.

Hi, did you read the post above yours?

http://forum.xbmc.org/showpost.php?p=840364&postcount=1071

Specifically this line: "Not tested is 4oD."

This means 4oD is not working, not even on XBOX and no dates on when it will work Smile.


- TobiasTheCommie - 2011-07-17 17:52

VanZan Wrote:I don't believe 4oD is geo locked anyway.
It is MOST definetly geolocked. It might not block you but it blocks us.

With that said, 4oD content(even if we fix it soon) is going to take a few months before it works. Basically you need version 2.4 of rtmpdump, which doesn't exist yet.

So wait ill xbmx4xbox has version 2.4 of librtmp then it MIGHT work.

The 4oD videos that currently work solely work because they don't use RTMP.*

* There might be other aspects that make RTMP fail besides for this. We don't know (yet).


- VanZan - 2011-07-17 18:10

HenrikDK Wrote:Hi, did you read the post above yours?

http://forum.xbmc.org/showpost.php?p=840364&postcount=1071

Specifically this line: "Not tested is 4oD."

This means 4oD is not working, not even on XBOX and no dates on when it will work Smile.

lol Big Grin Sorry! I actually did see that but thought it might apply to some super recent beta version on some repo somewhere not available to my XBOX! I'm a little bit of a newbie but I'm sure you've noticed that.

TobiasTheCommie Wrote:It is MOST definetly geolocked. It might not block you but it blocks us.

With that said, 4oD content(even if we fix it soon) is going to take a few months before it works. Basically you need version 2.4 of rtmpdump, which doesn't exist yet.

So wait ill xbmx4xbox has version 2.4 of librtmp then it MIGHT work.

The 4oD videos that currently work solely work because they don't use RTMP.*

* There might be other aspects that make RTMP fail besides for this. We don't know (yet).

Great! Thanks for letting me know. So I'll need a VPN as well as a non-existent version of rtmpdump.


- VanZan - 2011-07-17 18:35

Can I just add that the plugin works great on the XBOX and is fantastic? Thank you for your efforts and please pardon my ignorance. Blush


- TobiasTheCommie - 2011-07-17 19:13

VanZan Wrote:Great! Thanks for letting me know. So I'll need a VPN as well as a non-existent version of rtmpdump.
I'm not sure if you will need VPN. All i know is that I need VPN to get 4oD content.

So some kind of geolock is in effect. If you can see the videos in your browser you won't be needing a VPN connection to use XBMC.

4oD has never worked (consistently) in the plugin. And the RTMP problems were added on top of that, so even with the latest librtmp/rtmpdump updates 4oD may still fail.

We just can't test it from Denmark, so we really have no idea.

If anyone feels up to test if 4oD now works with the librtmp 2.4(i honestly don't expect it to work) these would be the procedures to follow.

1) Install nightly XBMC
2) In windows replace librtmp.dll with a 2.4 version. On mac replace librtmp.so.0 with 2.4 version. On linux install rtmpdump 2.4(Currently that would mean latest git from github)
3) Install latest youtube beta from git.
4) Verify that RTMP playback works with this video http://www.youtube.com/watch?v=8wxOVn99FTE ( This is our default RTMP testing video ).
5) Try 4oD video.

Note: If you need to ask for help to go through these steps. You should not try to do it.


- TobiasTheCommie - 2011-07-17 19:15

VanZan Wrote:Can I just add that the plugin works great on the XBOX and is fantastic? Thank you for your efforts and please pardon my ignorance. Blush

Neither me nor Henrik have an XBOX. Thus the official plugin does not support the XBOX in any way shape or form. It is great that it is working for you, but even when this is fixed, the XBOX plugin will need to be updated before it will be of any use to you.

Just FYI.


- VanZan - 2011-07-18 18:26

4oD stuff playing fine for me today with a build containing the new librtmp.dll. That Miley Cyrus video ain't playing though...shit!


- TobiasTheCommie - 2011-07-19 13:25

VanZan Wrote:4oD stuff playing fine for me today with a build containing the new librtmp.dll. That Miley Cyrus video ain't playing though...shit!

That's a nice pretty debug log you attached there.