XBMC Community Forum
24p and audio sync issues - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: 24p and audio sync issues (/showthread.php?tid=80247)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44


RE: 24p and audio sync issues - DDDamian - 2012-05-01 00:48

@torcar - can you give us a Debug Log? Start one of the problem files and let it run till a few minutes past the issue. Sounds like the timestamps are borked in them.


RE: 24p and audio sync issues - robl45 - 2012-05-01 00:58

i used the AE build, it was better on xvid/avi files, but still had the same issue that the regular build does, the missing counter ramps up, maybe not at first, but then randomly it would just get out of sync.


RE: 24p and audio sync issues - DDDamian - 2012-05-01 19:37

Hi torcar - from what I can see in your log and from your description it is almost certainly bad timestamps in those files. As a test you can try demux/remux them with mkvmerge or eac3to.

A patch was submitted recently for review that attempts to fail a little more gracefully when these are encountered, and it may help with these files, but there's no set timeframe for inclusion or not into master.

I would try the demux/remux on the file(s) and see if it helps as about the only short-term workaround.


RE: 24p and audio sync issues - torcar - 2012-05-01 20:18

@DDDamian: Ok, will try that as soon as possible.

FYI: I have about 500-600 .mkv's and the problem seems to be present on as good as all of them... (Haven't tried ALL of them, but I also haven't found any that does not go out of sync yet)

Thanks so far Smile


RE: 24p and audio sync issues - DDDamian - 2012-05-01 20:26

Big ouch - I thought this was limited to a few files. Can you focus on one known problematic one and see if it happens at a fixed location in the file? If so, a sample uploaded of that portion would be beneficial.


RE: 24p and audio sync issues - torcar - 2012-05-01 20:30

Will do that.

One question though... Is there any way I can actually see when it gets out of sync or do I just have to register it with my eyes and ears?
Some movies aren't that easy to spot sync-problems in before you get to scenes with talking, shooting, knocking etcWink


RE: 24p and audio sync issues - DDDamian - 2012-05-01 20:53

Press "O" while watching a movie and watch dropped frames ("Drop: xx"). If there are timestamp issues this should increment.

In the log, look for any Discontinuity errors *after* Pull-up correction" has been applied.


RE: 24p and audio sync issues - torcar - 2012-05-02 16:35

Sorry, took a while to do all the testing.

I have now tested about 15 different .mkv's. A mix of 720p, 1080p, DD5.1 and DTS. All of them display the same symptoms with some variation regarding when the sync-issues start... but usually within less than 30 minutes. Most often within 0-10 minutes.
I have also tested the same files on a Popcorn Hour C-200, a WDTV gen.3 and of course on the XBMC rig using MPC in windows... all without any flaws im kinda sorry to say;/


I see both dropped frames increasing, and several discontinuity errors in the log-file.


RE: 24p and audio sync issues - DDDamian - 2012-05-02 17:23

@torcar - this is starting to point more to buffering/caching than anything else. Try copy a movie to a local drive and let it play completely through while monitoring the OSD periodically.


RE: 24p and audio sync issues - torcar - 2012-05-02 17:29

Will do. Not sure if I'll have the time before the weekend, but I will post back as soon as I've tried.


RE: 24p and audio sync issues - PsychoCheF - 2012-05-02 21:02

OK, so it was not so easy as the lipsync that comes with HDMI v1.3 Sad

@DDDamian


What happend after Babylon?
I'm using an really old Babylon nightly, rev. 22516, and theres is never any problems with audio sync, or laggy picture when resumed from sleep (windows).
I have tried every build since Camelot, and some nightlys (not AE), and they all have this sync problem.

It would be interesting if it the same for you, so test this old version if you have a moment, I uploaded it here:
http://www.sendspace.com/file/6hnmv4
http://www.crocko.com/FF14124A4E624B83911BBD4AB96C2F50/XBMCSetup-Rev22516.exe
I'm using it in portable mode btw.

@torcar Would you give me your TV Big Grin


RE: 24p and audio sync issues - torcar - 2012-05-03 09:22

@PsychoChef: Fix this 24fps issue and I'll think about it Tongue


I reverted to 60fps yesterday as a temporary fix. Will not have the time to experiment more until later this weekend so... :/

Quick question: When the debugging is turned on, the text in the upper left corner shows fps among other things... this shows 24fps even though I am now running 60fps without "Adjust display refresh rate to match video" enabled.

Is this correct behavior? I guess it's just showing the movie fps, and not the display fps?


RE: 24p and audio sync issues - DDDamian - 2012-05-03 15:05

@PsychoChef - I might have to d/l that just for historical reasons Tongue What's changed since then? Are you serious?

EDIT: re: lipsync - I have a setting in my Denon for this, and it didn't make any difference on my setup - sync was always good regardless, but your mileage may vary. It is designed to handle delays reported by the components, but is probably the worst-implemented feature of HDMI 1.3 - the fault of the manufacturers. It is unlikely that processing delays, what it's meant to account for, differ that much based on frequency.

@torcar - your Denon should have this feature as mine does - wanna try it?

@torcar - XBMC still has to lock onto the movie fps for decoding and audio demuxing - that's what it's showing you. There are some others struggling with smb shares: http://forum.xbmc.org/showthread.php?tid=126064

Given the number of files you're seeing this on, and the fact that it's seemingly random when it occurs makes me lean that way. Let us know how you do with a local file just to rule that out Smile


RE: 24p and audio sync issues - torcar - 2012-05-03 15:13

@DDDamian: I'm at work now and will probably not have any chance to test until the weekend, but... All the files play without any framedrops or sync-problems if i run them on 60hz. No problems with 30Mbit+ files either... so unless XBMC caches differently or something when playing 24fps I would be surprised if the network speed has anything to do with it. (Cisco GB switches/GBit NIC's all the way through)

However... it's always nice to rule things out, so I will test it no matter what just to be sureSmile


RE: 24p and audio sync issues - DDDamian - 2012-05-03 15:32

@torcar - the plot thickens lol - based on that, then no, XBMC does not cache them any differently based on frequency. We're back to timings as the cause Sad