XBMC Community Forum
External Player strange behavior - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: External Player strange behavior (/showthread.php?tid=85526)



External Player strange behavior - Zodler - 2010-11-16 21:50

I have set my external players like this:

The strange behavior is that when I exit ZoomPlayer or MPC-HC, XBMC plays again the file in its internal player!!!! Why?

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="true" video="true">
<filename>C:\Program Files\Video\Media Player Classic - Home Cinema\mpc-hc64.exe</filename>
<args>"{1}"</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="Zoom Player" type="ExternalPlayer" audio="true" video="true">
<filename>C:\Program Files (x86)\Video\Zoom Player\zplayer.exe</filename>
<args>"{1}"</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
</playercorefactory>


- jhsrennie - 2010-11-17 09:51

You don't have any rules to tell XBMC when to use the players you've defined. I can't see how XBMC would know to use the external players at all.

JR


- Zodler - 2010-11-17 14:57

There is no need for rules. They will be always present. I use the "Context->Play Using->" menu.


- jhsrennie - 2010-11-17 19:51

I don't get a "play using" option on the context menu? Is that a function of the Library mode? I use only file view.

JR


- Zodler - 2010-11-17 23:29

No its available in the file view. Just press c on a file and the second item should be Play Using.


- jhsrennie - 2010-11-18 11:00

With Dharma beta 4 I don't get "play using" on the context menu unless there is a rule for the selected file. If I copy and paste your playercorefactory.xml then pressing C on any file does not give me the "play using option". If I edit playercorefactory.xml and add:

Code:
<rules action="prepend">
    <rule name="play1" filetypes="mp4" player="MPC-HC" />
    <rule name="play2" filetypes="mp4" player="Zoom Player" />
  </rules>

then C on a .mp4 file gives me "play using" with a choice of the two players, but C on a .avi file does not show the "play using" option.

Either there's a difference between the versions of XVMC we are using, or you have a another playercorefactory.xml somewhere.

JR


- Zodler - 2010-11-18 13:00

I have Dharma beta 4, I will try to add a rule and see what happens with my problem.


- bsmith1051 - 2010-11-22 22:17

This isn't working for me, either. I used the example 'playercorefactory.xml' file from the Wiki,
http://wiki.xbmc.org/index.php?title=HOW-TO_use_an_External_Player_for_media_playback
then tweaked it to use the correct folder on my computer, as well as added more file-types. Per the instructions, I saved this as a 2nd copy under the 'UserData' sub-folder. But XBMC doesn't seem to be recognizing it?

I also tried editing it further per this post, e.g. I added rule names, but I still don't get any "Play Using" option when I press C on a video file.


- bsmith1051 - 2010-11-22 23:04

UPDATE
I got mine to work finally, but only by editing the 'main' copy of playercorefactory.xml, i.e., I never did get it to recognize the add-on copy.

UPDATE x2:
My mistake, I was putting the add-on copy of the .xml in the 'Userdata' folder of the C:\Progs\XBMC whereas I was supposed to put it under the 'Userdata' folder of my personal profile. That's confusing!

P.S. even though I have it successfully opening MPC-HC now the player has significant lag, whereas the same files play fine when opened directly in MPC-HC.


- mark007 - 2010-11-23 01:33

bsmith1051 Wrote:UPDATE
I got mine to work finally, but only by editing the 'main' copy of playercorefactory.xml, i.e., I never did get it to recognize the add-on copy.

UPDATE x2:
My mistake, I was putting the add-on copy of the .xml in the 'Userdata' folder of the C:\Progs\XBMC whereas I was supposed to put it under the 'Userdata' folder of my personal profile. That's confusing!

P.S. even though I have it successfully opening MPC-HC now the player has significant lag, whereas the same files play fine when opened directly in MPC-HC.

I have found in the past that when xbmc is running, even when minimized, it can use alot of cpu and even spikes of gpu usage for some reason... never got a resolution on a trac ticket on the gpu issue but check your cpu / gpu usage when you launch mpchc from xbmc, and pause mpchc to see what xbmc is upto.