XBMC Community Forum
[LINUX] Sam's beta image for Apple TV? - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: [LINUX] Sam's beta image for Apple TV? (/showthread.php?tid=88518)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19


[LINUX] Sam's beta image for Apple TV? - maartenst - 2010-12-24 16:35

Hi,

I'm trying to run Sam's beta image and it boots, but I don't get much further then that.
It does not seem to be able to make a network connection, and it seems to want to perform some network updates/scripts, which fail, throwing me on the prompt where I cant do much without a network connection....


- tuckbodi - 2010-12-24 17:36

Yeah, I'm getting something similar. Mine gets me as far as "sync.sh : no such file or directory" and stops pretty much right there. It first tries to remove this file, which errors, and then tries to connect to crystalhd-for-atv.googlecode.com.... and says service not known and can't download sync.sh from there (even though if I go to the url I can see it there).


- maartenst - 2010-12-24 18:28

tuckbodi Wrote:Yeah, I'm getting something similar. Mine gets me as far as "sync.sh : no such file or directory" and stops pretty much right there. It first tries to remove this file, which errors, and then tries to connect to crystalhd-for-atv.googlecode.com.... and says service not known and can't download sync.sh from there (even though if I go to the url I can see it there).
yeah, my guess is that is because there is no Internet access, and it thus cannot connect to that url, and not continue...


- Sam.Nazarko - 2010-12-24 19:11

http://twitter.com/SamNazarko/status/18358014985641984


- maartenst - 2010-12-25 22:47

Sam, is the usb.img.gz url of a couple of days ago on twitter the url to get your fixed image, or is there another url? I could not find a download url on your google code site (which looks quite complete documentation wise btw!)

Happy Xmas btw, and keep up the great work!


- dublus - 2010-12-25 22:58

Same question, Sam.

I was hoping you posted the revised image at the old link location but no luck.

Can you direct us to the new image please?


- Sam.Nazarko - 2010-12-26 00:46

Happy Christmas to you guys too,

The old is the same as the new link (it is updated on Subversion, and the link is to the latest version, not a specific revision). This means that the old Twitter link was auto updated when I committed the new image. http://crystalhd-for-atv.googlecode.com/svn/trunk/image/hardy/usb.img.gz


- jadel - 2010-12-26 06:11

Hi guys,

Thanks for the update. I started reading about your work a week or so ago and have waited for this new version to make my first install.

The question I have is both very simple and possibly very complex.

How do I install it? SmileI got the usb.img from the link you posted and now I am stuck.

Are the instructions on the 170 page thread still applicable? That seems fairly complex, I understood this new one was going to have an installer to automate some/all aspects.

Perhaps someone can point me in the right direction.

EDIT: I did some googling and forum reading and ended up putting the usb.img on a stick and booting the aTV. It does a bunch of starting linux stuff then ends up with a few errors as mentioned in this thread.
resolving crystalhd ... failed: Name or service not known
cannot access sync.sh: no such file or directory
getfile.sh ? (maybe . cant read first letter.) " "

I just got the image a couple of hours ago, perhaps its still the old one on that link above?

Then it has the 8.04 minimal for apple tv by Sam etc text but just sits there.

Anyway, looking forward to trying it out, thanks for making it.


- dublus - 2010-12-26 08:31

Same error here with the latest image...


- jadel - 2010-12-26 10:44

Can you SSH into the aTV if its just sitting at that text screen after the errors?

I would do the fix from the old release but I dont know if its possible.


- mullemull - 2010-12-26 12:48

Same error here with the latest image...

And no, can't SSH to my aTV.


- jagabongo - 2010-12-26 14:51

Same error here, the atv gets no network connection with the new image too... ( same with the old image )

Sad


- fistacorpse - 2010-12-26 15:00

Yeah, I'm getting the same. Looks like that didn't fix the issue Sam Sad

And at the point where it dies, you can't SSH in.


- jagabongo - 2010-12-26 15:07

Problem solved...

Used a USB-Hub then edited /etc/network/interfaces

changes eth0 to eth1 and rebootet! now everthing works!!


- jadel - 2010-12-26 15:11

Damn .. no usb Hub to try .. no usb keyboard for that matter.

EDIT ↓↓↓ This