XBMC Community Forum
[LINUX] HOW-TO use VAAPI HW Acceleration on AMD Zacate (Fusion) platform - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: XBMC General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: [LINUX] HOW-TO use VAAPI HW Acceleration on AMD Zacate (Fusion) platform (/showthread.php?tid=99154)



- dermute - 2011-11-06 22:26

Hello,
after some work I finally compiled my own XBMC and VAAPI works fine at 1080p@50Hz.
(lates xbmc from git, latest libva, latest fglrx 11.10)

I want to watch movies with 24Hz, but as soon as I activate it, i got a lot of Tearing and lagging Videos.

While watching a HD movie and browsing through the xbmc menus, the video is lagging too. (at 50Hz)


Could anyone help me to get 24Hz working?


- WytRaven - 2011-11-06 22:53

dermute Wrote:Hello,
after some work I finally compiled my own XBMC and VAAPI works fine at 1080p@50Hz.
(lates xbmc from git, latest libva, latest fglrx 11.10)

I want to watch movies with 24Hz, but as soon as I activate it, i got a lot of Tearing and lagging Videos.

While watching a HD movie and browsing through the xbmc menus, the video is lagging too. (at 50Hz)


Could anyone help me to get 24Hz working?

Just lock it at 60Hz and tell xbmc to resample audio. No headaches at all that way. This whole 24Hz thing really is much ado about nothing.


- kobik - 2011-11-06 23:44

tjones Wrote:Assuming you're using an APU.

Your top definitely states xbmc as the issue.

%us = user processes %sy = system processes.

From man top.
Code:
us  --  User CPU time
          The time the CPU has spent running users'  processes  that  are
          not niced.

        sy  --  System CPU time
          The  time  the  CPU  has  spent running the kernel and its pro‐
          cesses.

Try upping the amount of ram dedicated to the igfx. The default value is usually around 380MB. It might be a framebuffer capacity issue. I set mine to the max 2GB just for the fun of it. Try 1GB.

As to the compile try resetting your git directory and make sure libltdl7 libltdl-dev are installed as I've stated in this post. http://forum.xbmc.org/showpost.php?p=921595&postcount=607

I would get bootstrap/autoconfig errors in 11.10 unless I manually installed libltdl7.

Edit: another idea make sure that Composite is disabled in your xorg.conf if you haven't done so already.

Code:
Section "Extensions"
        Option  "Composite" "Disable"
EndSection

https://wiki.archlinux.org/index.php/Composite

Done the Composite thing and it didn't change a thing.
Is this related to the fact I'm running command line Ubuntu minimal install?

Also bumped RAM for IGFX to 1GB which is the max on my Gigabyte E350N-USB3 for some reason. Nothing was changed here too.

For the compiling thing, I reset git and ran ./bootstrap again just to fail here
Code:
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `.'.
libtoolize: copying file `./config.guess'
libtoolize: copying file `./config.sub'
libtoolize: copying file `./install-sh'
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `lib/libapetag'
autoreconf: Entering directory `lib/cpluff'
autoreconf: running: autopoint --force
Can't exec "autopoint": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 345.
autoreconf: failed to run autopoint: No such file or directory
autoreconf: autopoint is needed because this package uses Gettext



- tjones - 2011-11-07 02:48

@kobik

It looks like you're missing dependencies there somewhere. Did you install them manually from the README.linux or did you use apt-get build-dep xbmc after adding the unstable ppa?


- tjones - 2011-11-07 15:36

dermute Wrote:Hello,
after some work I finally compiled my own XBMC and VAAPI works fine at 1080p@50Hz.
(lates xbmc from git, latest libva, latest fglrx 11.10)

I want to watch movies with 24Hz, but as soon as I activate it, i got a lot of Tearing and lagging Videos.

While watching a HD movie and browsing through the xbmc menus, the video is lagging too. (at 50Hz)


Could anyone help me to get 24Hz working?

What WytRaven said, Also if you have a desktop environment installed you can enable the tear free option in amdcccle. Perhaps somebody could give us a command to enable this feature via command line.

Ah bless arch wiki, ask and it provides. Even though I don't use the distro I love their documentation.

https://wiki.archlinux.org/index.php/ATI_Catalyst

Quote:Tear Free Rendering

Presented in Catalyst 11.1 'Tear Free Desktop' feature reduces tearing in 2D, 3D and video applications. This likely adds triple-buffering and v-sync. Please note that it requires additional GPU processing.

To enable 'Tear Free Desktop' run amdcccle and go to: [Display Options] -> [Tear Free]

or as root run:
Code:
aticonfig --set-pcs-u32=DDX,EnableTearFreeDesktop,1
To disable use amdcccle or as root run:

Code:
aticonfig --del-pcs-key=DDX,EnableTearFreeDesktop

Restart X or reboot after the toggle.


- dermute - 2011-11-07 18:59

@WytRaven 24Hz ist not about headaches! with 24hz there is no framskip like with pal(50hz)/ntsc(60hz)
Just watch a movie on a good HDTV and switch between 24hz and 50/60hz... you dont wanna look a movie without 24hz anymore...


@tjones
thanks, but it isnt working.
With TearFreeDesktop enabled and 24Hz my video is stuttering really hard.
i tried to record it: https://www.dropbox.com/s/z3dal86ft05qh1i/video-2011-11-07-17-56-42.mp4
Any hints? (CPU is at 15%, vaapi works)


- kobik - 2011-11-07 20:36

tjones Wrote:@kobik

It looks like you're missing dependencies there somewhere. Did you install them manually from the README.linux or did you use apt-get build-dep xbmc after adding the unstable ppa?

No, i did only what is on the OP.
Should I run this apt-get build-dep xbmc command?


- Ason - 2011-11-07 22:38

Hey now i have been reading this topic for a while,
But i don't relay get it how to install UBUNTU and XMBC
I have a Asus E35M1-I

Can any point me where to start..


- kobik - 2011-11-08 00:14

tjones Wrote:@kobik

It looks like you're missing dependencies there somewhere. Did you install them manually from the README.linux or did you use apt-get build-dep xbmc after adding the unstable ppa?

kobik Wrote:No, i did only what is on the OP.
Should I run this apt-get build-dep xbmc command?

OK...
I did run apt-get build-dep xbmc and now I'm on the horse.
IMHO, this should be added to the OP too.
Now lets see if this fixes the crazy FPS thing.

Edit: It didn't help with the crazy FPS.
Got to be something with Linux detection of my TV.


- wsnipex - 2011-11-08 11:03

there are some rather deep problems with ati vaapi and 24p in XBMC. Without the patches from FernetMenta(read ~15 pages back) you will never get it working smoothly. Even with the patches the problems are not really fixed, but only less noticeable.

I for one, am waiting for direct xvba support, which is currently in the works.


- dermute - 2011-11-08 11:22

@wsnipex
Oh thanks... I searched for that problem you discribed and it seems to be serious and I am not the only one...
lets hope they can fix it soon (Fermet said, fix is not expected for Eden Sad )


- wsnipex - 2011-11-08 12:12

I don't care about Eden stable, since I compile from GIT.
If it does not get enabled in the official nightlies(as it is with vaapi), I bet someone will provide a ppa.


- tjones - 2011-11-08 18:09

@Ason

Starting at the beginning of the thread is usually the best point, then use all relevant references near the end of the thread since these typically will pertain to current issues. If you are having trouble understanding installing minimal Ubuntu I suggest you install Oracle Virtual Box in your desktop pc and play around installing minimal Ubuntu in virtual machines first. Once you're confident with your minimal Ubuntu installation use it on the real system and move onto installing xbmc. This will save you a lot of headaches.


- tjones - 2011-11-09 00:00

Removed potentially confusing/damaging information. I don't want ppl chasing their tails or blowing up their displays/systems.

Good news I think I almost have 24fps working.


- Hack_kid - 2011-11-09 02:00

looks like hes making progress

https://github.com/FernetMenta/xbmc/commits/xvba