XBMC PVR Client & For The Record: Argus TV-Server

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
venxxxxx Offline
Junior Member
Posts: 12
Joined: Feb 2012
Reputation: 0
Post: #31
Guys, are most of the tv tuner card are compatible ? I tried MediaPortal and my tv tuner (Avermedia) didnt scan any channels.
find quote
jansink Offline
Junior Member
Posts: 24
Joined: Mar 2010
Reputation: 0
Post: #32
Hi all, first my compliments for all posting here to help each other! Yesterday I installed fortherecord on my WHS 2011 box and XBMC and the client on my win7 machine. I got it al working..... but.... the video and audio is very instable, xbmc keeps buffering every 5 seconds. What are the minimum specs to run fortherecord? Is there something i can do (except from upgrading my WHS 2011 box)?
find quote
da-anda Offline
Team-XBMC Member
Posts: 2,755
Joined: Jun 2009
Reputation: 37
Location: germany
Post: #33
Hey folks,
I think there's a bug with the timer notifications - I at least get weird notifications once a recording begins or ends. It doesn't only say "recording xxx started/ended" but also shows me some already outdated notifications (like "timer xxx deleted" although that timer was from a day ago and is not related to the latest recording). Looks like all notifications since last notification are displayed, but that doesn't make sense - because PVR-backends might also do stuff while XBMC is not running. So just display the recent notifications (reset the "last viewed notification" timestamp - if there is something like that - on XBMC startup to the current time).
(This post was last modified: 2012-02-14 12:03 by da-anda.)
find quote
Avigrace Offline
Senior Member
Posts: 132
Joined: Mar 2009
Reputation: 0
Post: #34
I have been using the margro windows builds with fortherecord argus for many months now and it works great, however is there a plugin for linux as I am considering moving my clients from windows to the new XBMCuntu.

Fortherecord is on a dedicated windows box and will remain so, it's the clients I want to change from windows to linux.
find quote
CWestin Offline
Junior Member
Posts: 5
Joined: Sep 2011
Reputation: 0
Location: Melbourne, Australia
Post: #35
Red-F (the Developer ofthe for the record Argus plug in) will not formally release anything until Eden is final or when has his code merged into the main PVR branch.

You could refer to the post (in this thread) :rolleyes2: http://forum.xbmc.org/showpost.php?p=973...stcount=14

Perhaps Red-F or margro could give us an update?
find quote
pecinko Offline
Donor
Posts: 3,724
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #36
First of all many thanks for work on this plugin. Finally got working PVR setup!

Reading previous posts about timer incompatibilities with 4TR and XBMC I was wondering if any progress on this has been made lately?

I'm on Eden, OS X and using plugin ver 1.133 from this location http://www.4therecord.eu/forum/viewtopic...=41&t=2425

My skins:

Amber
Quartz

(This post was last modified: 2012-04-27 19:54 by pecinko.)
find quote
Red_F Offline
Member
Posts: 53
Joined: Oct 2010
Reputation: 2
Location: The Netherlands
Post: #37
(2012-02-14 23:49)Avigrace Wrote:  I have been using the margro windows builds with fortherecord argus for many months now and it works great, however is there a plugin for linux as I am considering moving my clients from windows to the new XBMCuntu.

Fortherecord is on a dedicated windows box and will remain so, it's the clients I want to change from windows to linux.

Avigrace, yes there is a version of the add-on for Linux. I've made a post at the ForTheRecord forum that has links to version of the add-on for all the different platforms that are currently supported: Windows, OS X, Linux, iOS (ATV2), iOS (iPhone/Pad/Pod).

See http://www.4therecord.eu/forum/viewtopic...=41&t=2425.

The ATV1 has a Crystalbuntu distribution with XBMC including the FTR add-on. See: http://www.stmlabs.com/tag/crystalbuntu/.[hr]
(2012-04-27 19:48)pecinko Wrote:  ...
Reading previous posts about timer incompatibilities with 4TR and XBMC I was wondering if any progress on this has been made lately?

I'm on Eden, OS X and using plugin ver 1.133 from this location http://www.4therecord.eu/forum/viewtopic...=41&t=2425

Pecinko, yes there are timer incompatibilities. But this does not preclude you from using timers within XBMC. You can add and delete timers from within XBMC (I'm not sure about changing, haven't looked at that for a long time).

The problem is that timers as they are known within XBMC are but a shadow of the way ForTheRecord knows them. All the rule-engine based flexibility about whether to record a recurring program based on earlier history, time slots, channel sets etc. etc. can not be used from the XBMC UI. You still have to use the FTR management console to create one of the more sophisticated recording schedules.

Cheers,
Fred
(This post was last modified: 2012-04-27 20:39 by Red_F.)
find quote
pecinko Offline
Donor
Posts: 3,724
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #38
Red_F thanks for info. I had problem adding timers from within xbmc but I will test some more on my side.

Hopefully we will see improved xbmc support for 4tr plugin soon.

My skins:

Amber
Quartz

find quote
futuro Offline
Senior Member
Posts: 104
Joined: Aug 2011
Reputation: 1
Post: #39
Hello All,

I am watching TV for a week now using Margo's latest XBMC Eden PVR build and Argus TV server. It works great but I have one problem. When I first start up XBMC and want to start Live TV, XBMC says the is no PVR client. I then have to go to settings, disable Live TV, enable it again and then I can start Live TV. Did anyone face the same problem? I would very much appreciate any help on that!
find quote
pecinko Offline
Donor
Posts: 3,724
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #40
In my case it is sufficient to wait for a few sec for XBMC to make a connection, EPG updates, and all is well.

My skins:

Amber
Quartz

find quote
futuro Offline
Senior Member
Posts: 104
Joined: Aug 2011
Reputation: 1
Post: #41
Thanks for your fast answer. I also thought first that I need to wait a bit longer... but it doesn't work. Even when I have XBMC running half a dax, when I first time start Live TV, I have to go through the procedure described in my above post.
find quote
Red_F Offline
Member
Posts: 53
Joined: Oct 2010
Reputation: 2
Location: The Netherlands
Post: #42
(2012-05-05 00:26)futuro Wrote:  Hello All,

I am watching TV for a week now using Margo's latest XBMC Eden PVR build and Argus TV server. It works great but I have one problem. When I first start up XBMC and want to start Live TV, XBMC says the is no PVR client. I then have to go to settings, disable Live TV, enable it again and then I can start Live TV. Did anyone face the same problem? I would very much appreciate any help on that!
You probably have an incompatible version of the xbmc database. Did you follow this advice from Margro's website?
Quote:To prevent incompatibility problems, uninstall previous XBMC (pre-)Eden builds and cleanup the EPG?.db, addon?.db and TV??.db files in your XBMC userprofile directory.


Enabled/Disabled status is kept in the addon database.

I simple delete *.db from my database folder when testing new versions.

See also: http://wiki.xbmc.org/index.php?title=The...ata_Folder.

Cheers.

P.S. deleting the databases means that the addon will be disabled at the next start of XBMC Wink
(This post was last modified: 2012-05-05 13:54 by Red_F.)
find quote
Red_F Offline
Member
Posts: 53
Joined: Oct 2010
Reputation: 2
Location: The Netherlands
Post: #43
Version 0.0.136 added for ATV2, Linux86 and iOS to the downloads at http://www.4therecord.eu/forum/viewtopic...25&p=20217.
find quote
KRA77 Offline
Senior Member
Posts: 288
Joined: Jul 2010
Reputation: 0
Post: #44
Linux version tested on xbmc live.

Still have the issue with SD live-tv fluctuating severely in FPS

HD live-tv works fine
recordings HD/SD works fine
find quote
mactor Offline
Junior Member
Posts: 2
Joined: Dec 2011
Reputation: 0
Post: #45
Thx Red_F for this excellent addon.

Anyway got problem with latest windows version (0.0.135). I can't play any recording containing my national (polish) characters in its title. Version 0.0.132 worked fine. I'm using 4tr 1.6.1.0 beta 7.
find quote
Post Reply