Do the devs dislike ION users?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
RKMFlorida Offline
Senior Member
Posts: 134
Joined: May 2004
Reputation: 0
Post: #1
I've been trying to run XBMC on ATOM/ION chipsets for years now.

I was so excited when v9 came out because I had hoped my ION chipset would work out-of-the-box. That didn't happen. After about 6 hours searching/testing, I was able to get the sound to work.

When v10 came out, I figured that would definitely be the version where ION's would work out of the box. I eventually got it working with workarounds, but it eventually stopped working properly. I switched to OpenElec and was able to get it working again.

Eden (v11) just arrived and I was really hoping that for the first time, my original ION and ION 330 (Giada Cube) would work. I did another fresh install using XBMCbuntu, yet no sound. So far I've been working on it for 4.5 hours, tested every suggested fix I can find, and yet it still crashes upon playing music or videos .. no matter what I try.

I've spent so much time working on ALSA fixes for XBMC, I'm ready to take a sledge-hammer to my ION boxes. Unfortunately I'm not a Linux guy, and although I'm trying my best, I'm at my wit's end!

If ION chipsets are always going to be such a headache, what hardware can I use that will eliminate these problems?
find quote
Fox Offline
Senior Member
Posts: 134
Joined: Oct 2003
Reputation: 1
Post: #2
Nah they don't dislike ION users specifically, they hate all users! :-p
No but serious though, I think you must be very unlucky, sure in the beginning there was a lot of trial and error but now I find the ION work very nicely right out of the box, especially with the XBMCbuntu (formerly known as XBMCfreak) most things have worked perfectly.
But thats just for me and my ION box, there are so many different ones out there so sure some has to be troublesome. Sad

You write that it crashes for you, maybe post some logs and someone can see what's going on.

If you find any spelling mistakes you can keep them ;)
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #3
I love my ION box(s), stick OpenElec on it and you are up in 10 mins. I also love my arm box(s) and atv(1,2,3)s.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #4
indeed my ion box runs fine on Openelec but only because I don't want to do anything but xbmc on that box so no need for a full OS
(This post was last modified: 2012-04-02 15:02 by Jezz_X.)
find quote
bossanova808 Offline
Donor
Posts: 2,228
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #5
@davilla - any chance you want to lend your mighty brain to the ION on Shuttle XS35 frame dropping issues - see:
http://openelec.tv/forum/131-vdpau-nvidi...d-ionvdpau

(particularly the last couple pages...)

...FernetMenta has basically re-jigged ION video playback to make it a lot more efficient but there's an outstanding issue to do with powermizer on this particular (lovely, silent!) system..you're pretty amazing on the hardware/embedded/trick sh*t side of things so maybe you can helpConfused

My XBMC stuff:
find quote
RKMFlorida Offline
Senior Member
Posts: 134
Joined: May 2004
Reputation: 0
Post: #6
Yes, I was running OpenElec all of v10. I switched back to XBMCbuntu because it now loads quicker and I had some issues with the dailies of OpenElec (as one should probably expect with a daily -- but it was the only way to get Eden, since OpenElec is trailing with Eden).

BTW - I do not think XBMCbuntu is the former XBMC Freak, but rather, it is the new carnation of XBMC Live. XBMC Freak was a unofficial, third-party distro, if I'm not mistaken.

After roughly 7 hours of trying dozens of different suggestions, I believe I have got a solution to get v11 running on ION. I'm posting the step-by-step below for anyone else that stumbles upon this thread:

Programs > Get More > XBMC Audio Mixer > Uninstall

Control + Alt + F1 (get command console) >
rm .asoundrc
apt-get remove pulseaudio
Control + Alt + F7 (return to XBMC) -- or reboot from the command line.

...Reboot...

System > Settings > System > Audio Output >
Audio Output: HDMI
Speaker Config: Any option (2,0, 5.1, etc)
Boost volume level on downmix: On (or) Off
AC3 capable receiver: (depends on your hardware)
DTS capable receiver: (depends on your hardware)
Audio output device: HDA NVidia - hdmi - 0 (ALSA)
Passthrough output device: HDA NVidia - hdmi - 0 (ALSA)

The "HDA NVidia - hdmi - 0 (ALSA)" will not be available until after you disable/remove the audio mixer and delete the ALSA config (.asoundrc), if you're running a similar setup to me (GIADA Cube w/ION 330).

Good luck!
find quote
darkscout Offline
Posting Freak
Posts: 2,145
Joined: Jul 2008
Reputation: 12
Post: #7
If you want a 'full OS' then you get to deal with the problems of getting sound working on a 'full OS'. This isn't an XBMC problem, this is an Ubuntu one.

[Image: aeKO.jpeg]
Code:
GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';
IF you have a mysql problem, find one of the 4 dozen threads already open.
find quote
digitalb0y Offline
Senior Member
Posts: 103
Joined: Feb 2012
Reputation: 1
Location: denver.co
Post: #8
(2012-04-02 16:47)darkscout Wrote:  This isn't an XBMC problem, this is an Ubuntu one.

Indeed. Check out some Ubuntu forums (or even other distros) and you'll find XBMC users are not the only ones who have to tweak their ALSA settings.

XBMCbuntu 11.0
Zotac ZBOX Blu-ray HD-ID34
URC RF-20 (configured with Flirc)
find quote
voochi Offline
Fan
Posts: 326
Joined: Jan 2010
Reputation: 2
Post: #9
Openelec works great on my Acer Revo (Atom330/Ion). Im using a nightly Eden build currently but im sure the OpenElec guys will release the stable Eden version soon.
find quote