[Windows] AudioEngine testers - Windows platform only

  Thread Rating:
  • 3 Votes - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Aemstel Offline
Member
Posts: 82
Joined: Feb 2011
Reputation: 0
Post: #91
(2012-04-05 08:18)ix400 Wrote:  
(2012-04-05 06:05)ix400 Wrote:  ... good to hear, thanks a lot.

Chris

I will be off for a short vacation over easter. I'm gonna leave in about 24 hours, but tonight I could
still do a little testing if you put on the new build. If not, I will test it next monday.

Thanks again for your work,

Chris

I am also experiencing this bug, so will also test the new build and report on it.

Thanks again DDDamian, looking forward to it!
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #92
Okay - new build up. Direct link XBMC-AE-20120406.zip or link from first post and check newest date.

Changelog:
- use old-style WAVEFORMATEXTENSIBLE structure for backwards compatibility
- use WAVE_FORMAT_DOLBY_AC3_SPDIF format for backwards compatibility
- fix DTS breakage - works on my setup with DTS, DTS-HD (24/96) and DTS-MA
- fix double sink opening for quicker skip/seek and hopefully no receiver switching from encoded->pcm
- fix buffer sizing in CSoftAEStream
- add dynamic Stereo to All Channels upmix for stereo music/videos
- fix crash on deselecting MultiChannelLPCM capable receiver button
- a few other invisible tweaks Smile

Tested on just about all formats on my setup:
Win 7 x64 Premium
ATI HD6450 GPU
Catalyst drivers 12.1 w/AMD High Definition Device Driver 7.12.0.7705 12/06/2011
HDMI to Denon 3808CI

Tested: AC3 2.0/5.1, DTS 5.1, DTS-HD 24/96, DTS-MA, AAC, TrueHD, mp3 video soundtracks
Tested: mp3, FLAC stereo and m/c from 2.0 16/44.1 to 5.1 24/96

I am using WASAPI, exclusive mode, HDMI, 7.1 channels. Just about any video settings have worked fine.

Note: please start with your audio buffer size around 50msec - I set the default a bit high and found it can overrun buffers on high-bitrate audio - I'll fix that in the next build. For now just go to the Audio Output settings page and reduce it to 50msec to start, higher only if required.

As always, full debug logs with any issue - all feedback, good and bad is welcome!

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(This post was last modified: 2012-04-06 19:19 by DDDamian.)
find quote
Aemstel Offline
Member
Posts: 82
Joined: Feb 2011
Reputation: 0
Post: #93
Fantastic DDDamian! Have time to do a quick test in an hour or so. Will let you know.
(This post was last modified: 2012-04-05 23:23 by Aemstel.)
find quote
Martijn Offline
Team Kodi
Posts: 11,434
Joined: Jul 2011
Reputation: 165
Location: Dawn of time
Post: #94
You will hear from me tomorrow Big Grin

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #95
Ahh great - the master of disaster is on the case Smile

Just an FYI folks - if you've ever installed XBMC on that machine you can uncheck installing DirectX and the Microsoft Visual C++ distributables - they only need installing once. Just saves time.

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
Dixon Butz Offline
Senior Member
Posts: 255
Joined: Dec 2010
Reputation: 3
Location: Hershey Highway
Post: #96
Still static when playing DTS FLAC's. They play with Daniella's build.

http://pastebin.com/P6nh16RB

Win7x64 Portable XBMC

PC connected to Denon AVR 1912 via HDMI
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #97
(2012-04-06 01:25)Dixon Butz Wrote:  Still static when playing DTS FLAC's. They play with Daniella's build.

http://pastebin.com/P6nh16RB

Win7x64 Portable XBMC

PC connected to Denon AVR 1912 via HDMI

As mentioned earlier, DTS-wav not supported yet. Maybe I'll tackle that next. Any other results?

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(This post was last modified: 2012-04-06 02:05 by DDDamian.)
find quote
Aemstel Offline
Member
Posts: 82
Joined: Feb 2011
Reputation: 0
Post: #98
Won't run at all here, get an immediate crash.

edit:

Tried again with a clean install and also in portable mode but still crashes immediately...
(This post was last modified: 2012-04-06 02:17 by Aemstel.)
find quote
Dixon Butz Offline
Senior Member
Posts: 255
Joined: Dec 2010
Reputation: 3
Location: Hershey Highway
Post: #99
(2012-04-06 01:27)DDDamian Wrote:  
(2012-04-06 01:25)Dixon Butz Wrote:  Still static when playing DTS FLAC's. They play with Daniella's build.

http://pastebin.com/P6nh16RB

Win7x64 Portable XBMC

PC connected to Denon AVR 1912 via HDMI

As mentioned earlier, DTS-wav not supported yet. Maybe I'll tackle that next. Any other results?

Nothing found yet. I tried DTS MA mkv, Dolby true ISO, DTS mkv. I dont have much time tonight.
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #100
(2012-04-06 02:14)Dixon Butz Wrote:  
(2012-04-06 01:27)DDDamian Wrote:  
(2012-04-06 01:25)Dixon Butz Wrote:  Still static when playing DTS FLAC's. They play with Daniella's build.

http://pastebin.com/P6nh16RB

Win7x64 Portable XBMC

PC connected to Denon AVR 1912 via HDMI

As mentioned earlier, DTS-wav not supported yet. Maybe I'll tackle that next. Any other results?

Nothing found yet. I tried DTS MA mkv, Dolby true ISO, DTS mkv. I dont have much time tonight.

Np - thx for testing. I assumed they worked well? Would also be great if you could test music out (audiophile mode, stereo to all channels, etc) whenever you have time. Appreciate your help - and have a nice weekend!

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(This post was last modified: 2012-04-06 02:32 by DDDamian.)
find quote
Dixon Butz Offline
Senior Member
Posts: 255
Joined: Dec 2010
Reputation: 3
Location: Hershey Highway
Post: #101
(2012-04-06 02:31)DDDamian Wrote:  
(2012-04-06 02:14)Dixon Butz Wrote:  
(2012-04-06 01:27)DDDamian Wrote:  As mentioned earlier, DTS-wav not supported yet. Maybe I'll tackle that next. Any other results?

Nothing found yet. I tried DTS MA mkv, Dolby true ISO, DTS mkv. I dont have much time tonight.

Np - thx for testing. I assumed they worked well?

Working fine.
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #102
(2012-04-06 02:32)Dixon Butz Wrote:  
(2012-04-06 02:31)DDDamian Wrote:  
(2012-04-06 02:14)Dixon Butz Wrote:  Nothing found yet. I tried DTS MA mkv, Dolby true ISO, DTS mkv. I dont have much time tonight.

Np - thx for testing. I assumed they worked well?

Working fine.

Great! Sync should be better too. Will look into DTS-wav next Smile

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
Dixon Butz Offline
Senior Member
Posts: 255
Joined: Dec 2010
Reputation: 3
Location: Hershey Highway
Post: #103
(2012-04-06 02:42)DDDamian Wrote:  
(2012-04-06 02:32)Dixon Butz Wrote:  
(2012-04-06 02:31)DDDamian Wrote:  Np - thx for testing. I assumed they worked well?

Working fine.

Great! Sync should be better too. Will look into DTS-wav next Smile

yeah sync is great! Watching a true hd iso atm.
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #104
(2012-04-06 02:46)Dixon Butz Wrote:  
(2012-04-06 02:42)DDDamian Wrote:  
(2012-04-06 02:32)Dixon Butz Wrote:  Working fine.

Great! Sync should be better too. Will look into DTS-wav next Smile

yeah sync is great! Watching a true hd iso atm.

awesome Smile should be much tighter. give everything a good workout and keep us posted as you do. glad it's all good - should sound pretty sweet if you play music too!

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #105
I rebuilt the installer and it installed now okay on the virgin test machine, so I've re-uploaded to GitHub with today's date and a note about the fixed installer. Not sure why it was looking for the xxxxxxxxd.dll's (development or debugging dlls) but a rebuild of the install package did the trick.

The package should be (and needs to be) self-contained, so the rebuild method is better than having to install local dlls.

I'll clean up the last bunch of posts just to get the thread back on track, but PM me if you have any install issues with the new installable I've just uploaded.

I'm updating the link in the previous post (will take 2sec) or you can just go here: https://github.com/downloads/DDDamian/xb...120406.zip

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
Post Reply