[RELEASE] Spotimc: Another Spotify music addon

  Thread Rating:
  • 30 Votes - 4.7 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
mazkolain Offline
Senior Member
Posts: 114
Joined: Mar 2012
Reputation: 13
Post: #106
(2012-04-03 21:44)Hitcher Wrote:  My main concern comes from the fact that I was about to push some changes and only noticed when comparing the diffs.

I thought that was the whole point of addons having a skin folder in the addon?

By the way, yours is labelled DefaultSkin when it should be simply Default I believe.
Sorry if any changes made by the addon went through. It probably crashed and the cleanup task did not have a chance to run.

(2012-04-04 14:15)coendeurloo Wrote:  Wow, first of all, thanks a million for this!

Second, I have a minor issue. I have loads of playlist, mainly albums. I have placed these in playlist folders, a function Spotify provides to make your playlists easily categorized and browsable. Is it possible to integrate this function into the plugin? It would certainly increase the user-friendliness! :-)
Yes, playlist folder support is planned. I know that is hard when you have 100+ playlists Tongue

(2012-04-04 14:32)dallasnights Wrote:  When is the new update coming out so we can test the playlist problem and hopefully it will be fixed

Thanks!
Hopefully I'll release the next alpha in a week, so be patient!

(2012-04-04 19:40)lr10 Wrote:  I figured it out. After studying the debug log I realised that I had CouchPotato running on the same port (8083). As soon as I changed the port for CouchPotato, Spotimc started working perfect.

Great job by the way. I love the addon!
Thanks for the report! Spotimc will try ports 8080-8089 on startup, switching them if they are in use. I'll try to reproduce the problem with CouchPotato enabled.
find quote
lr10 Offline
Junior Member
Posts: 8
Joined: May 2009
Reputation: 0
Location: Sweden
Post: #107
Quote:Thanks for the report! Spotimc will try ports 8080-8089 on startup, switching them if they are in use. I'll try to reproduce the problem with CouchPotato enabled.


Actually it turns out it might have been a combination of things then. Because after I closed CouchPotato I got the same problem again the next time I started up Spotimc. And then I switched the XBMC http server to 8070 and Spotimc started working again.
But since I've had CouchPotato, SickBeard, SABnzbd+ and XBMC running on port 8080-8083 that would explain a lot.
Well it's up and running again and thanks for the info.
find quote
Novin Offline
Senior Member
Posts: 218
Joined: Dec 2005
Reputation: 0
Location: Helsingborg, Sweden
Post: #108
Hi

Tried this because I want to get rid of the hassle of compiling spotyxbmc2.

The plugin starts, I enter my login details and I get to the home screen. From there, nothing works though. Nothing in news, in playlists, it just lists the number of playlists that I have (51) but I can't see them & search doesn't give any results.

System info:

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

XBMC 11.0~git20120321.14feb09-0ubuntu1~ppa1~oneiric

script.audio.spotimc-0.1-alpha4.zip
find quote
Spikey1989 Offline
Junior Member
Posts: 12
Joined: Dec 2011
Reputation: 0
Post: #109
(2012-03-28 20:26)mazkolain Wrote:  
(2012-03-26 21:50)Sambuccashake Wrote:  I can't seem to get it too launch. (Windows 7)

"Script failed" and then the spinning thing.

Reinstalled twice but no change.

http://pastebin.com/7yp7UZyB
Did you get if from the binary packages of the lower part of the download screen? The upper left links generate only a dump of the latest version in the repository, no binary dependencies included. Try uninstalling it first, and then get it from mortstar's repo.

(2012-03-26 23:53)baldsasquatch Wrote:  I get Script failed.  script.audio.spotify.  Then exits.
Mmm, would love to see a debug log. Hopefully it's a bug described earlier on this thread and a fix is on the works.

I give up, i have looked and look and cant find anything that helps me to get it to work.
i have downloaded the "Repositories Installer Addon" and installed "mortstar's repo" from there didnt work, i have only downloaded "mortar's repo" didnt work.
i have downloaded both "script.audio.spotimc-0.1-alpha3.zip" and "script.audio.spotimc-0.1-alpha4.zip" didnt work.
in every downloaded installation i get "Script failed:  script.audio.spotify."

i have looked up and down and cant find "Did you get if from the binary packages of the lower part of the download screen?" that anywhere.
if u tell me how to send a debug log i will do it but only on 1 installation. cause i have been trying all possible combintation for 2h now. so i wont do it again :/.

P.S.
(2012-03-28 22:23)Sambuccashake Wrote:  
Quote:Did you get if from the binary packages of the lower part of the download screen? The upper left links generate only a dump of the latest version in the repository, no binary dependencies included. Try uninstalling it first, and then get it from mortstar's repo.
Cheers, that did it!

Checking it out now, looks nice so far.

how did u do it?

thanks in advance
/Spikey
find quote
Varazir Offline
Junior Member
Posts: 37
Joined: Nov 2009
Reputation: 0
Post: #110
I uninstalled, restarted/rebooted the system then I could install it from the repo
find quote
Spikey1989 Offline
Junior Member
Posts: 12
Joined: Dec 2011
Reputation: 0
Post: #111
Sorry to say it, but it didnt work. not that i intended to try it, but pressed the wrong button once.

/Spikey
(This post was last modified: 2012-04-06 16:37 by Spikey1989.)
find quote
Laiton Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #112
Hello!

does spotimc work on OSX?
find quote
mazkolain Offline
Senior Member
Posts: 114
Joined: Mar 2012
Reputation: 13
Post: #113
(2012-04-05 22:52)Novin Wrote:  Hi

Tried this because I want to get rid of the hassle of compiling spotyxbmc2.

The plugin starts, I enter my login details and I get to the home screen. From there, nothing works though. Nothing in news, in playlists, it just lists the number of playlists that I have (51) but I can't see them & search doesn't give any results.

System info:

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

XBMC 11.0~git20120321.14feb09-0ubuntu1~ppa1~oneiric

script.audio.spotimc-0.1-alpha4.zip
Which skin are you using? Spotimc has some similar issues with Transparency on Linux, but they will be fixed with the new alpha I'm about to release. Anyway, please let me see a log file, just to be sure.

(2012-04-06 14:55)Spikey1989 Wrote:  I give up, i have looked and look and cant find anything that helps me to get it to work.
i have downloaded the "Repositories Installer Addon" and installed "mortstar's repo" from there didnt work, i have only downloaded "mortar's repo" didnt work.
i have downloaded both "script.audio.spotimc-0.1-alpha3.zip" and "script.audio.spotimc-0.1-alpha4.zip" didnt work.
in every downloaded installation i get "Script failed:  script.audio.spotify."

i have looked up and down and cant find "Did you get if from the binary packages of the lower part of the download screen?" that anywhere.
if u tell me how to send a debug log i will do it but only on 1 installation. cause i have been trying all possible combintation for 2h now. so i wont do it again :/.
Just run the addon and let it crash, and then you can send me the log file. This page explains where to find XBMC's log files: http://wiki.xbmc.org/index.php?title=Log_file#Location

(2012-04-06 20:01)Laiton Wrote:  Hello!

does spotimc work on OSX?
It does. Give it a try!
find quote
derchris Offline
Member
Posts: 64
Joined: Oct 2004
Reputation: 0
Post: #114
Thanks for the addon,

works like a charm, and much better then compiling a whole XBMC like spotyxbmc2
find quote
Spikey1989 Offline
Junior Member
Posts: 12
Joined: Dec 2011
Reputation: 0
Post: #115
(2012-04-06 21:09)mazkolain Wrote:  
(2012-04-06 14:55)Spikey1989 Wrote:  I give up, i have looked and look and cant find anything that helps me to get it to work.
i have downloaded the "Repositories Installer Addon" and installed "mortstar's repo" from there didnt work, i have only downloaded "mortar's repo" didnt work.
i have downloaded both "script.audio.spotimc-0.1-alpha3.zip" and "script.audio.spotimc-0.1-alpha4.zip" didnt work.
in every downloaded installation i get "Script failed:  script.audio.spotify."

i have looked up and down and cant find "Did you get if from the binary packages of the lower part of the download screen?" that anywhere.
if u tell me how to send a debug log i will do it but only on 1 installation. cause i have been trying all possible combintation for 2h now. so i wont do it again :/.
Just run the addon and let it crash, and then you can send me the log file. This page explains where to find XBMC's log files: http://wiki.xbmc.org/index.php?title=Log_file#Location

starts in about row 463: log file
this file has 3 dif trys. dont know how to seperate them: log file 2
(This post was last modified: 2012-04-07 13:22 by Spikey1989.)
find quote
Laiton Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #116
I try this on 2 different mac, and i get script failed then it freeze to that spinnig thing.

But anyway million thanks for this addon.

http://pastebin.com/UJqt4qUY my log file
(This post was last modified: 2012-04-07 12:58 by Laiton.)
find quote
Jan-Erik Offline
Junior Member
Posts: 40
Joined: Jan 2012
Reputation: 0
Wink  My experience with Spotimc
Post: #117
I was also tired of compiling spotyxbmc2 with mixed experiences, so was very happy when I discovered this add-on Big Grin

So far I have two things I like to fix (or maybe just me that don't know)

1. If I go out of Spotimc and eg. play som video I can't start Spotimc again. When I try to start the add-on I get the turning wheel and then script failed script.audio.spotimc. Have to restart XBMC to get it working again


15:43:46 T:3076520816 INFO: -->Python script returned the following error<--
15:43:46 T:3076520816 ERROR: Error Type: <class 'spotify.LibSpotifyError'>
15:43:46 T:3076520816 ERROR: Error Contents: Initialization of library failed
15:43:46 T:3076520816 ERROR: Traceback (most recent call last):
File "/home/xbmc/.xbmc/addons/script.audio.spotimc/default.py", line 83, in <module>
main(addon_dir)
File "/home/xbmc/.xbmc/addons/script.audio.spotimc/resources/libs/spotimcgui/__init__.py", line 190, in main
initially_unload_playlists=False,
File "/home/xbmc/.xbmc/addons/script.audio.spotimc/resources/libs/PyspotifyCtypes.egg/spotify/session.py", line 264, in __init__
spotify.handle_sp_error(err)
File "/home/xbmc/.xbmc/addons/script.audio.spotimc/resources/libs/PyspotifyCtypes.egg/spotify/__init__.py", line 20, in handle_sp_error
raise LibSpotifyError(msg)
LibSpotifyError: Initialization of library failed
15:43:46 T:3076520816 INFO: -->End of Python script error report<--

2. Using crossfade (8 sec) with good luck for my FLAC music files, but in Spotimc I get stutter in the last few sec when the next song start playing. If i change in the midle of a song the crossfade work as expected (fade down -> playing both -> fade up new song).


Linux 3.0.0-17-generic
XBMCbuntu
find quote
neoflex Offline
Senior Member
Posts: 120
Joined: May 2011
Reputation: 0
Post: #118
thanks a lot, it's very promising.
Compared to akezeke solution, it's less integrated and still lack some features but it has the big advantage of being a stand alone plugin.
Features request (sorry Tongue):

- add an "api" like the youtube plugin has (you can play a youtube video using the JSON api "VideoPlaylist.Add", { file: "plugin://plugin.video.youtube/?action=play_video&videoid=...@" }). When done, we will be able to integrate the plugin in xbmc web interfaces or imagine a lot of fancy stuff like greasemonkey scripts.

- build an /artist/albums/tracks tree from stars item. I love this feature from spotyXBMC Wink
find quote
disolo Offline
Junior Member
Posts: 12
Joined: Nov 2009
Reputation: 0
Post: #119
I just installed the plugin on an XBMCbuntu Eden install. It works great.

However, if I use it in conjunction with XBMC Commander (iOS remote control app), tracks only play for about 7-10 seconds before going to the next track.

Is anyone else having this issue or a similar issue?

Thanks.
find quote
Jan-Erik Offline
Junior Member
Posts: 40
Joined: Jan 2012
Reputation: 0
Post: #120
(2012-04-07 21:08)disolo Wrote:  I just installed the plugin on an XBMCbuntu Eden install. It works great.

However, if I use it in conjunction with XBMC Commander (iOS remote control app), tracks only play for about 7-10 seconds before going to the next track.

Is anyone else having this issue or a similar issue?

Thanks.

I have had problem with Spotify it self jumping to next track if it was some problem with streaming the track.
Had similar problem when using fast forward to much and when pressing play again sound strart to stutter and sometimes give up and jump to next track

(On a side track, when using fast forward playback time get lost sometimes and at the end of track playtime is higher than track time.)

Check your log to see if you have buffer underrun or CPU use issues
find quote
Post Reply