Artwork Downloader

  Thread Rating:
  • 12 Votes - 4.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Horiz0n Offline
Junior Member
Posts: 8
Joined: Apr 2004
Reputation: 0
Post: #556
Thanks for the reply, if that doesn't work I will probably just do a fresh install of beta2...oh well, I had the problem once you got rid of the logo downloader and went to artwork downloader, not sure why.
find quote
Martijn Offline
Team Kodi
Posts: 11,421
Joined: Jul 2011
Reputation: 165
Location: Dawn of time
Post: #557
Just pushed an update to repo that fixes the image selection dialog not showing and reporting nothing found for movies when there was actually artwork available

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
Martijn Offline
Team Kodi
Posts: 11,421
Joined: Jul 2011
Reputation: 165
Location: Dawn of time
Post: #558
(2012-04-21 15:27)detroitdr Wrote:  Thanks again if you're able to make it support many multipaths in the future.

:>

Getting the multipath set up was more work than actually fixing it Tongue
This will copy all the artwork downloaded to each multipath folder so they will be totally synced.

Please try it out and let me know it you encounter any bugs:
https://github.com/paddycarey/script.art.../downloads

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
(This post was last modified: 2012-04-25 20:36 by Martijn.)
find quote
simplykaje Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #559
I have recently installed XBMC Eden and Artwork Downloader. I have been successful in downloading artwork for movies but not for tvshows. TV shows are enabled in the settings. I am using it in portable mode, but I don't think that could be causing the issue. Please check out my LOG and hopefully its a quick fix.

I added a short snippet of what my NFO files look like.
find quote
Martijn Offline
Team Kodi
Posts: 11,421
Joined: Jul 2011
Reputation: 165
Location: Dawn of time
Post: #560
Same answer:
(2012-04-17 21:01)Martijn Wrote:  
(2012-04-17 20:24)rolapinou Wrote:  OK Martijn, here is my log enabling the debug mode in the script and then launching it : http://xbmclogs.com/show.php?id=1663
I also took a look at the rapport generated by Artwork Downloader and it is written that the "TVDB ID was not found" whereas I built my tvshows.nfo through a tool called MediaCompanion that relies on TVDB ... How strange. I'll follow that track.

Well it's pretty easy. MediaCompanion uses IMDB ids for tv shows and neither fanart.tv or tvdb support that so that's why I don't support those either.

So either you missed an option in MediaCompanion or it doesn't work correctly

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
Drazzilb Offline
Senior Member
Posts: 111
Joined: Dec 2010
Reputation: 0
Post: #561
Hello Martijn I'm not sure if this is an issue with your software (I doubt it) or just something I've ran across that is located somewhere else.

I'm using Latest Eden as well as Latest version of your addon. I'm using Xeebo as the Skin.

My question is that why when i choose to change the banner it won't update w/in xbmc. I can go to the individual folder and see that banner.jpg has changed from it's original to the new one I've selected. However XBMC doesn't reflect the changes.

The only way I've been able to force the changes is by totally rebuilding the database by rescanning all the information all over again. Now I'm not 100% sure if it's a xeebo issue or XBMC or your addon. Thoughts would be swell.. Thanks
find quote
necronomicon Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #562
I'm having a weird problem which seems to go beyond artwork downloader, but let me try to describe it anyways: For some reason, XBMC (dharma) has exported NFO files for TV shows with more than one show per NFO, when all of my TV shows are duly separated with the typical "[tv show name]/[season]/[episode]" format. At some point, this led Artwork Downloader (or it's predecesor) to download the wrong artwork on those folders.

Now, after upgrading to Eden I realized about this problem and I tried to fix it by manually modifying the NFO files and removing the incorrect artwork. The artwork on the folders is now correct, but for some reason my skin (Aeon Nox) continues to show the wrong artwork (e.g. clearart) for the show.

Is there some cache mechanism going on that I need to clear? Has somebody experienced this issue or it's just me?
find quote
Tomahawk Offline
Member
Posts: 68
Joined: Apr 2012
Reputation: 0
Post: #563
Hmmm, does anyone know why I'm getting the same logo applied to multiple movies?

For example, I have a bunch of movies stored on Hard Drive 1 in the same folder. I downloaded the logo for Iron Man, and now every movie in that folder has the Iron Man logo.

Same thing on Hard Drive 2. All the movies in there have the logo for The Losers.

Do I have to put every one of my movies in its own folder for logos to work properly? Or is there a workaround in the config settings?

I should note that I don't have this problem with TV shows, because all my TV shows are in their own folders.
find quote
Martijn Offline
Team Kodi
Posts: 11,421
Joined: Jul 2011
Reputation: 165
Location: Dawn of time
Post: #564
If you had read the add-on info or the wiki you should have know ALL movies need to be in SEPERATE folders.

No workaround

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
Tomahawk Offline
Member
Posts: 68
Joined: Apr 2012
Reputation: 0
Post: #565
(2012-05-01 22:40)Martijn Wrote:  If you had read the add-on info or the wiki you should have know ALL movies need to be in SEPERATE folders.

No workaround

Right -- thanks.
find quote
deh2k7 Offline
Donor
Posts: 441
Joined: Dec 2008
Reputation: 5
Post: #566
Martjin -

I have a question about the non-standard named TV season items, like TV Posters. It seems like skins are not supporting the new naming convention (perhaps there are some but I'm not using those skins so not sure). Is there any way to put on your request list AD download the items using the XBMC convention instead of the new convention you are using with AD?

I'm aware of the potential issues (need to have a library scraped for AD to work), but there are ways to force a rescrape without losing watched status that has been posted by the XBMC dev team previously. This way, one could scrape, run AD, possibly altering some of the artwork, and then for a rescrape to pick up the newly-downloaded artwork.

Love the addon, but season items is the one thing that's giving me some issues.
find quote
kryke Offline
Junior Member
Posts: 8
Joined: Apr 2012
Reputation: 0
Post: #567
Would it be possible to expand the centralize extrafanart folder option to separate folders based on source instead of just tv and movie? I have anime and regular television shows as separate sources and display them using a smart list as different categories. I would like to use the slideshow option but not have the two categories overlap.

Another idea is an option to append the series' title to the beginning of the centralized extrafanart so that it would be a bit easier to go in and manually move a series. If the option is enabled you'd end up with Its.Always.Sunny.in.Philadelphia.22212.jpg in the centralized folder instead of 22212.jpg.
find quote
detroitdr Offline
Member
Posts: 91
Joined: May 2009
Reputation: 0
Location: Canada
Post: #568
(2012-04-25 20:34)Martijn Wrote:  
(2012-04-21 15:27)detroitdr Wrote:  Thanks again if you're able to make it support many multipaths in the future.

:>

Getting the multipath set up was more work than actually fixing it Tongue
This will copy all the artwork downloaded to each multipath folder so they will be totally synced.

Please try it out and let me know it you encounter any bugs:
https://github.com/paddycarey/script.art.../downloads

Well..too funny.. I've been spending the last 2 days MANUALLY defrag'n all my TV shows to one directory. (Only at the letter E so far... this is going to take a long time)

HOWEVER now I have a problem.

If I had Castle (2009) on F/G/I/J/L drives.. I copied all files onto a newer drive Q
I deleted all artwork and files other then the .avi files.
I deleted the tv show from the library, CLEANED LIBRARY and then scanned Q drive to bring the single directory Castle (2009) tv show back into XBMC library.

When I run your artwork downloader from the castle tv show info screen it doesn't have any updates.

My guess is that there is a flag or cache someone that you are keeping track of which is why it doesn't donwload the artwork again??

(I've even tried to set the flag copy over and it still didn't grab any new artwork)

Also I've tried this with multiple tv shows that i've already copied over to a single directory.

Basically after I delete the artwork and move the TV show to another directory, your plugin won't download it again.

Is there not a way to clear "cache" and force a full download again. (Remember i did turn on over write flag in settings)

Thx
(This post was last modified: 2012-05-02 16:37 by detroitdr.)
find quote
Martijn Offline
Team Kodi
Posts: 11,421
Joined: Jul 2011
Reputation: 165
Location: Dawn of time
Post: #569
It keeps the database data for one hour before it refreshes so that might be the case.
I also noticed when testing the multipath that skins are not able to support it (in the quick test i did)

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
detroitdr Offline
Member
Posts: 91
Joined: May 2009
Reputation: 0
Location: Canada
Post: #570
Hi Martin,
I did read through your posts and did know about the 1 hour refresh.. but this is 24 hours later and xbmc closed and restarted.

Your debug log... I can turn it on, but where does it write to? i could send you that if you wish.
find quote
Post Reply