[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC

  Thread Rating:
  • 15 Votes - 4.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
cfriedberg Offline
Junior Member
Posts: 12
Joined: Dec 2009
Reputation: 0
Post: #871
New to XBMC, trying to get this to work using Eden on a rather new iMac. When I had the Add-on setting item OSX set to "No", Safari would open up and offer me to link the account, but I got a Script Failed error, when I have the OSX setting to "Yes", Safari doesn't launch. This is really the only thing preventing me from fully switching over to XBMC and would really appreciate any help. Thanks.
find quote
psionicsin Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #872
(2012-04-22 21:35)cfriedberg Wrote:  New to XBMC, trying to get this to work using Eden on a rather new iMac. When I had the Add-on setting item OSX set to "No", Safari would open up and offer me to link the account, but I got a Script Failed error, when I have the OSX setting to "Yes", Safari doesn't launch. This is really the only thing preventing me from fully switching over to XBMC and would really appreciate any help. Thanks.

See my topics on the previous page. We're working to iron this out now hopefully.
find quote
cfriedberg Offline
Junior Member
Posts: 12
Joined: Dec 2009
Reputation: 0
Post: #873
Thanks for the reply, I did read your fix on the prior page, I actually pulled the URL, it is

https://api-user.netflix.com/oauth/login?

and then in XBMC tried the authorization again, but I did not get the authorization screen (I am using Safari). Odd that if the Add On is set for No for OSX that the window pops up correctly, yet if it is set for Yes for OSX, it does not.

So I did try your fix, but it didn't work for me. Thanks again, looking forward to getting this working.
find quote
bengalih Offline
Senior Member
Posts: 117
Joined: Oct 2004
Reputation: 1
Post: #874
(2012-04-22 19:42)psionicsin Wrote:  
(2012-04-22 19:23)bengalih Wrote:  No idea...but first step would be a debug log...

http://pastebin.com/KGncmFVZ

Well I am not that well versed in reading the logs yet, especially from OSX machine, but it looks like your issue is in the line 776:

Code:
13:37:30 T:2954383360   ERROR: OpenDemuxStream - Error creating demuxer

Right back on page #1 of this thread someone is having the same errors:
http://forum.xbmc.org/showthread.php?tid...#pid664133

There is a response from Fekker indicating that something is not properly configured with your playercorefactory.xml file and the browser being used to initiate the launch of the link.

Take a look at that post and a few above it that describe the playercorefactory.xml...it shouldn't be too hard to figure out.


(2012-04-23 00:35)cfriedberg Wrote:  Thanks for the reply, I did read your fix on the prior page, I actually pulled the URL, it is

https://api-user.netflix.com/oauth/login?

and then in XBMC tried the authorization again, but I did not get the authorization screen (I am using Safari). Odd that if the Add On is set for No for OSX that the window pops up correctly, yet if it is set for Yes for OSX, it does not.

So I did try your fix, but it didn't work for me. Thanks again, looking forward to getting this working.

Again I say that the easiest solution may be to download and install a copy of XBMC 10 Dharma....if it works in there, it should generate a userinfo.txt file which you can copy to your 11 install. Or, you can probably just move the entirety of the XBMCFlicks folders from 10 to 11...but I think it is the userinfo file that is giving everyone so much trouble.

.peace out.
(This post was last modified: 2012-04-23 02:51 by bengalih.)
find quote
kobyboy Offline
Member
Posts: 75
Joined: Mar 2011
Reputation: 0
Post: #875
where is the link to download this addy?
find quote
silvetti Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #876
Hi,

I'm having the same issue as others... when i choose something to watch in Netflix it is launched in the background thru Safari but XBMC stays in the foreground :/

Any ideas ?

Using Eden and MacOSX Lion.
find quote
bengalih Offline
Senior Member
Posts: 117
Joined: Oct 2004
Reputation: 1
Post: #877
(2012-04-23 22:31)silvetti Wrote:  Hi,

I'm having the same issue as others... when i choose something to watch in Netflix it is launched in the background thru Safari but XBMC stays in the foreground :/

Any ideas ?

Using Eden and MacOSX Lion.

I don't see anyone else stating those problems...the current issues people have been discussing do not match your description. Perhaps you can point to the other posts where people report the same issues as you? If you can point to them, then you should probably read further in the thread - because a solution exists, it was most likely given to those users. If no solution was given, then you may be out of luck. :/

I have no way to test anything at this point on an OSX machine...I do have two suggestions however:

If, as you claim, Safari is properly launching your Netflix episode, it is just showing it in the background and keeping XBMC focused, you can try the following:

System > Settings > Video Output > Use a fullscreen window rather than true fullscreen.

Alternatively, you can try to set your playcorefactory.xml (see posts above) to use FireFox or Chrome instead of Safari...you may not have the issues with those browsers.

.peace out.
(This post was last modified: 2012-04-24 00:16 by bengalih.)
find quote
lestat1977uk Offline
Fan
Posts: 324
Joined: Jan 2009
Reputation: 1
Post: #878
Any progress with UK accounts?
find quote
war2die4 Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 2
Post: #879
Hi im having trouble with my instant queue, the tv shows dont show up unless I have the max items retrieved set to 200 which would be fine except its not retrieving all the tv shows or movies, most but not all. If I have it set to anything higher it just wont retrieve anything at all tv or movies and if set lower it gets movies but no tv shows. From what I can tell everything else works.

Im using eden.
find quote
xbmcsnapper Offline
Junior Member
Posts: 45
Joined: Nov 2011
Reputation: 1
Location: Vancouver
Post: #880
(2012-04-28 07:36)war2die4 Wrote:  Hi im having trouble with my instant queue

If you post your xbmc.log it would help others help you. Nod

(2012-04-23 03:10)kobyboy Wrote:  where is the link to download this addy?

https://github.com/spudsdude/XBMC-Flicks
(This post was last modified: 2012-04-28 08:45 by xbmcsnapper.)
find quote
tcat Offline
Junior Member
Posts: 4
Joined: Dec 2010
Reputation: 0
Location: Austin, TX
Sad  RE:
Post: #881
(2012-02-14 04:04)xekon Wrote:  the check marks that show which episodes you watched are not saving between restarts, so it only remembers which netflix episodes i've seen until i turn the computer off or reboot it, then nothing is checked.

could this be a file permissions problem or something? what should i check first?

Does anyone know why this is happening? I am having the same problem since upgrading to eden. It worked fine previously. I have searched the database and cannot find a fix anywhere. Sad
any info would be appreciated
thanks
Tcat
find quote
bengalih Offline
Senior Member
Posts: 117
Joined: Oct 2004
Reputation: 1
Post: #882
(2012-04-28 07:36)war2die4 Wrote:  Hi im having trouble with my instant queue, the tv shows dont show up unless I have the max items retrieved set to 200 which would be fine except its not retrieving all the tv shows or movies, most but not all. If I have it set to anything higher it just wont retrieve anything at all tv or movies and if set lower it gets movies but no tv shows. From what I can tell everything else works.

Im using eden.

I'm confirming similar issues with the Recently Watched queue. My Instant Queue is relatively small, so I haven't tested with this...but basically I have the same issue with Recently Watched...if I set it around 350 or so I have a high success rate with enumerating my episodes.

I am 99.9% sure this is actually a Netflix issue, and I say this for several reasons:

1) This was working without a problem on XBMC 11 with the same XBMCFlicks release just last week. Nothing has changed there.
2) I did a bunch of various tests with packet captures and the max items set to different values. I got the following response from the Netflix server on a rental_history/watched query:

After about 10 seconds of waiting with the max items set to 500:
{"error":true,"status":{"status_code":504,"message":"Gateway timeout"}}

or

{"status": {"message": "Filter threw Exception"}}

There have been some issues over the last couple weeks with various developers having problems with the API:
http://developer.netflix.com/forum/read/155908

So, this seems to be an issue with Netflix's servers either not being able to handle the load, improperly configured, or else they have been messing with the API code without proper quality control.

I have tested viewing my entire history from the Netflix site and it works - I can only assume they use the same APIs internally - so perhaps it is a network problem with their external servers (hence the Gateway Timeouts).

I think right now the only fix is to adjust the values down to lower numbers to prevent these problems. Unfortunately, for people with very large instant queues this is going to be a problem.

Also, this error doesn't happen 100% of the time...I can get it to enumerate larger sets if I keep retrying...but maybe a 10% rate if I try as many as 500.

At this point let's hope that Netflix gets their act together and fixes whatever is wrong. There is a technical fix for this, but I'm not good enough to implement it on my own...

Basically XBMCFlicks is requesting the full queue at a time...so that mean if your max results is set to 500, it will ask for 500. There is a way via the API to say send me 100 starting at 1, 100 starting at 101, 100 starting at 201, etc...until you get them all. I hope that Netflix is not going to require that.

I'd be curious as to others experiencing this problem with large Instant Queues if you have other Netflix devices (like XBOX, ROKU, etc) if you are also having problems. If not...I suspect those devices use an iterative query through the queue like mentioned above.

UPDATE: I did some more digging and it appears that the timeouts are coming from Mashery's servers. They seem to be the infrastructure that the Netflix API is built on, and serve as some sort of proxy. I have contacted their tech support to get some more information as to why this is occurring.

(2012-04-28 21:57)tcat Wrote:  
(2012-02-14 04:04)xekon Wrote:  the check marks that show which episodes you watched are not saving between restarts, so it only remembers which netflix episodes i've seen until i turn the computer off or reboot it, then nothing is checked.

could this be a file permissions problem or something? what should i check first?

Does anyone know why this is happening? I am having the same problem since upgrading to eden. It worked fine previously. I have searched the database and cannot find a fix anywhere. Sad
any info would be appreciated
thanks
Tcat

I have confirmed this is an issue as well. Works in Dharma, not in Eden. I've done a bit of research today as to the problem but I'm going to have to ask some developers who are smarter than me...

You will also find that the "W" key which toggles episodes watched or not is also not working.

The actual table in the .db file is being properly updated when an episode is watched, but this information is not being read back out.

My fear is that something in Eden has changed and the .html file links that XBMCFlicks generates are not being parsed anymore. If this is the case, there might not be much that can be done via the Add-on, and some changes might be required to XBMC. I will update back with what I find out.

.peace out.
(This post was last modified: 2012-04-29 06:46 by bengalih.)
find quote
war2die4 Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 2
Post: #883
Ah that makes me feel much better knowing its not just meSmile

Just to test it I set it to 300 and got no results for movies or tv but it did for all and it gave me 70 items more then I actually have in my queue (weird).

Well thanks for the input and hopefully they get that fixed soon.Wink
find quote
bengalih Offline
Senior Member
Posts: 117
Joined: Oct 2004
Reputation: 1
Post: #884
(2012-04-29 07:01)war2die4 Wrote:  Ah that makes me feel much better knowing its not just meSmile

Just to test it I set it to 300 and got no results for movies or tv but it did for all and it gave me 70 items more then I actually have in my queue (weird).

Well thanks for the input and hopefully they get that fixed soon.Wink

That is strange...I honestly don't use my instant queue that much...I have maybe 30 items in it... I usually only add some movies that I see while browsing. I tend to just pull it up out of the watched queue.

So, for me, everything is working fine...I get all 30 items in my instant queue...nothing more.

The fact that you are getting 70 other items is worrisome and I wonder if there is another problem you are having. Are those 70 items anything you recognize as having had in your queue or watched in the past, or are they totally random?

.peace out.
find quote
yeroc1982 Offline
Member
Posts: 60
Joined: Jan 2012
Reputation: 0
Post: #885
Say zip does not have correct structure.
find quote
Post Reply