Linux - Visual Effects in Ubuntu 12.04

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
TheFincher Offline
Junior Member
Posts: 40
Joined: Apr 2012
Reputation: 0
Post: #1
Evening

Upgraded to Ubuntu 12.04 over the weekend and have from 10.04 where I had the ability to go System > Preferences > Appearance > Visual Effects > None. Unfortunately that doesn't seem to exist in 12.04 and as a result when I play video it isn't as smooth as it should be. This is particularly noticeable when streaming content.

Long story short, is there a way I can disable these effects either from the desktop in Ubuntu 12.04 or from terminal somehow??
find quote
boosted Offline
Member
Posts: 61
Joined: Oct 2011
Reputation: 0
Location: New Zealand
Post: #2
(2012-04-30 21:16)TheFincher Wrote:  Evening

Upgraded to Ubuntu 12.04 over the weekend and have from 10.04 where I had the ability to go System > Preferences > Appearance > Visual Effects > None. Unfortunately that doesn't seem to exist in 12.04 and as a result when I play video it isn't as smooth as it should be. This is particularly noticeable when streaming content.

Long story short, is there a way I can disable these effects either from the desktop in Ubuntu 12.04 or from terminal somehow??

Have you had a look at the login screen. I think their is an option for Unity with no effects ie unity 2d
find quote
Pyromaniac Offline
Donor
Posts: 157
Joined: Mar 2012
Reputation: 1
Location: Germany
Post: #3
I would prefer Xubuntu or Lubuntu for XBMC-only Systems.
In Kubuntu you can disable effects with an shortcut or command-line, so you could create an starter for XBMC like this:
Quote:disable effects
start xbmc
enable effects
described here: http://ubuntuforums.org/showthread.php?t=1224822

But Ubuntu...with unity...I don't know if someone really likes it, but in my opinion its an 100% fail. I can't find anything positive in it...(not restricted to XBMC-Systems)
find quote
WonderStivi Offline
Junior Member
Posts: 19
Joined: Apr 2009
Reputation: 0
Post: #4
Use Unity 2D. And if you have an nVidia video card, run sudo nvidia-xconfig --no-composite.
find quote
TheFincher Offline
Junior Member
Posts: 40
Joined: Apr 2012
Reputation: 0
Post: #5
I don't have a login screen. Boots straight to the desktop..... How do I access unity 2D if this is the case?
find quote
TheFincher Offline
Junior Member
Posts: 40
Joined: Apr 2012
Reputation: 0
Post: #6
(2012-05-01 14:27)WonderStivi Wrote:  Use Unity 2D. And if you have an nVidia video card, run sudo nvidia-xconfig --no-composite.

Running that line in terminal lost all my icons on the desktop and my sidebar so I ran xbmc from terminal and sure enough it worked like a charm. I boot in to XBMC so is there anyway I can do whatever that did permanently but with keeping my side bar in Ubuntu when I exit from XBMC or am I asking for the earth??
find quote
TheFincher Offline
Junior Member
Posts: 40
Joined: Apr 2012
Reputation: 0
Post: #7
Seems I spoke a bit too soon. Whilst the RSS feed in XBMC is smooth now the video is still not 100%, think I need to bootup in 2D but can't see how to do this
find quote
boosted Offline
Member
Posts: 61
Joined: Oct 2011
Reputation: 0
Location: New Zealand
Post: #8
(2012-05-01 20:08)TheFincher Wrote:  Seems I spoke a bit too soon. Whilst the RSS feed in XBMC is smooth now the video is still not 100%, think I need to bootup in 2D but can't see how to do this

The Unity Greeter (the LightDM login screen) uses a new session chooser dialog which displays the logo for each desktop environment.
Just log out and select Unity 2d and log in

http://www.webupd8.org/2012/04/ubuntu-12...s-new.html
(This post was last modified: 2012-05-01 23:17 by boosted.)
find quote
TheFincher Offline
Junior Member
Posts: 40
Joined: Apr 2012
Reputation: 0
Post: #9
Not seen that screen. Will give it a whirl tomorrow. Wonder how that affects booting in to XBMC on startup?
find quote
TheFincher Offline
Junior Member
Posts: 40
Joined: Apr 2012
Reputation: 0
Post: #10
Hmmmmm. Tried every login option and it's still jerky. It's hard to describe the exact problem but i suppose the best way is that it just doesn't play smoothly, like the processor is always trying to catch up with itself.

Any other ideas?
find quote
boosted Offline
Member
Posts: 61
Joined: Oct 2011
Reputation: 0
Location: New Zealand
Post: #11
(2012-05-02 16:22)TheFincher Wrote:  Hmmmmm. Tried every login option and it's still jerky. It's hard to describe the exact problem but i suppose the best way is that it just doesn't play smoothly, like the processor is always trying to catch up with itself.

Any other ideas?

Have you had a look to see what the load is on the CPU at idle or in xbmc, also RAM. Is it using the swap all the time?
Did you upgrade from 10.04 or is it a fresh install?
What are the specs of your system?
What does 'glxgears' give you, you might need to install 'mesa-utils'
Post your '/etc/X11/xorg.conf'
find quote