Windows - Can't get IMDB to scrape correct info

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #1
I have previously posted this issue but still have not found a solution. I know what the problem is but can't find a solution even tho it seems very simple.

I have IMDB and TMDb both enabled to scrape movie information. IMDB gets the info for most films but films with original releases in another language it struggles with, it either chooses its foreign name or just fails to find the info altogether.

The problem is that it is using akas.imdb.com rather than imdb.com despite my language being set to usa/international and the "keep original titles" unselected. I know it's using akas because I searched the site for films it fails on and it comes up with the same results but imdb.com comes up with the correct usa/international (english) titles.

The problem only started when i had the pre eden release (from xbmc.org) and put it into portable mode, it has persisted even tho I have now installed Eden 11 (from xbmc.org)

I have looked in the xbmc folder and looked at any files corresponding to IMDB I opened up some of the files in wordpad and just as i thought any mention of imdb is akas.imdb. so i deleted the akas part from these files but the problem persists.

Sad it's very annoying!

Anyone know of a cure?
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #2
How do you unselect "keep original title"?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #3
(2012-05-02 19:41)sho Wrote:  How do you unselect "keep original title"?

In the TMDB settings in system> addons> movie info> TMDB . I don't know why i mentioned this cus it shouldn't affect imdb. but yeah my language in the imdb settings is USA/International rather than "keep original"
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #4
There is a similar setting for IMdB that you might want to look into

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #5
(2012-05-02 19:57)sho Wrote:  There is a similar setting for IMdB that you might want to look into

Wheres this? I can only find "prefer title language" from which is what i said above that i've changed to USA/International

* I've just deleted the imdb files somewhere within the portable folder so imdb suggested an update so i tok it and it's still scraping akas. Something is telling it to search akas. someone must know what tells it to search either akas.imdb or imdb
(This post was last modified: 2012-05-02 20:15 by DanTheHam.)
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #6
You managed to confuse me there with that TMDB talk, the setting I am talking about is "preferred title language from" which you seem to have correct.
Can you give us examples of movies giving issues?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #7
(2012-05-02 22:29)sho Wrote:  You managed to confuse me there with that TMDB talk, the setting I am talking about is "preferred title language from" which you seem to have correct.
Can you give us examples of movies giving issues?

ah sorry, I confused myself to, all the settings I can find are correct :/. go on akas.imdb yourself to see how it's affected if you like, i don't see how me saying will help but here goes. All studio ghilbi can't find the title name so I pick a a foreign name which is sometimes the right film with English description but foreign cover and artwork. Pans labyrinth displays as labyrinth (manual search doesn't find the correct one). The good the bad and the ugly only finds a documentary on it. etc. All foreign films that now have international titles too come up as the original title with no other option.
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #8
Edit: I see what you mean, the scraper returns the original title and is then not able to match it to the US/international title you send. (I seriously doubt that the akas is responsible though).
You then have to know the original title to be able to manually refresh them.
I am sure Olympia has a perfectly good explanation, now I just need to get him here.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
(This post was last modified: 2012-05-02 23:14 by sho.)
find quote
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #9
(2012-05-02 23:03)sho Wrote:  Edit: I see what you mean, the scraper returns the original title and is then not able to match it to the US/international title you send. (I seriously doubt that the akas is responsible though).
You then have to know the original title to be able to manually refresh them.
I am sure Olympia has a perfectly good explanation, now I just need to get him here.

I've already said I know it is akas as the files say it is scraping everything from akas.imdb.com. check the website if you don't believe me too. and knowing the original title sometimes isn't enough as I said above too The good the bad and the ugly is a film with original language in English and Pans labyrinth doesn't give a manual search option for the correct title only labyrinth. Sorry but there's no point in replying if you haven't read what I've posted, i'm looking for an answer not understanding.
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #10
(2012-05-03 00:02)DanTheHam Wrote:  The good the bad and the ugly is a film with original language in English
Oh no... Ever heard the term Spaghetti Western?

(2012-05-03 00:02)DanTheHam Wrote:  and Pans labyrinth doesn't give a manual search option for the correct title only labyrinth. Sorry but there's no point in replying if you haven't read what I've posted, i'm looking for an answer not understanding.
It sure does (refresh, manual). Looks like the understanding might need to come from a different direction.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
(This post was last modified: 2012-05-03 00:10 by sho.)
find quote
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #11
(2012-05-03 00:08)sho Wrote:  
(2012-05-03 00:02)DanTheHam Wrote:  The good the bad and the ugly is a film with original language in English
Oh no... Ever heard the term Spaghetti Western?

(2012-05-03 00:02)DanTheHam Wrote:  and Pans labyrinth doesn't give a manual search option for the correct title only labyrinth. Sorry but there's no point in replying if you haven't read what I've posted, i'm looking for an answer not understanding.
It sure does (refresh, manual). Looks like the understanding might need to come from a different direction.

My bad I thought that was american, I haven't got round to watching it yet. well it's definetly an akas problem cus it's only foreign titles. I just need to find out what tells the Imdb scraper to use akas cus it's obviously not listening to my preferences. It is pretty odd that it persisted even after deleted the imdb files then updates them again.
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #12
XBMC has always used akas... nothing else, your preferences have nothing to do with this.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
DanTheHam Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #13
(2012-05-03 00:47)sho Wrote:  XBMC has always used akas... nothing else, your preferences have nothing to do with this.

I don't get what your saying? So are you saying everyone gets this problem? surely it makes sense for it to only use akas if you select "prefer original title"? so the language preference is irrelevant?
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #14
yes, akas is not used for that reason.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
sho Offline
Team-XBMC Member
Posts: 4,130
Joined: May 2004
Reputation: 3
Post: #15
I see you have been through this before and have a way of rubbing people the wrong way.
http://forum.xbmc.org/showthread.php?tid=120888

live long and prosper.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Post Reply