StreamOn Video Addon

  Thread Rating:
  • 4 Votes - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
shaktoo Offline
Posting Freak
Posts: 870
Joined: Mar 2010
Reputation: 6
Location: Surrey
Post: #181
@ncube2 ; you are on atv2 & using openelec ... my instructions are for windows build / xbmc . Furthermore if you are having issuess with getting the addon from repo then why not directly install the addon from the zip on the first page as suggested ! Patience is a virtue .. especially regarding opensource freeware
find quote
ncube2 Offline
Member
Posts: 56
Joined: Apr 2012
Reputation: 0
Post: #182
@shawon
I cannot access that URL from my PC, not sure why ? So u think that's what my issue is with empty listings ?

@shaktoo
Openelec is Linux based OS with XBMC built into it. I installed just the plugin 1.08 version but i get a script error that way. And when i go thru the Repo i get empty listing. So i am clueless as to what's going on. So hoping someone can crack this. I don't think i can go about un-installing/re-installing OpenElec at this time to start fresh. Thanks all for helping out though.

@Chatoor
You seem to have similar issues as mine.. What OS are you on buddy and let me know if u fix this.
(This post was last modified: 2012-10-20 01:40 by ncube2.)
find quote
shawonmq Offline
Senior Member
Posts: 212
Joined: Jun 2012
Reputation: 8
Post: #183
@ncube

The reason Chatoor was having issues was that he had StreamOn repo 1.0 which was not built properly..And he didn't manage to remove the repo from xbmc completely.
In your case your network could be behind some proxy or you may need one...figure out how u can access that xml link from your pc..if you figure that out you may find a solution to your problem..
And script error is due to Urlresolver.
See if http://mirrors.xbmc.org/addons/eden/scri...-1.0.3.zip one helps u in any way..
BTW have u installed Maxmusterman repo as I suggested from the posted link?
Guys
What's your opinion on upgraded DRulez in StreamOn? I know there is "next page" missing..I need to code that.
But apart from that how is the access experience...Your opinion will help me understand what to be changed...Personally I don't use them much..
(This post was last modified: 2012-10-20 03:09 by shawonmq.)
find quote
chatoorchand Offline
Member
Posts: 65
Joined: Aug 2012
Reputation: 1
Post: #184
Guys have done everything to the last step ...including deleting addon15.db, manually uninstalling and re-installing both max and streamon repo in above described fashion, still getting empty repo and on installing the plugin itself 1.0.8 am getting script error here is the error report


22:00:42 T:3172 DEBUG: ParentPath = [addons://sources/video/]
22:00:42 T:2052 DEBUG: Thread Jobworker start, auto delete: 1
22:00:42 T:3864 DEBUG: CImageLoader::DoWork - took 1834 ms to load special://skin/backgrounds/search/search.jpg
22:00:42 T:3864 DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin StreamOn('plugin://plugin.video.StreamOn/','0','')
22:00:42 T:3864 INFO: initializing python engine.
22:00:42 T:3864 DEBUG: new python thread created. id=10
22:00:42 T:3864 DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - waiting on the StreamOn plugin...
22:00:42 T:2632 DEBUG: Thread XBPyThread start, auto delete: 0
22:00:42 T:2632 DEBUG: Python thread: start processing
22:00:42 T:2632 NOTICE: -->Python Interpreter Initialized<--
22:00:42 T:2632 DEBUG: XBPyThread::Process - The source file to load is C:\Users\XXXX\AppData\Roaming\XBMC\addons\plugin.video.StreamOn\default.py
22:00:42 T:2632 DEBUG: XBPyThread::Process - Setting the Python path to C:\Users\XXXX\AppData\Roaming\XBMC\addons\plugin.video.StreamOn;C:\Users\XXXX\Ap​pData\Roaming\XBMC\addons\script.module.xbmcswift\lib;C:\Users\XXXX\AppData\Roam​ing\XBMC\addons\script.module.t0mm0.common\lib;C:\Users\XXXX\AppData\Roaming\XBM​C\addons\script.module.cryptopy\lib;C:\Users\XXXX\AppData\Roaming\XBMC\addons\sc​ript.module.demjson\lib;C:\Program Files\XBMC\addons\script.module.simplejson\lib;C:\Users\XXX\AppData\Roaming\XBMC​\addons\script.module.turtle\lib;C:\Users\XXX\AppData\Roaming\XBMC\addons\script​.module.beautifulsoup\lib;C:\Program Files\XBMC\addons\script.module.pil\lib;C:\Users\XXXX\AppData\Roaming\XBMC\addon​s\script.common.plugin.cache\lib;C:\Users\XXXX\AppData\Roaming\XBMC\addons\scrip​t.module.simple.downloader\lib;C:\Users\XXX\AppData\Roaming\XBMC\addons\script.m​odule.free.cable.database\lib;C:\Users\XXX\AppData\Roaming\XBMC\addons\script.mo​dule.coveapi\lib;C:\Users\XXX\AppData\Roaming\XBMC\addons\script.module.urlresol​ver\lib;C:\Users\xxxxx\AppData\Roaming\XBMC\addons\script.module.mechanize\lib;C​:\Users\XXX\AppData\Roaming\XBMC\addons\script.module.parsedom\lib;C:\Users\XXX\​AppData\Roaming\XBMC\addons\script.module.elementtree\lib;C:\Program Files\XBMC\addons\script.module.pysqlite\lib;C:\Users\XXX\AppData\Roaming\XBMC\a​ddons\script.module.metahandler\lib;C:\Program Files\XBMC\system\python\DLLs;C:\Program Files\XBMC\system\python\Lib;C:\Program Files\XBMC\python26.zip;C:\Program Files\XBMC\system\python\lib\plat-win;C:\Program Files\XBMC\system\python\lib\lib-tk;C:\Program Files\XBMC;C:\Program Files\XBMC\system\python;C:\Program Files\XBMC\system\python\lib\site-packages;
22:00:42 T:2632 DEBUG: XBPyThread::Process - Entering source directory C:\Users\XXX\AppData\Roaming\XBMC\addons\plugin.video.StreamOn
22:00:42 T:2632 DEBUG: Instantiating addon using automatically obtained id of "plugin.video.StreamOn" dependent on version 2.0 of the xbmc.python api
22:00:43 T:3172 DEBUG: ------ Window Init (DialogBusy.xml) ------
22:00:43 T:2632 DEBUG: urlresolver: adding plugin dir: C:\Users\XXX\AppData\Roaming\XBMC\addons\script.module.urlresolver\lib\urlresolv​er\plugins
22:00:43 T:2632 DEBUG: urlresolver: registering plugin: 180upload (OneeightyuploadResolver), as: UrlResolver (P=100)
22:00:43 T:2632 DEBUG: urlresolver: registering plugin: 180upload (OneeightyuploadResolver), as: PluginSettings (P=100)
22:00:43 T:2632 DEBUG: urlresolver: registering plugin: 2gbhosting (TwogbhostingResolver), as: UrlResolver (P=100)
22:00:43 T:2632 DEBUG: urlresolver: registering plugin: 2gbhosting (TwogbhostingResolver), as: PluginSettings (P=100)
22:00:43 T:2632 DEBUG: urlresolver: registering plugin: daclips (DaclipsResolver), as: UrlResolver (P=100)
22:00:43 T:2632 DEBUG: urlresolver: registering plugin: daclips (DaclipsResolver), as: PluginSettings (P=100)
22:00:44 T:2632 DEBUG: urlresolver: registering plugin: dailymotion (DailymotionResolver), as: UrlResolver (P=100)
22:00:44 T:2632 DEBUG: urlresolver: registering plugin: dailymotion (DailymotionResolver), as: PluginSettings (P=100)
22:00:44 T:2632 DEBUG: urlresolver: registering plugin: divxstage (DivxstageResolver), as: UrlResolver (P=100)
22:00:44 T:2632 DEBUG: urlresolver: registering plugin: divxstage (DivxstageResolver), as: PluginSettings (P=100)
22:00:44 T:2632 DEBUG: urlresolver: registering plugin: override_me (hostingbulkResolver), as: PluginSettings (P=100)
22:00:45 T:2632 DEBUG: urlresolver: registering plugin: zshare (ZshareResolver), as: UrlResolver (P=100)
22:00:45 T:2632 DEBUG: urlresolver: registering plugin: zshare (ZshareResolver), as: PluginSettings (P=100)
22:00:45 T:2632 NOTICE: addon started with mode: None
22:00:45 T:2632 NOTICE: Starting build_show_directory() with url: http://streamon.hostizzo.com/public_html...categories
22:00:45 T:2632 NOTICE: playmode is: 0
22:00:45 T:3864 INFO: Loading skin file: DialogProgress.xml
22:00:45 T:3788 DEBUG: CImageLoader::DoWork - took 6579 ms to load special://masterprofile/Thumbnails/a/a3393491.jpg
22:00:46 T:316 DEBUG: CImageLoader::DoWork - took 6571 ms to load special://skin/backgrounds/search/search.jpg
22:00:46 T:3864 DEBUG: DialogProgress::StartModal called
22:00:46 T:3864 DEBUG: ------ Window Init (DialogProgress.xml) ------
22:00:48 T:172 DEBUG: CImageLoader::DoWork - took 399 ms to load special://skin/backgrounds/search/globalsearch2.jpg
22:00:56 T:3788 DEBUG: CImageLoader::DoWork - took 245 ms to load special://skin/backgrounds/search/search.jpg
22:01:00 T:3172 INFO: XCURL::DllLibCurlGlobal::CheckIdle - Closing session to http://feeds.feedburner.com (easy=00625F90, multi=004A7DA0)
22:01:04 T:2052 DEBUG: CImageLoader::DoWork - took 634 ms to load special://skin/backgrounds/search/globalsearch2.jpg
22:01:06 T:2632 INFO: -->Python script returned the following error<--
22:01:06 T:2632 ERROR: Error Type: <class 'urllib2.URLError'>
22:01:06 T:2632 ERROR: Error Contents: <urlopen error [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond>
22:01:06 T:2632 ERROR: Traceback (most recent call last):
File "C:\Users\XXX\AppData\Roaming\XBMC\addons\plugin.video.StreamOn\default.py", line 1022, in <module>
build_show_directory(__rooturl__)
File "C:\Users\XXXX\AppData\Roaming\XBMC\addons\plugin.video.StreamOn\default.py", line 498, in build_show_directory
items = getItemsFromUrl(origurl)
File "C:\Users\XXX\AppData\Roaming\XBMC\addons\plugin.video.StreamOn\default.py", line 795, in getItemsFromUrl
file = urllib2.urlopen(url, timeout=140)
File "C:\Program Files\XBMC\system\python\Lib\urllib2.py", line 126, in urlopen
return _opener.open(url, data, timeout)
File "C:\Program Files\XBMC\system\python\Lib\urllib2.py", line 391, in open
response = self._open(req, data)
File "C:\Program Files\XBMC\system\python\Lib\urllib2.py", line 409, in _open
'_open', req)
File "C:\Program Files\XBMC\system\python\Lib\urllib2.py", line 369, in _call_chain
result = func(*args)
File "C:\Program Files\XBMC\system\python\Lib\urllib2.py", line 1170, in http_open
return self.do_open(httplib.HTTPConnection, req)
File "C:\Program Files\XBMC\system\python\Lib\urllib2.py", line 1145, in do_open
raise URLError(err)
URLError: <urlopen error [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond>
22:01:06 T:2632 INFO: -->End of Python script error report<--
find quote
shawonmq Offline
Senior Member
Posts: 212
Joined: Jun 2012
Reputation: 8
Post: #185
@ncube and chatoot what are your geo location?
Look like you dont have access to streamon server. Its nothing with repo or urlresolver.
find quote
chatoorchand Offline
Member
Posts: 65
Joined: Aug 2012
Reputation: 1
Post: #186
I am in US..and streamOn used to work fine before, not sure how would it change now (since location is same)
find quote
binder420 Offline
Member
Posts: 64
Joined: Aug 2012
Reputation: 0
Post: #187
some of the channels such as colors under desirulez is not working
when i click on channel color and then on show like big boss i get script error
it was working fine before the update happen
please fix it as colors have some of my favorite shows
thank you so much
and great add on
find quote
shawonmq Offline
Senior Member
Posts: 212
Joined: Jun 2012
Reputation: 8
Post: #188
@binder
Is the error occurs only when on specific episode or the whole Big boss show?
@chatoor
Have u tried opening the link I posted ?
http://shawonrepo.hostizzo.com/public_html/addons.xml
See if u r able to open it..
And location/server is changed..perhaps u missed the msg in the board ...last server was suspended due to excessive usage..I can't afford paid server..So I had to change to another server.
(This post was last modified: 2012-10-20 13:38 by shawonmq.)
find quote
shaktoo Offline
Posting Freak
Posts: 870
Joined: Mar 2010
Reputation: 6
Location: Surrey
Post: #189
shawonmq.. the new desirulez is great ! working links nearly 100% . there are certain links but maybe thats very old links ( like the 1st epiosde of an old serial ). One thing is the play all link certainly dosent work but if i play individually they are working ... I am happy.. Thank you

@ cahtoor & ncube2... dude I Wish that what I tried could have helped you but really all I could say is dont give up.. try and do this again, and again, thats what I did.check your firewall maybe firewall is blocking this ? hope you guys sort it out .
find quote
binder420 Offline
Member
Posts: 64
Joined: Aug 2012
Reputation: 0
Post: #190
(2012-10-20 13:06)shawonmq Wrote:  @binder
Is the error occurs only when on specific episode or the whole Big boss show?
@chatoor
Have u tried opening the link I posted ?
http://shawonrepo.hostizzo.com/public_html/addons.xml
See if u r able to open it..
And location/server is changed..perhaps u missed the msg in the board ...last server was suspended due to excessive usage..I can't afford paid server..So I had to change to another server.

when i click on big boss 6
it says retrieving and then it doesn't go past 0
and i get script failed error
it wont even fetch any episode now
i tried it both on windows 7 and atv 2
same problem
now i cant even open any shows
i get script error
(This post was last modified: 2012-10-20 21:17 by binder420.)
find quote
binder420 Offline
Member
Posts: 64
Joined: Aug 2012
Reputation: 0
Post: #191
(2012-10-20 21:13)binder420 Wrote:  
(2012-10-20 13:06)shawonmq Wrote:  @binder
Is the error occurs only when on specific episode or the whole Big boss show?
@chatoor
Have u tried opening the link I posted ?
http://shawonrepo.hostizzo.com/public_html/addons.xml
See if u r able to open it..
And location/server is changed..perhaps u missed the msg in the board ...last server was suspended due to excessive usage..I can't afford paid server..So I had to change to another server.

when i click on big boss 6
it says retrieving and then it doesn't go past 0
and i get script failed error
it wont even fetch any episode now
i tried it both on windows 7 and atv 2
never mind
i uninstall and reinstalled the plugin and everything working now
sorry for the trouble
thank you for all ur hard work in making such a nice plugin
ur awsome
same problem
now i cant even open any shows
i get script error


never mind
i uninstall and reinstalled the plugin and everything working now
sorry for the trouble
thank you for all ur hard work in making such a nice plugin
ur awsome
(This post was last modified: 2012-10-20 21:30 by binder420.)
find quote
chatoorchand Offline
Member
Posts: 65
Joined: Aug 2012
Reputation: 1
Post: #192
@chatoor
Have u tried opening the link I posted ?
http://shawonrepo.hostizzo.com/public_html/addons.xml
See if u r able to open it..
And location/server is changed..perhaps u missed the msg in the board ...last server was suspended due to excessive usage..I can't afford paid server..So I had to change to another server.
[/quote]

Unfortunately I am not able to open the http link even from my browser, could that be issue?
find quote
shawonmq Offline
Senior Member
Posts: 212
Joined: Jun 2012
Reputation: 8
Post: #193
@chatoor
Well u need to use a proxy...see your pm..and upgrade your addon
find quote
chatoorchand Offline
Member
Posts: 65
Joined: Aug 2012
Reputation: 1
Post: #194
(2012-10-21 02:41)shawonmq Wrote:  @chatoor
Well u need to use a proxy...see your pm..and upgrade your addon

Yup it did work, thanks mate, send u a pm too
find quote
apnadesi Offline
Junior Member
Posts: 44
Joined: Sep 2012
Reputation: 1
Post: #195
(2012-10-21 02:49)chatoorchand Wrote:  
(2012-10-21 02:41)shawonmq Wrote:  @chatoor
Well u need to use a proxy...see your pm..and upgrade your addon

Yup it did work, thanks mate, send u a pm too

I am having this same issue as Chatoor. Can you please send me info on how to use the proxy?

Thanks!
find quote
Post Reply